]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blobdiff - kde4-kdebase-runtime.spec
- man fix
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
index d69d4b1507175e48f05b6a7ee4f4087e0034aecb..1ad2a73b1754775b49df0adfada872fa20afd10d 100644 (file)
@@ -2,24 +2,27 @@
 # - l10n != %lang glibc locales (et = etiopia not estonia!)
 #
 # Conditional build:
-#
+%bcond_with    ntrack  #  disabled due to https://bugs.launchpad.net/bugs/1115449
+
 %define                _state          stable
 %define                orgname         kde-runtime
-%define                qtver           4.8.1
+%define                qtver           4.8.3
 %define                atticaver       0.2.0
 
 Summary:       KDE 4 base runtime components
 Summary(pl.UTF-8):     Komponenty uruchomieniowe podstawowej części KDE 4
 Name:          kde4-kdebase-runtime
-Version:       4.9.2
+Version:       4.10.4
 Release:       1
 License:       GPL
 Group:         X11/Applications
 Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
-# Source0-md5: e5d8bcef6082478fe58d43471f4a6845
+# Source0-md5: 979626f3f5f3b9fa69bab828cd1694e4
 Source1:       kdebase-searchproviders.tar.bz2
 # Source1-md5: 126c3524b5367f5096a628acbf9dc86f
 Source2:       l10n-iso639-1
+Source3:       battery.svgz
+# Source3-md5: 5e8154256c2941b74ed17b0bf18c753d
 Patch100:      %{name}-branch.diff
 Patch0:                %{name}-rpc.patch
 URL:           http://www.kde.org/
@@ -33,6 +36,7 @@ BuildRequires:        cmake >= 2.8.0
 BuildRequires: docbook-dtd42-xml
 BuildRequires: docbook-style-xsl
 BuildRequires: exiv2-devel >= 0.18.2
+BuildRequires: kde4-kactivities-devel >= %{version}
 BuildRequires: kde4-nepomuk-core >= %{version}
 BuildRequires: kde4-kdelibs-devel >= %{version}
 BuildRequires: kde4-kdepimlibs-devel >= %{version}
@@ -43,7 +47,7 @@ BuildRequires:        libsmbclient-devel
 BuildRequires: libssh-devel >= 1:0.4.0
 BuildRequires: libtirpc-devel
 BuildRequires: kde4-nepomuk-core-devel
-BuildRequires: ntrack-devel
+%{?with_ntrack:BuildRequires:  ntrack-devel}
 BuildRequires: openslp-devel
 BuildRequires: phonon-devel >= 4.4.3
 BuildRequires: pkgconfig
@@ -102,6 +106,7 @@ Wtyczki KDE 4 dla Phonona.
 install -d build
 cd build
 %cmake \
+       %{!?with_ntrack:-DQNTRACK=BOOL:FALSE} \
        -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
        ../
 
@@ -117,6 +122,12 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
 
+%if "%{version}" > "4.11"
+echo "4.11 contains new battery so drop SOURCE3"
+exit 1
+%endif
+install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/apps/desktoptheme/default/icons/battery.svgz
+
 collect_l10n_files() {
        while read country language comment; do
                [ "$country" != "#" ] || continue
@@ -238,6 +249,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
+%attr(755,root,root) %{_libdir}/kde4/kio_tags.so
 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
 %attr(755,root,root) %{_libdir}/kde4/kio_timeline.so
 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
@@ -282,6 +294,7 @@ rm -rf $RPM_BUILD_ROOT
 #%attr(755,root,root) %{_libdir}/kde4/libexec/klocaldomainurifilterhelper
 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
+%{_libdir}/kde4/platformimports
 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
@@ -381,6 +394,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/sftp.protocol
 %{_datadir}/kde4/services/smb.protocol
 %{_datadir}/kde4/services/svgthumbnail.desktop
+%{_datadir}/kde4/services/tags.protocol
 %{_datadir}/kde4/services/tar.protocol
 %{_datadir}/kde4/services/textthumbnail.desktop
 %{_datadir}/kde4/services/thumbnail.protocol
@@ -466,8 +480,9 @@ rm -rf $RPM_BUILD_ROOT
 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
 %lang(en) %{_kdedocdir}/en/knetattach
 %lang(en) %{_kdedocdir}/en/network
-%lang(en) %{_mandir}/man1/kdesu.1*
-%lang(en) %{_mandir}/man8/nepomuk*.8*
+%{_mandir}/man1/kdesu.1*
+%{_mandir}/man1/plasmapkg.1*
+%{_mandir}/man8/nepomuk*.8*
 
 %{_datadir}/sounds/*
 %{_iconsdir}/hicolor/*/*/*.png
@@ -503,11 +518,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
-%attr(755,root,root) %{_libdir}/kde4/kcm_phononxine.so
 %{_datadir}/kde4/services/kcm_phonon.desktop
 %{_datadir}/kde4/services/spellchecking.desktop
 %{_datadir}/kde4/servicetypes/phononbackend.desktop
-%{_datadir}/kde4/services/kcm_phononxine.desktop
 
 %dir %{_libdir}/kde4/plugins/phonon_platform
 %{_libdir}/kde4/plugins/phonon_platform/kde.so
This page took 0.147575 seconds and 4 git commands to generate.