]> git.pld-linux.org Git - packages/kde4-calligra.git/commitdiff
- added icu,boost patches to fix build with icu 64/boost 1.70 auto/th/kde4-calligra-2.8.7-28
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 20 Apr 2019 08:35:42 +0000 (10:35 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 20 Apr 2019 08:35:42 +0000 (10:35 +0200)
- help with openjpeg (1.x) detection
- note that libreverse based converters are no longer built (older versions are expected)
- release 28

calligra-boost.patch [new file with mode: 0644]
calligra-icu.patch [new file with mode: 0644]
kde4-calligra.spec

diff --git a/calligra-boost.patch b/calligra-boost.patch
new file mode 100644 (file)
index 0000000..c0a69d6
--- /dev/null
@@ -0,0 +1,11 @@
+--- calligra-2.8.7/krita/gemini/desktopviewproxy.cpp.orig      2014-11-30 15:02:20.000000000 +0100
++++ calligra-2.8.7/krita/gemini/desktopviewproxy.cpp   2019-04-20 10:31:53.092416765 +0200
+@@ -31,8 +31,6 @@
+ #include <krecentfilesaction.h>
+ #include <kactioncollection.h>
+-#include <boost/config/posix_features.hpp>
+-
+ #include <KoMainWindow.h>
+ #include <KoFilterManager.h>
+ #include <KoFileDialog.h>
diff --git a/calligra-icu.patch b/calligra-icu.patch
new file mode 100644 (file)
index 0000000..9d25063
--- /dev/null
@@ -0,0 +1,38 @@
+--- calligra-2.8.7/libs/db/tableviewdata.cpp.orig      2014-11-30 15:02:20.000000000 +0100
++++ calligra-2.8.7/libs/db/tableviewdata.cpp   2019-04-19 20:57:59.892689347 +0200
+@@ -51,7 +51,7 @@
+ public:
+     CollatorInstance() {
+         UErrorCode status = U_ZERO_ERROR;
+-        m_collator = Collator::createInstance(status);
++        m_collator = icu::Collator::createInstance(status);
+         if (U_FAILURE(status)) {
+             kWarning() << "Could not create instance of collator: " << status;
+             m_collator = NULL;
+@@ -63,7 +63,7 @@
+             kWarning() << "Could not set collator attribute: " << status;
+     }
+-    Collator* getCollator() {
++    icu::Collator* getCollator() {
+         return m_collator;
+     }
+@@ -72,7 +72,7 @@
+     }
+ private:
+-    Collator *m_collator;
++    icu::Collator *m_collator;
+ };
+ K_GLOBAL_STATIC(CollatorInstance, _collator)
+@@ -161,7 +161,7 @@
+     static  bool cmpStringWithCollator(const QVariant& left, const QVariant& right) {
+         const QString &as = left.toString();
+         const QString &bs = right.toString();
+-        return (Collator::LESS == _collator->getCollator()->compare((const UChar *)as.constData(), as.size(),
++        return (icu::Collator::LESS == _collator->getCollator()->compare((const UChar *)as.constData(), as.size(),
+                 (const UChar *)bs.constData(), bs.size())) ? true : false;
+     }
index d7a25c143d6b6534613dab29ef943491118e30a2..edc288c308dd92cbb5a49c9d62a2cf2316577a06 100644 (file)
@@ -3,15 +3,16 @@
 #-- The following OPTIONAL packages could NOT be located on your system.
 #-- Consider installing them to enable more features from this software.
 #-----------------------------------------------------------------------------
-#   * OpenCTL (0.9.10 or higher)  <http://www.opengtl.org>
-#     Free Color Transformation Language implementation (part of OpenGTL)
-#     Required for High Dynamic Range Color Spaces, YCbCr and LMS support
-#   * OpenShiva  <http://www.opengtl.org>
-#     OpenShiva interpreter for the Shiva Kernel Language (part of OpenGTL)
-#     Required for Shiva based Generators and Filters
-#   * QtShiva  <http://www.opengtl.org>
-#     Qt bindings for the OpenShiva interpreter (part of libQtGTL)
-#     Required for Shiva based Generators and Filters
+#   * Vc  <http://code.compeng.uni-frankfurt.de/projects/vc>
+#     Portable, zero-overhead SIMD library for C++
+#     Required by the Krita for vectorization
+#   * openjpeg  <http://www.openjpeg.org>
+#     Free library for JPEG 2000 image compression
+#     Required by the Krita JPEG 2000 filter
+#   * Cauchy's M2MML  <https://bitbucket.org/cyrille/cauchy>
+#     Matlab/Octave to MathML compiler
+#     Required for the matlab/octave formula tool
+#   * LibOdfGen, LibWpd, LibWpg, LibWps, LibVisio, LibEtonyek - pre-C++11 versions are expected
 #
 # Conditional build:
 %bcond_without pdf             # build without PDF support
@@ -27,13 +28,15 @@ Summary:    Calligra - powerful office suite for KDE
 Summary(pl.UTF-8):     Calligra - potężny pakiet biurowy dla KDE
 Name:          kde4-calligra
 Version:       2.8.7
-Release:       27
+Release:       28
 License:       GPL/LGPL
 Group:         X11/Applications
 Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{orgname}-%{version}/%{orgname}-%{version}.tar.xz
 # Source0-md5: 5ba4b76e3f81daffb28d3ed545908736
 Patch0:                moc.patch
 Patch1:                %{orgname}-exiv2.patch
+Patch2:                %{orgname}-icu.patch
+Patch3:                %{orgname}-boost.patch
 URL:           http://www.calligra-suite.org/
 BuildRequires: GraphicsMagick-devel
 BuildRequires: OpenEXR-devel
@@ -67,24 +70,24 @@ BuildRequires:      kde4-libksane-devel >= %{kdever}
 BuildRequires: kde4-marble-devel >= %{kdever}
 BuildRequires: kde4-okular-devel >= %{kdever}
 BuildRequires: lcms2-devel
-BuildRequires: libetonyek-devel
+#BuildRequires:        libetonyek-devel < 0.1
 BuildRequires: libexif-devel >= 0.6.12
 BuildRequires: libicu-devel
 BuildRequires: libjpeg-devel
-BuildRequires: libodfgen-devel
+#BuildRequires:        libodfgen-devel < 0.1
 BuildRequires: libpng-devel
 %{?with_pqxx:BuildRequires:    libpqxx-devel >= 4.0.0}
 BuildRequires: libspnav-devel
 BuildRequires: libtiff-devel
-BuildRequires: libtiff-devel
-BuildRequires: libvisio-devel
-BuildRequires: libwpd-devel >= 0.9
-BuildRequires: libwpg-devel >= 0.2
-BuildRequires: libwps-devel
+#BuildRequires:        libvisio-devel < 0.1
+#BuildRequires:        libwpd-devel >= 0.9 < 0.10
+#BuildRequires:        libwpg-devel >= 0.2 < 0.3
+#uildRequires: libwps-devel >= 0.2 < 0.3
 BuildRequires: libxml2-devel >= 0:2.4.8
 BuildRequires: libxslt-devel >= 1.0.7
 BuildRequires: mysql-devel
-BuildRequires: openjpeg2-devel >= 1.3
+BuildRequires: openjpeg-devel >= 1.5
+BuildRequires: openjpeg-devel < 2
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 %{?with_pdf:BuildRequires:     poppler-Qt-devel >= 0.6}
@@ -350,17 +353,19 @@ finalną publikację.
 %setup -q -n %{orgname}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 install -d build
 cd build
-%cmake \
-       -DBUILD_cstester:BOOL=OFF \
+%cmake .. \
        -DBUILD_active:BOOL=OFF \
+       -DBUILD_cstester:BOOL=OFF \
        -DBUILD_koabstraction:BOOL=OFF \
        -DBUILD_mobile:BOOL=OFF \
        -DKDE4_BUILD_TESTS:BOOL=OFF \
-       ../
+       -DOPENJPEG_INCLUDE_DIR:PATH=/usr/include/openjpeg-1.5
 
 %{__make}
 
This page took 0.128724 seconds and 4 git commands to generate.