]> git.pld-linux.org Git - packages/kazehakase.git/blame - kazehakase.spec
- fixed bconds in files
[packages/kazehakase.git] / kazehakase.spec
CommitLineData
03160c97 1#
5e7397d1 2# - force kazehakase to use old SSL dialogs using nsIBadCertListener, ie. port
3# EphyBadCertRejector from Epiphany, this will fix issues with https sites
4# using self signed and expired certificates or mismatches in domain names
5#
6# Conditional builds
9eee9440
JB
7%bcond_without gecko # build without gecko support
8%bcond_without webkit # build without webkit support
03160c97 9#
10Summary: A browser with multiple rendering engines support
9eee9440 11Summary(pl.UTF-8): Przeglądarka obsługująca wiele silników renderujących
a0563285 12Name: kazehakase
d5e6c46c 13Version: 0.5.6
14Release: 1
fa48900a
JB
15License: GPL
16Group: X11/Applications/Networking
d5e6c46c 17Source0: http://downloads.sourceforge.jp/kazehakase/33533/%{name}-%{version}.tar.gz
18# Source0-md5: b88257aa10dd53fd5d39c627f8f95890
a6b45d00 19Patch0: %{name}-desktop.patch
5306880a 20Patch1: %{name}-deprecated.patch
21Patch2: %{name}-ti-agent.patch
22Patch3: %{name}-agent.patch
ecee25b5 23Patch4: %{name}-libxul.patch
5e7397d1 24Patch5: %{name}-xulappinfo.patch
fa48900a 25URL: http://kazehakase.sourceforge.jp/
e30aeaf6 26BuildRequires: autoconf
171705b2 27BuildRequires: automake
4c5fe5e2 28BuildRequires: gettext-devel
cc3ad5d6 29BuildRequires: gnutls-devel
4c5fe5e2 30BuildRequires: gtk+2-devel
03160c97 31%{?with_webkit:BuildRequires: gtk-webkit-devel}
4c5fe5e2 32BuildRequires: libstdc++-devel
1c8859c8 33BuildRequires: libtool
4c5fe5e2 34BuildRequires: pkgconfig
5306880a 35BuildRequires: rpm >= 4.4.9-56
03160c97 36%{?with_gecko:BuildRequires: xulrunner-devel}
ed2f17cf 37Requires: %{name}-libs = %{version}-%{release}
20830783 38Requires: kazehakase_engine
c482f379 39%requires_eq_to xulrunner xulrunner-devel
a0563285 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
c482f379
MB
42# we have strict deps for it
43%define _noautoreq libxpcom.so
44
a0563285 45%description
03160c97 46Kazehakase is a browser which allow use many rendering engines. For
9eee9440 47now it support only Gecko (like Epiphany or Galeon) and webkit engines.
a0563285 48
321a9c12 49%description -l pl.UTF-8
03160c97 50Kazehakase jest przeglądarką, która pozwala na używanie wielu
9eee9440
JB
51silników renderujących. Na dzień dzisiejszy obsługuje silniki Gecko
52(taki jak w Epiphany lub Galeonie) oraz webkit.
a0563285 53
ed2f17cf 54%package libs
55Summary: Kazehakase libraries
56Summary(pl.UTF-8): Biblioteki Kazehakase
57Group: Libraries
58
59%description libs
60This package contains Kazehakase libraries.
61
62%description libs -l pl.UTF-8
63Pakiet zawiera biblioteki Kazehakase.
64
03160c97 65%package plugin-gecko
66Summary: Gecko plugin engine for Kazehakase
9eee9440 67Summary(pl.UTF-8): Wtyczka Gecko dla Kazehakase
03160c97 68Group: X11/Applications/Networking
69Requires: xulrunner
20830783 70Provides: kazehakase_engine
03160c97 71
72%description plugin-gecko
9eee9440 73This plugin provides Gecko rendering engine support.
03160c97 74
75%description plugin-gecko -l pl.UTF-8
9eee9440 76Ta wtyczka dodaje obsługę silnika renderującego Gecko.
03160c97 77
78%package plugin-webkit
79Summary: Webkit plugin engine for Kazehakase
9eee9440 80Summary(pl.UTF-8): Wtyczka webkit dla Kazehakase
03160c97 81Group: X11/Applications/Networking
20830783 82Provides: kazehakase_engine
03160c97 83
84%description plugin-webkit
85This plugin provides webkit rendering engine support.
86
87%description plugin-webkit -l pl.UTF-8
9eee9440 88Ta wtyczka dodaje obsługę silnika renderującego webkit.
03160c97 89
a0563285 90%prep
91%setup -q
679126f2 92%patch0 -p1
b27b22f5 93%patch1 -p1
5306880a 94%if "%{pld_release}" == "ti"
1a55cf25 95%patch2 -p1
5306880a 96%else
97%patch3 -p1
98%endif
ecee25b5 99%patch4 -p1
5e7397d1 100%patch5 -p1
a0563285 101
102%build
4c5fe5e2 103%{__libtoolize}
2860fed1 104%{__aclocal} -I macros
cc58b2fa 105%{__autoconf}
106%{__automake}
03160c97 107%configure \
c3843468 108 %{!?with_gecko:--disable-gecko} \
03160c97 109 %{!?with_webkit:--disable-webkit}
a0563285 110
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
fa48900a 115
a0563285 116%{__make} install \
cf902c03 117 libkazehakasedir=%{_libdir} \
a0563285 118 DESTDIR=$RPM_BUILD_ROOT
cf902c03
KK
119
120# unnecessary
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
2860fed1 122rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/embed/*.la
cf902c03 123
dc2a4855 124%find_lang %{name}
cf902c03 125
a0563285 126%clean
127rm -rf $RPM_BUILD_ROOT
128
ed2f17cf 129%post libs -p /sbin/ldconfig
130%postun libs -p /sbin/ldconfig
cc3ad5d6 131
dc2a4855 132%files -f %{name}.lang
a0563285 133%defattr(644,root,root,755)
134%doc README README.ja AUTHORS ChangeLog COPYING.README TODO.ja
135%{_sysconfdir}/%{name}
136%attr(755,root,root) %{_bindir}/*
056ea567 137%{_desktopdir}/%{name}.desktop
a0563285 138%{_datadir}/%{name}
139%{_pixmapsdir}/*
a6b45d00 140%{_mandir}/man?/*
ed2f17cf 141
142%files libs
143%defattr(644,root,root,755)
850ffdd1 144%attr(755,root,root) %{_libdir}/lib*.so
145%attr(755,root,root) %{_libdir}/lib*.so.*
ed2f17cf 146%dir %{_libdir}/%{name}
9eee9440 147%dir %{_libdir}/%{name}/embed
03160c97 148
ebed0e96 149%if %{with gecko}
03160c97 150%files plugin-gecko
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_libdir}/%{name}/embed/gecko.so
153%endif
ebed0e96 154%if %{with webkit}
03160c97 155%files plugin-webkit
156%defattr(644,root,root,755)
157%attr(755,root,root) %{_libdir}/%{name}/embed/webkit_gtk.so
158%endif
This page took 0.077288 seconds and 4 git commands to generate.