]> git.pld-linux.org Git - packages/kannel.git/blame - kannel.spec
- adapterized
[packages/kannel.git] / kannel.spec
CommitLineData
9468b827 1# TODO:
9468b827 2# - check file list when built with docs
8961ecde 3#
4# Conditional build:
5%bcond_with doc # build documentation
8bc7020a 6%bcond_without openssl # link against openssl (requires multithreaded libs)
8961ecde 7%bcond_without mysql # don't link against mysql
8#
9468b827 9Summary: SMS/WAP gateway
2375cc07 10Summary(pl.UTF-8): Bramka WAP oraz SMS
51a540df 11Name: kannel
696776f7
AG
12Version: 1.4.5
13Release: 0.1
e4b5efdb 14License: BSD-like (see COPYING)
51a540df 15Group: Networking/Daemons
9468b827 16Source0: http://www.kannel.org/download/%{version}/gateway-%{version}.tar.gz
696776f7 17# Source0-md5: b6b5b48edb646e0e0e2ea5378c8ac9ff
51a540df 18Source1: %{name}.init
9468b827 19Source2: %{name}.sysconfig
20Source3: %{name}.conf
696776f7 21Patch0: %{name}-bison.patch
6a1435a6 22Patch1: %{name}-openssl-1.1.0.patch
27eb402a 23URL: http://www.kannel.org/
51a540df 24BuildRequires: ImageMagick
40c9dbce 25BuildRequires: autoconf
38a92f05 26BuildRequires: automake
741694c7 27BuildRequires: libxml2-devel
8961ecde 28%{?with_mysql:BuildRequires: mysql-devel}
3eca4687
AG
29BuildRequires: pam-devel
30BuildRequires: pcre-devel
8bc7020a
AM
31%if %{with doc}
32BuildRequires: openjade
33BuildRequires: texlive-latex
34BuildRequires: texlive-latex-ams
35BuildRequires: texlive-latex-extend
36%endif
9468b827 37# requires multithread enabled openssl (?)
a24f3c69 38%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
9468b827 39BuildRequires: zlib-devel
27eb402a 40Requires(post,preun): /sbin/chkconfig
51a540df
AM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
fb10c3c2 44Kannel is an Open Source SMS/WAP gateway. WAP is short for Wireless
45Application Protocol. It lets the phone act as a simple hypertext
46browser, but optimizes the markup language, scripting language, and
47the transmission protocols for wirelessuse. The optimized protocols
48are translated to normal Internet protocols by a WAP gateway. Kannel
49also works as a SMS gateway for GSM networks. Almost all GSM phones
50can send and receive SMS messages, so this is a way to serve many more
51clients than just those using WAP phones.
51a540df 52
7a220c34
JR
53%description -l pl.UTF-8
54Kannel jest bramką SMS/WAP Open Source. WAP pozwala używać telefonów
55jako prostych przeglądarek hipertekstowych, ale korzysta ze
56zoptymalizowanych protokołów transmisji. Bramka WAP tłumaczy je na
57protokoły internetowe. Kannel działa również jako bramka SMS dla sieci
58GSM. Prawie wszystkie telefony GSM mogą odbierać i wysyłać wiadomości
59SMS, więc pozwala to na obsługę większej liczby klientów.
51a540df 60
518da49f
AG
61%package devel
62Summary: Header files for %{name} library
63Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68Header files for %{name} library.
69
70%description devel -l pl.UTF-8
71Pliki nagłówkowe biblioteki %{name}.
72
73%package static
74Summary: Static %{name} library
75Summary(pl.UTF-8): Statyczna biblioteka %{name}
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
80Static %{name} library.
81
82%description static -l pl.UTF-8
83Statyczna biblioteka %{name}.
84
51a540df
AM
85%prep
86%setup -q -n gateway-%{version}
40c9dbce 87%patch0 -p1
6a1435a6 88%patch1 -p1
51a540df
AM
89
90%build
741694c7 91cp -f /usr/share/automake/config.sub .
40c9dbce
JB
92%{__autoconf}
93%configure \
8bc7020a
AM
94 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
95 --with-malloc=native \
51a540df 96 --enable-cookies \
8bc7020a
AM
97 --enable-pcre \
98 --enable-pam \
99 --with%{!?with_mysql:out}-mysql \
8961ecde 100 %{?with_openssl: --with-wtls=openssl --with-ssl=%{_prefix} --en}%{!?with_openssl: --dis}able-ssl \
101 --%{!?with_doc:dis}%{?with_doc:en}able-docs
51a540df
AM
102
103touch .depend
104%{__make} depend
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
7fa4f974 109install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man{1,8}}
9468b827 110
7fa4f974
PG
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
51a540df 113
33dcd0a2 114install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
115install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
e9f73c49 116install -D %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/kannel/%{name}.conf
3eca4687
AG
117cp -p gw/smskannel.conf $RPM_BUILD_ROOT%{_sysconfdir}/kannel/smskannel.conf
118cp -p test/fakesmsc $RPM_BUILD_ROOT%{_bindir}
119cp -p test/fakewap $RPM_BUILD_ROOT%{_bindir}
51a540df
AM
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post
2e3a0733 125if [ "$1" = "1" ]; then
126 /sbin/chkconfig --add %{name}
127 echo "Run \"/etc/rc.d/init.d/kannel start\" to start kannel." >&2
128else
129 if [ -f /var/lock/subsys/kannel ]; then
130 /etc/rc.d/init.d/kannel restart >&2
131 fi
132fi
133
51a540df
AM
134
135%preun
136if [ "$1" = "0" ]; then
e9f73c49 137 if [ -f /var/lock/subsys/kannel ]; then
138 /etc/rc.d/init.d/kannel stop >&2
139 fi
140 /sbin/chkconfig --del kannel
51a540df
AM
141fi
142
143%files
144%defattr(644,root,root,755)
8bc7020a
AM
145%doc LICENSE README COPYING NEWS VERSION STATUS doc/{*.txt,examples/*.conf}
146%doc doc/ChangeLog*
51a540df
AM
147%attr(755,root,root) %{_bindir}/*
148%attr(755,root,root) %{_sbindir}/*
e4b5efdb 149%attr(754,root,root) /etc/rc.d/init.d/%{name}
38a92f05
ER
150%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
151%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kannel/kannel.conf
152%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kannel/smskannel.conf
7fa4f974
PG
153%dir %{_sysconfdir}/kannel
154%{_mandir}/man*/*
518da49f
AG
155
156%files devel
157%defattr(644,root,root,755)
158%{_includedir}/%{name}
159
160%files static
161%defattr(644,root,root,755)
162%{_libdir}/%{name}
This page took 0.893855 seconds and 4 git commands to generate.