- updated to 18.12.1; ninja auto/th/ka5-libkipi-18.12.1-1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 12 Jan 2019 17:07:56 +0000 (18:07 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 12 Jan 2019 17:07:56 +0000 (18:07 +0100)
ka5-libkipi.spec

index e3097df12736720b0d2aaeb92afc3a01a5f79769..4cc5b97f87f038feed0ed9ee9dd955ad7d907082 100644 (file)
@@ -1,16 +1,16 @@
-%define                kdeappsver      18.12.0
+%define                kdeappsver      18.12.1
 %define                qtver           5.9.0
 %define                kaname          libkipi
 
 Summary:       Kipi library
 Summary(pl.UTF-8):     Biblioteka kipi
 Name:          ka5-%{kaname}
-Version:       18.12.0
+Version:       18.12.1
 Release:       1
 License:       GPL v2+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: 36542096568f918cf58c57c5c3c9004f
+# Source0-md5: 524a64c8956f7c8d81a94d8a78613d31
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel
 BuildRequires: Qt5Gui-devel
@@ -22,6 +22,7 @@ BuildRequires:        kf5-kxmlgui-devel >= 5.1.0
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libtiff-devel
+BuildRequires: ninja
 BuildRequires: rpmbuild(macros) >= 1.164
 Obsoletes:     libkipi <= 4.8.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -53,14 +54,14 @@ Pliki nagłówkowe dla programistów używających %{kaname}.
 install -d build
 cd build
 %cmake \
+       -G Ninja \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.181959 seconds and 4 git commands to generate.