- updated to 21.04.0
[packages/ka5-libkgapi.git] / ka5-libkgapi.spec
CommitLineData
55c90d81 1%define kdeappsver 21.04.0
76ed2702 2%define kframever 5.56.0
137496d6
WF
3%define qtver 5.9.0
4%define kaname libkgapi
5Summary: libkgapi
6Name: ka5-%{kaname}
55c90d81
WF
7Version: 21.04.0
8Release: 1
137496d6
WF
9License: GPL v2+/LGPL v2.1+
10Group: X11/Libraries
f278bc66 11Source0: http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
55c90d81 12# Source0-md5: a0ad9b4bca86bb90c3e61a18b5abf278
137496d6
WF
13URL: http://www.kde.org/
14BuildRequires: Qt5Core-devel >= %{qtver}
15BuildRequires: Qt5Gui-devel >= 5.11.1
16BuildRequires: Qt5Network-devel
17BuildRequires: Qt5Positioning-devel >= 5.11.1
18BuildRequires: Qt5PrintSupport-devel >= 5.11.1
19BuildRequires: Qt5Qml-devel >= 5.11.1
20BuildRequires: Qt5Quick-devel >= 5.11.1
21BuildRequires: Qt5Test-devel
22BuildRequires: Qt5WebChannel-devel >= 5.11.1
23BuildRequires: Qt5WebEngine-devel >= 5.11.1
24BuildRequires: Qt5Widgets-devel
25BuildRequires: Qt5Xml-devel
26BuildRequires: cmake >= 2.8.12
27BuildRequires: cyrus-sasl-devel
28BuildRequires: gettext-devel
76ed2702 29BuildRequires: kf5-extra-cmake-modules >= %{kframever}
f278bc66
WF
30BuildRequires: kf5-kcalendarcore-devel >= %{kframever}
31BuildRequires: kf5-kcontacts-devel >= %{kframever}
76ed2702
WF
32BuildRequires: kf5-kio-devel >= %{kframever}
33BuildRequires: kf5-kwallet-devel >= %{kframever}
34BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
35BuildRequires: ninja
137496d6
WF
36BuildRequires: qt5-build >= %{qtver}
37BuildRequires: rpmbuild(macros) >= 1.164
38BuildRequires: shared-mime-info
39BuildRequires: tar >= 1:1.22
40BuildRequires: xz
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44LibKGAPI is a KDE-based library for accessing various Google services
45via their public API.
46
47%package devel
48Summary: Header files for %{kaname} development
49Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kaname}
50Group: X11/Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54Header files for %{kaname} development.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe dla programistów używających %{kaname}.
58
59%prep
60%setup -q -n %{kaname}-%{version}
61
62%build
63install -d build
64cd build
76ed2702
WF
65%cmake -G Ninja \
66 -DHTML_INSTALL_DIR=%{_kdedocdir} \
137496d6
WF
67 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68 ..
76ed2702 69%ninja_build
137496d6
WF
70
71%install
72rm -rf $RPM_BUILD_ROOT
76ed2702 73%ninja_install -C build
137496d6
WF
74
75%find_lang %{kaname}_qt --with-qm --all-name --with-kde
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%files -f %{kaname}_qt.lang
84%defattr(644,root,root,755)
55c90d81 85%ghost %{_libdir}/libKPimGAPIBlogger.so.5
137496d6 86%attr(755,root,root) %{_libdir}/libKPimGAPIBlogger.so.5.*.*
55c90d81 87%ghost %{_libdir}/libKPimGAPICalendar.so.5
137496d6 88%attr(755,root,root) %{_libdir}/libKPimGAPICalendar.so.5.*.*
55c90d81 89%ghost %{_libdir}/libKPimGAPIContacts.so.5
137496d6 90%attr(755,root,root) %{_libdir}/libKPimGAPIContacts.so.5.*.*
55c90d81 91%ghost %{_libdir}/libKPimGAPICore.so.5
137496d6 92%attr(755,root,root) %{_libdir}/libKPimGAPICore.so.5.*.*
55c90d81 93%ghost %{_libdir}/libKPimGAPIDrive.so.5
137496d6 94%attr(755,root,root) %{_libdir}/libKPimGAPIDrive.so.5.*.*
55c90d81 95%ghost %{_libdir}/libKPimGAPILatitude.so.5
137496d6 96%attr(755,root,root) %{_libdir}/libKPimGAPILatitude.so.5.*.*
55c90d81 97%ghost %{_libdir}/libKPimGAPIMaps.so.5
137496d6 98%attr(755,root,root) %{_libdir}/libKPimGAPIMaps.so.5.*.*
55c90d81 99%ghost %{_libdir}/libKPimGAPITasks.so.5
137496d6 100%attr(755,root,root) %{_libdir}/libKPimGAPITasks.so.5.*.*
55c90d81 101%ghost %{_libdir}/sasl2/libkdexoauth2.so.3
137496d6 102%attr(755,root,root) %{_libdir}/sasl2/libkdexoauth2.so.3.*.*
f278bc66 103%{_datadir}/qlogging-categories5/libkgapi.categories
137496d6
WF
104
105%files devel
106%defattr(644,root,root,755)
107%{_includedir}/KPim/KGAPI
108%{_includedir}/KPim/kgapi_version.h
109%{_libdir}/cmake/KPimGAPI
55c90d81
WF
110%{_libdir}/libKPimGAPIBlogger.so
111%{_libdir}/libKPimGAPICalendar.so
112%{_libdir}/libKPimGAPIContacts.so
113%{_libdir}/libKPimGAPICore.so
114%{_libdir}/libKPimGAPIDrive.so
115%{_libdir}/libKPimGAPIMaps.so
116%{_libdir}/libKPimGAPILatitude.so
117%{_libdir}/libKPimGAPITasks.so
118%{_libdir}/sasl2/libkdexoauth2.so
137496d6
WF
119%{_libdir}/qt5/mkspecs/modules/qt_KGAPIBlogger.pri
120%{_libdir}/qt5/mkspecs/modules/qt_KGAPICalendar.pri
121%{_libdir}/qt5/mkspecs/modules/qt_KGAPIContacts.pri
122%{_libdir}/qt5/mkspecs/modules/qt_KGAPICore.pri
123%{_libdir}/qt5/mkspecs/modules/qt_KGAPIDrive.pri
124%{_libdir}/qt5/mkspecs/modules/qt_KGAPILatitude.pri
125%{_libdir}/qt5/mkspecs/modules/qt_KGAPIMaps.pri
126%{_libdir}/qt5/mkspecs/modules/qt_KGAPITasks.pri
This page took 0.181174 seconds and 4 git commands to generate.