]> git.pld-linux.org Git - packages/ka5-kontact.git/blame - ka5-kontact.spec
- bcond_with tests
[packages/ka5-kontact.git] / ka5-kontact.spec
CommitLineData
fd5eb0a9
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
5ed61296 4%define kdeappsver 21.12.3
c5b245cd 5%define kframever 5.56.0
3afc98c6
WF
6%define qtver 5.9.0
7%define kaname kontact
8Summary: kontact
9Name: ka5-%{kaname}
5ed61296 10Version: 21.12.3
3afc98c6
WF
11Release: 1
12License: GPL v2+/LGPL v2.1+
13Group: X11/Applications
710a9bd2 14Source0: http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
5ed61296 15# Source0-md5: 821f520616ce9533140fcf7232114513
3afc98c6
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5DBus-devel
19BuildRequires: Qt5Gui-devel >= 5.11.1
20BuildRequires: Qt5Network-devel >= 5.11.1
21BuildRequires: Qt5Positioning-devel >= 5.11.1
22BuildRequires: Qt5PrintSupport-devel >= 5.11.1
23BuildRequires: Qt5Qml-devel >= 5.11.1
24BuildRequires: Qt5Quick-devel >= 5.11.1
25BuildRequires: Qt5WebChannel-devel >= 5.11.1
26BuildRequires: Qt5WebEngine-devel
27BuildRequires: Qt5Widgets-devel
28BuildRequires: cmake >= 2.8.12
29BuildRequires: gettext-devel
0cfd155d
WF
30BuildRequires: ka5-akonadi-devel >= %{kdeappsver}
31BuildRequires: ka5-grantleetheme-devel >= %{kdeappsver}
0cfd155d
WF
32BuildRequires: ka5-kontactinterface-devel >= %{kdeappsver}
33BuildRequires: ka5-kpimtextedit-devel >= %{kdeappsver}
34BuildRequires: ka5-libkdepim-devel >= %{kdeappsver}
c5b245cd
WF
35BuildRequires: kf5-extra-cmake-modules >= %{kframever}
36BuildRequires: kf5-kcmutils-devel >= %{kframever}
37BuildRequires: kf5-kcrash-devel >= %{kframever}
38BuildRequires: kf5-kdbusaddons-devel >= %{kframever}
39BuildRequires: kf5-kdoctools-devel >= %{kframever}
40BuildRequires: kf5-kiconthemes-devel >= %{kframever}
41BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
0cfd155d 42BuildRequires: ninja
3afc98c6
WF
43BuildRequires: qt5-build >= %{qtver}
44BuildRequires: rpmbuild(macros) >= 1.164
45BuildRequires: shared-mime-info
46BuildRequires: tar >= 1:1.22
47BuildRequires: xz
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51Kontact is the integrated solution to your personal information
52management (PIM) needs. It combines well-known KDE applications like
53KMail, KOrganizer and KAddressBook into a single interface to provide
54easy access to mail, scheduling, address book and other PIM
55functionality.
56
fc580692
WF
57%description -l pl.UTF-8
58Kontact jest zintegrowanym rozwiązaniem do zarządzania informacją
59osobistą (PIM). W jego skład wchodzą dobrze znane aplikacje KDE, takie
d9a4e724
WF
60jak KMail, KOrganizer i KAddressBook. Mają ujednolicony interfejs i
61dają łatwy dostęp do poczty, listy zadań, książki adresowej i innych
fc580692
WF
62funkcjonalności PIM.
63
3afc98c6
WF
64%prep
65%setup -q -n %{kaname}-%{version}
66
67%build
68install -d build
69cd build
70%cmake \
0cfd155d 71 -G Ninja \
fd5eb0a9 72 %{!?with_tests:-DBUILD_TESTING=OFF} \
c5b245cd 73 -DHTML_INSTALL_DIR=%{_kdedocdir} \
3afc98c6
WF
74 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
75 ..
0cfd155d 76%ninja_build
3afc98c6 77
fd5eb0a9
WF
78%if %{with tests}
79ctest
80%endif
81
82
3afc98c6
WF
83%install
84rm -rf $RPM_BUILD_ROOT
0cfd155d 85%ninja_install -C build
3afc98c6
WF
86
87%find_lang %{kaname} --all-name --with-kde
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
95%files -f %{kaname}.lang
96%defattr(644,root,root,755)
3afc98c6 97%attr(755,root,root) %{_bindir}/kontact
296f38d4
WF
98%ghost %{_libdir}/libkontactprivate.so.5
99%attr(755,root,root) %{_libdir}/libkontactprivate.so.*.*.*
d9a4e724
WF
100%dir %{_libdir}/qt5/plugins/pim/kcms/kontact
101%attr(755,root,root) %{_libdir}/qt5/plugins/pim/kcms/kontact/kcm_kontact.so
3afc98c6
WF
102%{_desktopdir}/org.kde.kontact.desktop
103%{_datadir}/config.kcfg/kontact.kcfg
104%{_iconsdir}/hicolor/128x128/apps/kontact.png
105%{_iconsdir}/hicolor/16x16/apps/kontact.png
106%{_iconsdir}/hicolor/22x22/apps/kontact.png
107%{_iconsdir}/hicolor/32x32/apps/kontact.png
108%{_iconsdir}/hicolor/48x48/apps/kontact.png
109%{_iconsdir}/hicolor/64x64/apps/kontact.png
110%{_iconsdir}/hicolor/scalable/apps/kontact.svg
3afc98c6
WF
111%{_datadir}/kservices5/kontactconfig.desktop
112%{_datadir}/messageviewer/about/default/introduction_kontact.html
113%{_datadir}/messageviewer/about/default/loading_kontact.html
114%{_datadir}/metainfo/org.kde.kontact.appdata.xml
710a9bd2
WF
115%{_datadir}/dbus-1/services/org.kde.kontact.service
116%{_datadir}/qlogging-categories5/kontact.categories
117%{_datadir}/qlogging-categories5/kontact.renamecategories
This page took 0.09757 seconds and 4 git commands to generate.