]> git.pld-linux.org Git - packages/ka5-kontact.git/blame - ka5-kontact.spec
- updated to 22.04.3
[packages/ka5-kontact.git] / ka5-kontact.spec
CommitLineData
fd5eb0a9
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
8a9e888d
WF
4%define kdeappsver 22.04.3
5%define kframever 5.94.0
6%define qtver 5.15.2
3afc98c6
WF
7%define kaname kontact
8Summary: kontact
9Name: ka5-%{kaname}
8a9e888d
WF
10Version: 22.04.3
11Release: 1
3afc98c6
WF
12License: GPL v2+/LGPL v2.1+
13Group: X11/Applications
83258702 14Source0: https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
8a9e888d 15# Source0-md5: 61b49cd7710c0bb3ef29e85d8f1d6553
3afc98c6
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5DBus-devel
19BuildRequires: Qt5Gui-devel >= 5.11.1
20BuildRequires: Qt5Network-devel >= 5.11.1
21BuildRequires: Qt5Positioning-devel >= 5.11.1
22BuildRequires: Qt5PrintSupport-devel >= 5.11.1
23BuildRequires: Qt5Qml-devel >= 5.11.1
24BuildRequires: Qt5Quick-devel >= 5.11.1
25BuildRequires: Qt5WebChannel-devel >= 5.11.1
26BuildRequires: Qt5WebEngine-devel
27BuildRequires: Qt5Widgets-devel
28BuildRequires: cmake >= 2.8.12
29BuildRequires: gettext-devel
0cfd155d
WF
30BuildRequires: ka5-akonadi-devel >= %{kdeappsver}
31BuildRequires: ka5-grantleetheme-devel >= %{kdeappsver}
0cfd155d
WF
32BuildRequires: ka5-kontactinterface-devel >= %{kdeappsver}
33BuildRequires: ka5-kpimtextedit-devel >= %{kdeappsver}
34BuildRequires: ka5-libkdepim-devel >= %{kdeappsver}
c5b245cd
WF
35BuildRequires: kf5-extra-cmake-modules >= %{kframever}
36BuildRequires: kf5-kcmutils-devel >= %{kframever}
37BuildRequires: kf5-kcrash-devel >= %{kframever}
38BuildRequires: kf5-kdbusaddons-devel >= %{kframever}
39BuildRequires: kf5-kdoctools-devel >= %{kframever}
40BuildRequires: kf5-kiconthemes-devel >= %{kframever}
41BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
0cfd155d 42BuildRequires: ninja
3afc98c6
WF
43BuildRequires: qt5-build >= %{qtver}
44BuildRequires: rpmbuild(macros) >= 1.164
45BuildRequires: shared-mime-info
46BuildRequires: tar >= 1:1.22
47BuildRequires: xz
c27f05a8 48ExcludeArch: x32
3afc98c6
WF
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52Kontact is the integrated solution to your personal information
53management (PIM) needs. It combines well-known KDE applications like
54KMail, KOrganizer and KAddressBook into a single interface to provide
55easy access to mail, scheduling, address book and other PIM
56functionality.
57
fc580692
WF
58%description -l pl.UTF-8
59Kontact jest zintegrowanym rozwiązaniem do zarządzania informacją
60osobistą (PIM). W jego skład wchodzą dobrze znane aplikacje KDE, takie
d9a4e724
WF
61jak KMail, KOrganizer i KAddressBook. Mają ujednolicony interfejs i
62dają łatwy dostęp do poczty, listy zadań, książki adresowej i innych
fc580692
WF
63funkcjonalności PIM.
64
3afc98c6
WF
65%prep
66%setup -q -n %{kaname}-%{version}
67
68%build
69install -d build
70cd build
71%cmake \
0cfd155d 72 -G Ninja \
fd5eb0a9 73 %{!?with_tests:-DBUILD_TESTING=OFF} \
c5b245cd 74 -DHTML_INSTALL_DIR=%{_kdedocdir} \
3afc98c6
WF
75 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
76 ..
0cfd155d 77%ninja_build
3afc98c6 78
fd5eb0a9
WF
79%if %{with tests}
80ctest
81%endif
82
83
3afc98c6
WF
84%install
85rm -rf $RPM_BUILD_ROOT
0cfd155d 86%ninja_install -C build
3afc98c6
WF
87
88%find_lang %{kaname} --all-name --with-kde
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%files -f %{kaname}.lang
97%defattr(644,root,root,755)
3afc98c6 98%attr(755,root,root) %{_bindir}/kontact
296f38d4
WF
99%ghost %{_libdir}/libkontactprivate.so.5
100%attr(755,root,root) %{_libdir}/libkontactprivate.so.*.*.*
d9a4e724
WF
101%dir %{_libdir}/qt5/plugins/pim/kcms/kontact
102%attr(755,root,root) %{_libdir}/qt5/plugins/pim/kcms/kontact/kcm_kontact.so
3afc98c6
WF
103%{_desktopdir}/org.kde.kontact.desktop
104%{_datadir}/config.kcfg/kontact.kcfg
105%{_iconsdir}/hicolor/128x128/apps/kontact.png
106%{_iconsdir}/hicolor/16x16/apps/kontact.png
107%{_iconsdir}/hicolor/22x22/apps/kontact.png
108%{_iconsdir}/hicolor/32x32/apps/kontact.png
109%{_iconsdir}/hicolor/48x48/apps/kontact.png
110%{_iconsdir}/hicolor/64x64/apps/kontact.png
111%{_iconsdir}/hicolor/scalable/apps/kontact.svg
3afc98c6
WF
112%{_datadir}/kservices5/kontactconfig.desktop
113%{_datadir}/messageviewer/about/default/introduction_kontact.html
114%{_datadir}/messageviewer/about/default/loading_kontact.html
115%{_datadir}/metainfo/org.kde.kontact.appdata.xml
710a9bd2
WF
116%{_datadir}/dbus-1/services/org.kde.kontact.service
117%{_datadir}/qlogging-categories5/kontact.categories
118%{_datadir}/qlogging-categories5/kontact.renamecategories
This page took 0.23816 seconds and 4 git commands to generate.