]> git.pld-linux.org Git - packages/ka5-kalgebra.git/blob - ka5-kalgebra.spec
- updated to 23.08.5
[packages/ka5-kalgebra.git] / ka5-kalgebra.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kalgebra
8 Summary:        Kalgebra
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  dc51e93650dac71669ca2303576fe6f6
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= 5.11.1
20 BuildRequires:  Qt5Network-devel >= 5.11.1
21 BuildRequires:  Qt5PrintSupport-devel
22 BuildRequires:  Qt5Qml-devel
23 BuildRequires:  Qt5Quick-devel
24 BuildRequires:  Qt5Svg-devel
25 BuildRequires:  Qt5Test-devel
26 BuildRequires:  Qt5WebEngine-devel >= 5.15.5
27 BuildRequires:  Qt5Widgets-devel >= 5.11.1
28 BuildRequires:  Qt5Xml-devel
29 BuildRequires:  cmake >= 3.20
30 BuildRequires:  gettext-devel
31 BuildRequires:  ka5-analitza-devel >= %{kdeappsver}
32 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
33 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
34 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
35 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
36 BuildRequires:  kf5-ki18n-devel >= %{kframever}
37 BuildRequires:  kf5-kio-devel >= %{kframever}
38 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
39 BuildRequires:  ninja
40 BuildRequires:  qt5-build >= %{qtver}
41 BuildRequires:  rpmbuild(macros) >= 1.164
42 BuildRequires:  shared-mime-info
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 ExcludeArch:    x32
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 KAlgebra is a fully featured calculator that lets you plot different
50 types of 2D and 3D functions and to calculate easy (and not so easy)
51 calculations, such as addition, trigonometric functions or
52 derivatives.
53
54 The application has been thought to be progressively understood for
55 students, so that starting to use it doesn't get in the way. The
56 language is deeply integrated with the UI, providing a dictionary with
57 representations for all the available operations, code highlighting
58 and code completion.
59
60 %description -l pl.UTF-8
61 KAlgebra jest wszechstronnym kalkulatorem, pozwalającym rysować
62 różne typy funkcji dwu- i trójwymiarowych i przeliczać łatwe (i
63 nie tylko) operacje matematycze, jak dodawanie, funkcje
64 trygonometryczne i pochodne.
65
66 Aplikacja została pomyślana tak, aby była stopniowo rozumiana przez
67 studentów. Język jest głęboko zintegrowany z interfejsem
68 użykownika, dostarczając słownik z reprezentacją wszystkich
69 dostępnych operacji, a także podświetlanie kodu i podpowiadanie
70 dopełnień.
71
72 %prep
73 %setup -q -n %{kaname}-%{version}
74
75 %build
76 %cmake \
77         -B build \
78         -G Ninja \
79         %{!?with_tests:-DBUILD_TESTING=OFF} \
80         -DHTML_INSTALL_DIR=%{_kdedocdir} \
81         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
82 %ninja_build -C build
83
84 %if %{with tests}
85 ctest --test-dir build
86 %endif
87
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %ninja_install -C build
92
93 %find_lang %{kaname} --all-name --with-kde
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files -f %{kaname}.lang
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_bindir}/calgebra
101 %attr(755,root,root) %{_bindir}/kalgebra
102 %attr(755,root,root) %{_bindir}/kalgebramobile
103 %{_desktopdir}/org.kde.kalgebramobile.desktop
104 %{_iconsdir}/hicolor/64x64/apps/kalgebra.png
105 %{_iconsdir}/hicolor/scalable/apps/kalgebra.svgz
106 %{_datadir}/metainfo/org.kde.kalgebramobile.appdata.xml
107 %{_desktopdir}/org.kde.kalgebra.desktop
108 %{_datadir}/katepart5/syntax/kalgebra.xml
109 %{_datadir}/metainfo/org.kde.graphsplasmoid.appdata.xml
110 %{_datadir}/metainfo/org.kde.kalgebra.appdata.xml
111 %{_datadir}/plasma/plasmoids/org.kde.graphsplasmoid
This page took 0.089131 seconds and 4 git commands to generate.