]> git.pld-linux.org Git - packages/ka5-kalgebra.git/blob - ka5-kalgebra.spec
- bcond_with tests
[packages/ka5-kalgebra.git] / ka5-kalgebra.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      21.12.3
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          kalgebra
8 Summary:        Kalgebra
9 Name:           ka5-%{kaname}
10 Version:        21.12.3
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  b1573117feca56f84d7bcec7c0f8ab46
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= 5.11.1
20 BuildRequires:  Qt5Network-devel >= 5.11.1
21 BuildRequires:  Qt5PrintSupport-devel
22 BuildRequires:  Qt5Qml-devel
23 BuildRequires:  Qt5Quick-devel
24 BuildRequires:  Qt5Svg-devel
25 BuildRequires:  Qt5Test-devel
26 BuildRequires:  Qt5WebEngine-devel >= 5.15.5
27 BuildRequires:  Qt5Widgets-devel >= 5.11.1
28 BuildRequires:  Qt5Xml-devel
29 BuildRequires:  cmake >= 2.8.12
30 BuildRequires:  gettext-devel
31 BuildRequires:  ka5-analitza-devel >= %{kdeappsver}
32 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
33 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
34 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
35 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
36 BuildRequires:  kf5-ki18n-devel >= %{kframever}
37 BuildRequires:  kf5-kio-devel >= %{kframever}
38 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
39 BuildRequires:  ninja
40 BuildRequires:  qt5-build >= %{qtver}
41 BuildRequires:  rpmbuild(macros) >= 1.164
42 BuildRequires:  shared-mime-info
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 ExclusiveArch:  i686  %{x8664}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 KAlgebra is a fully featured calculator that lets you plot different
50 types of 2D and 3D functions and to calculate easy (and not so easy)
51 calculations, such as addition, trigonometric functions or
52 derivatives.
53
54 The application has been thought to be progressively understood for
55 students, so that starting to use it doesn't get in the way. The
56 language is deeply integrated with the UI, providing a dictionary with
57 representations for all the available operations, code highlighting
58 and code completion.
59
60 %description -l pl.UTF-8
61 KAlgebra jest wszechstronnym kalkulatorem, pozwalającym rysować różne
62 typy funkcji dwu- i trójwymiarowych i przeliczać łatwe (i nie tylko)
63 operacje matematycze, jak dodawanie, funkcje trygonometryczne i
64 pochodne.
65
66 Aplikacja została pomyślana tak, aby była stopniowo rozumiana przez
67 studentów. Język jest głęboko zintegrowany z interfejsem użykownika,
68 dostarczając słownik z reprezentacją wszystkich dostępnych operacji, a
69 także podświetlanie kodu i podpowiadanie dopełnień.
70
71 %prep
72 %setup -q -n %{kaname}-%{version}
73
74 %build
75 install -d build
76 cd build
77 %cmake \
78         -G Ninja \
79         %{!?with_tests:-DBUILD_TESTING=OFF} \
80         -DHTML_INSTALL_DIR=%{_kdedocdir} \
81         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
82         ..
83 %ninja_build
84
85 %if %{with tests}
86 ctest
87 %endif
88
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %ninja_install -C build
93
94 %find_lang %{kaname} --all-name --with-kde
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files -f %{kaname}.lang
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/calgebra
102 %attr(755,root,root) %{_bindir}/kalgebra
103 %attr(755,root,root) %{_bindir}/kalgebramobile
104 %{_desktopdir}/org.kde.kalgebramobile.desktop
105 %{_iconsdir}/hicolor/64x64/apps/kalgebra.png
106 %{_iconsdir}/hicolor/scalable/apps/kalgebra.svgz
107 %{_datadir}/metainfo/org.kde.kalgebramobile.appdata.xml
108 %{_desktopdir}/org.kde.kalgebra.desktop
109 %{_datadir}/katepart5/syntax/kalgebra.xml
110 %{_datadir}/kservices5/graphsplasmoid.desktop
111 %{_datadir}/metainfo/org.kde.kalgebra.appdata.xml
112 %{_datadir}/plasma/plasmoids/org.kde.graphsplasmoid
This page took 0.066088 seconds and 4 git commands to generate.