]> git.pld-linux.org Git - packages/ka5-incidenceeditor.git/blame - ka5-incidenceeditor.spec
- packaged files
[packages/ka5-incidenceeditor.git] / ka5-incidenceeditor.spec
CommitLineData
4bd654df
WF
1%define kdeappsver 18.12.0
2%define qtver 5.9.0
3%define kaname incidenceeditor
4Summary: Incidence editor
5Name: ka5-%{kaname}
6Version: 18.12.0
7Release: 1
8License: GPL v2+/LGPL v2.1+
9Group: X11/Libraries
10Source0: http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
11# Source0-md5: e9fdda4650d2a6c4de728100dd1b7967
12URL: http://www.kde.org/
13BuildRequires: Qt5Core-devel >= %{qtver}
055f8cff
WF
14BuildRequires: Qt5Gui-devel >= 5.11.1
15BuildRequires: Qt5Widgets-devel
4bd654df 16BuildRequires: cmake >= 2.8.12
055f8cff
WF
17BuildRequires: gettext-devel
18BuildRequires: ka5-akonadi-devel >= 18.12.0
19BuildRequires: ka5-akonadi-mime-devel >= 18.12.0
20BuildRequires: ka5-calendarsupport-devel >= 18.12.0
21BuildRequires: ka5-eventviews-devel >= 18.12.0
22BuildRequires: ka5-kcalcore-devel >= 18.12.0
23BuildRequires: ka5-kcalutils-devel >= 18.12.0
24BuildRequires: ka5-kdepim-apps-libs-devel >= 18.12.0
25BuildRequires: ka5-kldap-devel >= 18.12.0
26BuildRequires: ka5-kmailtransport-devel >= 18.12.0
27BuildRequires: ka5-kmime-devel >= 18.12.0
28BuildRequires: ka5-libkdepim-devel >= 18.12.0
29BuildRequires: kdiagram-devel >= 1.4.0
4bd654df 30BuildRequires: kf5-extra-cmake-modules >= 5.53.0
055f8cff
WF
31BuildRequires: kf5-kcodecs-devel >= 5.51.0
32BuildRequires: kf5-ki18n-devel >= 5.51.0
33BuildRequires: kf5-kiconthemes-devel >= 5.51.0
34BuildRequires: kf5-kio-devel >= 5.51.0
4bd654df
WF
35BuildRequires: qt5-build >= %{qtver}
36BuildRequires: rpmbuild(macros) >= 1.164
37BuildRequires: shared-mime-info
38BuildRequires: tar >= 1:1.22
39BuildRequires: xz
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43This lib provides incidence editor.
44
45%package devel
46Summary: Header files for %{kaname} development
47Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kaname}
48Group: X11/Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description devel
52Header files for %{kaname} development.
53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe dla programistów używających %{kaname}.
56
57%prep
58%setup -q -n %{kaname}-%{version}
59
60%build
61install -d build
62cd build
63%cmake \
64 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65 ..
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70%{__make} -C build install \
71 DESTDIR=$RPM_BUILD_ROOT
72
73%find_lang %{kaname} --all-name --with-kde
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79%postun -p /sbin/ldconfig
80
81%files -f %{kaname}.lang
82%defattr(644,root,root,755)
055f8cff
WF
83/etc/xdg/incidenceeditor.categories
84/etc/xdg/incidenceeditor.renamecategories
85%attr(755,root,root) %{_bindir}/kincidenceeditor
86%attr(755,root,root) %ghost %{_libdir}/libKF5IncidenceEditor.so.5
87%attr(755,root,root) %{_libdir}/libKF5IncidenceEditor.so.5.*.*
4bd654df
WF
88
89%files devel
90%defattr(644,root,root,755)
055f8cff
WF
91%{_includedir}/KF5/IncidenceEditor
92%{_includedir}/KF5/incidenceeditor
93%{_includedir}/KF5/incidenceeditor_version.h
94%{_libdir}/cmake/KF5IncidenceEditor
95%attr(755,root,root) %{_libdir}/libKF5IncidenceEditor.so
96%{_libdir}/qt5/mkspecs/modules/qt_IncidenceEditor.pri
This page took 0.050441 seconds and 4 git commands to generate.