- updated to 19.04.1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 13 May 2019 09:26:53 +0000 (11:26 +0200)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 13 May 2019 09:26:53 +0000 (11:26 +0200)
- packaged docs
- macro kframever

ka5-eventviews.spec

index 70df9e7bf5828891c935ec778f216e47d2023180..4351d057249a4cb635671e45e86e547c6834dd7b 100644 (file)
@@ -1,14 +1,15 @@
-%define                kdeappsver      18.12.1
+%define                kdeappsver      19.04.1
+%define                kframever       5.56.0
 %define                qtver           5.9.0
 %define                kaname          eventviews
 Summary:       Library for creating events
 Name:          ka5-%{kaname}
-Version:       18.12.1
+Version:       19.04.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: 62a2a1ca5b47647495f37d9b4154c7af
+# Source0-md5: 7f2139325da7a3387891aea192537483
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel >= 5.11.1
@@ -25,14 +26,14 @@ BuildRequires:      ka5-kcalutils-devel >= %{kdeappsver}
 BuildRequires: ka5-kmime-devel >= %{kdeappsver}
 BuildRequires: ka5-libkdepim-devel >= %{kdeappsver}
 BuildRequires: kdiagram-devel >= 1.4.0
-BuildRequires: kf5-extra-cmake-modules >= 5.53.0
-BuildRequires: kf5-kcodecs-devel >= 5.51.0
-BuildRequires: kf5-kcompletion-devel >= 5.51.0
-BuildRequires: kf5-kguiaddons-devel >= 5.51.0
-BuildRequires: kf5-kholidays-devel >= 5.51.0
-BuildRequires: kf5-ki18n-devel >= 5.51.0
-BuildRequires: kf5-kiconthemes-devel >= 5.51.0
-BuildRequires: kf5-kservice-devel >= 5.51.0
+BuildRequires: kf5-extra-cmake-modules >= %{kframever}
+BuildRequires: kf5-kcodecs-devel >= %{kframever}
+BuildRequires: kf5-kcompletion-devel >= %{kframever}
+BuildRequires: kf5-kguiaddons-devel >= %{kframever}
+BuildRequires: kf5-kholidays-devel >= %{kframever}
+BuildRequires: kf5-ki18n-devel >= %{kframever}
+BuildRequires: kf5-kiconthemes-devel >= %{kframever}
+BuildRequires: kf5-kservice-devel >= %{kframever}
 BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
@@ -64,6 +65,7 @@ install -d build
 cd build
 %cmake \
        -G Ninja \
+       -DHTML_INSTALL_DIR=%{_kdedocdir} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
 %ninja_build
This page took 0.058981 seconds and 4 git commands to generate.