- updated to 18.12.1; ninja auto/th/ka5-eventviews-18.12.1-1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 12 Jan 2019 16:45:21 +0000 (17:45 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 12 Jan 2019 16:45:21 +0000 (17:45 +0100)
ka5-eventviews.spec

index ac78aa65082117398997bc66a0f525bd47a49667..70df9e7bf5828891c935ec778f216e47d2023180 100644 (file)
@@ -1,14 +1,14 @@
-%define                kdeappsver      18.12.0
+%define                kdeappsver      18.12.1
 %define                qtver           5.9.0
 %define                kaname          eventviews
 Summary:       Library for creating events
 Name:          ka5-%{kaname}
-Version:       18.12.0
+Version:       18.12.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: d9840f1af87ca727367d51e1be9b0a2b
+# Source0-md5: 62a2a1ca5b47647495f37d9b4154c7af
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel >= 5.11.1
@@ -17,13 +17,13 @@ BuildRequires:      Qt5UiTools-devel
 BuildRequires: Qt5Widgets-devel
 BuildRequires: cmake >= 2.8.12
 BuildRequires: gettext-devel
-BuildRequires: ka5-akonadi-calendar-devel >= 18.12.0
-BuildRequires: ka5-akonadi-devel >= 18.12.0
-BuildRequires: ka5-calendarsupport-devel >= 18.12.0
-BuildRequires: ka5-kcalcore-devel >= 18.12.0
-BuildRequires: ka5-kcalutils-devel >= 18.12.0
-BuildRequires: ka5-kmime-devel >= 18.12.0
-BuildRequires: ka5-libkdepim-devel >= 18.12.0
+BuildRequires: ka5-akonadi-calendar-devel >= %{kdeappsver}
+BuildRequires: ka5-akonadi-devel >= %{kdeappsver}
+BuildRequires: ka5-calendarsupport-devel >= %{kdeappsver}
+BuildRequires: ka5-kcalcore-devel >= %{kdeappsver}
+BuildRequires: ka5-kcalutils-devel >= %{kdeappsver}
+BuildRequires: ka5-kmime-devel >= %{kdeappsver}
+BuildRequires: ka5-libkdepim-devel >= %{kdeappsver}
 BuildRequires: kdiagram-devel >= 1.4.0
 BuildRequires: kf5-extra-cmake-modules >= 5.53.0
 BuildRequires: kf5-kcodecs-devel >= 5.51.0
@@ -33,6 +33,7 @@ BuildRequires:        kf5-kholidays-devel >= 5.51.0
 BuildRequires: kf5-ki18n-devel >= 5.51.0
 BuildRequires: kf5-kiconthemes-devel >= 5.51.0
 BuildRequires: kf5-kservice-devel >= 5.51.0
+BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: shared-mime-info
@@ -62,14 +63,14 @@ Pliki nagłówkowe dla programistów używających %{kaname}.
 install -d build
 cd build
 %cmake \
+       -G Ninja \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kaname} --all-name --with-kde
 
This page took 0.077795 seconds and 4 git commands to generate.