- updated to 19.04.1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 13 May 2019 09:26:24 +0000 (11:26 +0200)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 13 May 2019 09:26:24 +0000 (11:26 +0200)
- packaged docs
- macro kframever

ka5-cantor.spec

index 678cc8cbbe7f1cca27254465db2e01f3a196aa20..f8e5337c2ddb58121d3844256364d22c3fb68a7e 100644 (file)
@@ -1,14 +1,15 @@
-%define                kdeappsver      18.12.1
+%define                kdeappsver      19.04.1
+%define                kframever       5.56.0
 %define                qtver           5.9.0
 %define                kaname          cantor
 Summary:       Cantor
 Name:          ka5-%{kaname}
-Version:       18.12.1
+Version:       19.04.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: d8dd65e5256f1c9e3dbb74bde0d95593
+# Source0-md5: 0a2d78da9b7a785adeddd1094e9bbe67
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel
@@ -21,24 +22,26 @@ BuildRequires:      Qt5Xml-devel
 BuildRequires: Qt5XmlPatterns-devel
 BuildRequires: cmake >= 2.8.12
 BuildRequires: gettext-devel
-BuildRequires: kf5-extra-cmake-modules >= 5.53.0
-BuildRequires: kf5-karchive-devel >= 5.49.0
-BuildRequires: kf5-kcompletion-devel >= 5.49.0
-BuildRequires: kf5-kconfig-devel >= 5.49.0
-BuildRequires: kf5-kcoreaddons-devel >= 5.49.0
-BuildRequires: kf5-kcrash-devel >= 5.49.0
-BuildRequires: kf5-kdoctools-devel >= 5.49.0
-BuildRequires: kf5-ki18n-devel >= 5.49.0
-BuildRequires: kf5-kiconthemes-devel >= 5.49.0
-BuildRequires: kf5-kio-devel >= 5.49.0
-BuildRequires: kf5-knewstuff-devel >= 5.49.0
-BuildRequires: kf5-kparts-devel >= 5.49.0
-BuildRequires: kf5-kpty-devel >= 5.49.0
-BuildRequires: kf5-ktexteditor-devel >= 5.49.0
-BuildRequires: kf5-ktextwidgets-devel >= 5.49.0
-BuildRequires: kf5-kxmlgui-devel >= 5.49.0
-BuildRequires: kf5-syntax-highlighting-devel >= 5.49.0
+BuildRequires: kf5-extra-cmake-modules >= %{kframever}
+BuildRequires: kf5-karchive-devel >= %{kframever}
+BuildRequires: kf5-kcompletion-devel >= %{kframever}
+BuildRequires: kf5-kconfig-devel >= %{kframever}
+BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
+BuildRequires: kf5-kcrash-devel >= %{kframever}
+BuildRequires: kf5-kdoctools-devel >= %{kframever}
+BuildRequires: kf5-ki18n-devel >= %{kframever}
+BuildRequires: kf5-kiconthemes-devel >= %{kframever}
+BuildRequires: kf5-kio-devel >= %{kframever}
+BuildRequires: kf5-knewstuff-devel >= %{kframever}
+BuildRequires: kf5-kparts-devel >= %{kframever}
+BuildRequires: kf5-kpty-devel >= %{kframever}
+BuildRequires: kf5-ktexteditor-devel >= %{kframever}
+BuildRequires: kf5-ktextwidgets-devel >= %{kframever}
+BuildRequires: kf5-kxmlgui-devel >= %{kframever}
+BuildRequires: kf5-syntax-highlighting-devel >= %{kframever}
+BuildRequires: libmarkdown-devel
 BuildRequires: libqalculate-devel >= 2.8.2
+BuildRequires: luajit-devel
 BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
@@ -85,6 +88,7 @@ install -d build
 cd build
 %cmake \
        -G Ninja \
+       -DHTML_INSTALL_DIR=%{_kdedocdir} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
 %ninja_build
@@ -105,6 +109,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 /etc/xdg/cantor.knsrc
 /etc/xdg/cantor_kalgebra.knsrc
+/etc/xdg/cantor_lua.knsrc
 /etc/xdg/cantor_maxima.knsrc
 /etc/xdg/cantor_octave.knsrc
 /etc/xdg/cantor_python2.knsrc
@@ -139,6 +144,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/qt5/plugins/cantor/assistants/cantor_solveassistant.so
 %dir %{_libdir}/qt5/plugins/cantor/backends
 %attr(755,root,root) %{_libdir}/qt5/plugins/cantor/backends/cantor_kalgebrabackend.so
+%attr(755,root,root) %{_libdir}/qt5/plugins/cantor/backends/cantor_luabackend.so
 %attr(755,root,root) %{_libdir}/qt5/plugins/cantor/backends/cantor_maximabackend.so
 %attr(755,root,root) %{_libdir}/qt5/plugins/cantor/backends/cantor_nullbackend.so
 %attr(755,root,root) %{_libdir}/qt5/plugins/cantor/backends/cantor_octavebackend.so
@@ -199,9 +205,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kxmlgui5/cantor/cantor_runscript_assistant.rc
 %{_datadir}/kxmlgui5/cantor/cantor_solve_assistant.rc
 %{_datadir}/metainfo/org.kde.cantor.appdata.xml
+%{_datadir}/config.kcfg/luabackend.kcfg
 
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/cantor
 %attr(755,root,root) %{_libdir}/libcantorlibs.so
-
+%{_libdir}/cmake/Cantor
This page took 0.276756 seconds and 4 git commands to generate.