]> git.pld-linux.org Git - packages/jquery-touchswipe.git/blame - jquery-touchswipe.spec
new, version 1.6.6
[packages/jquery-touchswipe.git] / jquery-touchswipe.spec
CommitLineData
807699a2
ER
1%define plugin touchSwipe
2Summary: A jQuery plugin for touch devices
3Name: jquery-touchswipe
4Version: 1.6.6
5Release: 1
6License: MIT/GPL
7Group: Applications/WWW
8Source0: https://github.com/mattbryson/TouchSwipe-Jquery-Plugin/archive/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: 98115bae96b53f2f8294fcfed87b7e54
10URL: http://labs.rampinteractive.co.uk/touchSwipe/demos/
11BuildRequires: unzip
12Requires: jquery
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%define _appdir %{_datadir}/jquery/%{plugin}
17
18%description
19A jQuery plugin to be used on touch devices such as iPad, iPhone,
20Android, etc.
21
22Detects single and multiple finger swipes, pinches and falls back to
23mouse 'drags' on the desktop.
24
25Time and distance thresholds can be set to destinguish between swipe
26gesture and slow drag.
27
28Allows exclusion of child elements (interactive elements) as well
29allowing page scrolling or page zooming depending on configuration.
30
31%package demo
32Summary: Demo for jQuery.%{plugin}
33Summary(pl.UTF-8): Pliki demonstracyjne dla pakietu jQuery.%{plugin}
34Group: Development
35Requires: %{name} = %{version}-%{release}
36
37%description demo
38Demonstrations and samples for jQuery.%{plugin}.
39
40%prep
41%setup -qc
42mv TouchSwipe-Jquery-Plugin-%{version}/* .
43
44%install
45rm -rf $RPM_BUILD_ROOT
46install -d $RPM_BUILD_ROOT{%{_appdir},%{_examplesdir}/%{name}-%{version}}
47
48cp -p jquery.%{plugin}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.min.js
49ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.js
50ln -s %{plugin}-%{version}.min.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.min.js
51
52cp -p jquery.%{plugin}.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}-%{version}.src.js
53ln -s %{plugin}-%{version}.src.js $RPM_BUILD_ROOT%{_appdir}/%{plugin}.src.js
54
55install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56cp -a demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%{_appdir}
64
65%files demo
66%defattr(644,root,root,755)
67%{_examplesdir}/%{name}-%{version}
This page took 0.065852 seconds and 4 git commands to generate.