]> git.pld-linux.org Git - packages/jquery-fancybox.git/blobdiff - jquery-fancybox.spec
- allow skip packing with -debug
[packages/jquery-fancybox.git] / jquery-fancybox.spec
index d73ab5027bb2fbe1076be81ee1901432c1e4ce4a..3d525b9d8ebef8ac7065b9fd9c4db680fbe063a4 100644 (file)
@@ -1,5 +1,5 @@
 # TODO
-# - pkg for mousewheel
+# - pkg for optional mousewheel?
 %define                plugin  fancybox
 Summary:       Fancybox - Fancy lightbox alternative
 Name:          jquery-%{plugin}
@@ -80,14 +80,22 @@ install -d build
 # compress .js
 for js in fancybox/*.js; do
        out=build/${js#*/jquery.}
+%if 0%{!?debug:1}
        yuicompressor --charset UTF-8 $js -o $out
        js -C -f $out
+%else
+       cp -a $js $out
+%endif
 done
 
 # pack .css
 for css in fancybox/*.css; do
        out=build/${css#*/jquery.}
+%if 0%{!?debug:1}
        yuicompressor --charset UTF-8 $css -o $out
+%else
+       cp -a $css $out
+%endif
 done
 
 cp -a fancybox/*.png build
This page took 0.080813 seconds and 4 git commands to generate.