]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- updated to 0.14.1
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4fca7b80 4
fb44557a
JB
5Summary: Generic formula compulation library
6Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
7Name: ixion
a1c26094 8Version: 0.14.1
c796b99b 9Release: 1
0885abe8 10License: MPL v2.0
fb44557a 11Group: Libraries
ef81fbd2 12#Source0Download: https://gitlab.com/ixion/ixion
0885abe8 13Source0: http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
a1c26094 14# Source0-md5: ab6b645987e4f3e2df2e4d5debace7f7
0885abe8 15Patch0: %{name}-flags.patch
ef81fbd2 16URL: https://gitlab.com/ixion/ixion
b8fb894e 17BuildRequires: autoconf >= 2.63
f369ddf3 18BuildRequires: automake >= 1:1.11
fb44557a 19BuildRequires: boost-devel >= 1.36
0885abe8 20BuildRequires: libstdc++-devel >= 6:4.7
940f72a8 21BuildRequires: libtool >= 2:2
c796b99b 22BuildRequires: mdds-devel >= 1.4.0
4fca7b80 23BuildRequires: pkgconfig
9c6a3add
JB
24BuildRequires: python3 >= 1:3.4
25BuildRequires: python3-devel >= 1:3.4
7439de13 26BuildRequires: rpmbuild(macros) >= 1.734
ef81fbd2
JB
27BuildRequires: tar >= 1:1.22
28BuildRequires: xz
fb44557a
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Ixion aims to provide a library for calculating the results of formula
33expressions stored in multiple named targets, or "cells". The cells
34can be referenced from each other, and the library takes care of
35resolving their dependencies automatically upon calculation. The
36caller can run the calculation routine either in a single-threaded
37mode, or a multi-threaded mode. The library also supports
38re-calculation where the contents of one or more cells have been
39modified since the last calculation, and a partial calculation of only
40the affected cells gets performed. It is written entirely in C++, and
41makes extensive use of the boost library to achieve portability across
42different platforms.
43
44%description -l pl.UTF-8
45Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
46wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
47"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
48biblioteka dba o automatyczne rozwiązywanie ich zależności przy
49obliczeniach. Procedura obliczająca może być wywołana w trybie
50jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
51przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
52komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
53komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
54C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
55przenośność na wiele platform.
56
57%package devel
58Summary: Development files for ixion
59Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: boost-devel >= 1.36
63Requires: libstdc++-devel
0885abe8 64Requires: mdds-devel >= 1.2.0
fb44557a
JB
65
66%description devel
67This package contains the header files for developing applications
68that use ixion.
69
70%description devel -l pl.UTF-8
71Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
72ixion.
73
74%package static
75Summary: Static ixion library
76Summary(pl.UTF-8): Statyczna biblioteka ixion
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79
80%description static
81Static ixion library.
82
83%description static -l pl.UTF-8
84Statyczna biblioteka ixion.
85
0885abe8
JB
86%package -n python3-ixion
87Summary: Python 3 interface to ixion library
88Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki ixion
ef81fbd2
JB
89Group: Libraries/Python
90Requires: %{name} = %{version}-%{release}
9c6a3add 91Requires: python3-libs >= 1:3.4
0885abe8
JB
92# python 2 is no longer supported
93Obsoletes: python-ixion
ef81fbd2 94
0885abe8
JB
95%description -n python3-ixion
96Python 3 interface to ixion library.
ef81fbd2 97
0885abe8
JB
98%description -n python3-ixion -l pl.UTF-8
99Interfejs Pythona 3 do biblioteki ixion.
ef81fbd2 100
fb44557a 101%prep
0885abe8 102%setup -q -n libixion-%{version}
70d27115 103%patch0 -p1
fb44557a
JB
104
105%build
b8fb894e
JB
106%{__libtoolize}
107%{__aclocal} -I m4
108%{__autoconf}
109%{__automake}
fb44557a 110%configure \
940f72a8
JB
111 --disable-silent-rules \
112 %{?with_static_libs:--enable-static}
fb44557a
JB
113
114%{__make}
115
116
117%install
118rm -rf $RPM_BUILD_ROOT
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
121
0885abe8 122%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.la
ef81fbd2 123%if %{with static_libs}
0885abe8 124%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.a
ef81fbd2 125%endif
fb44557a
JB
126# obsoleted by pkg-config
127%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post -p /sbin/ldconfig
133%postun -p /sbin/ldconfig
134
135%files
136%defattr(644,root,root,755)
a1c26094 137%doc AUTHORS LICENSE
cec02f4e 138%attr(755,root,root) %{_bindir}/ixion-formula-tokenizer
fb44557a
JB
139%attr(755,root,root) %{_bindir}/ixion-parser
140%attr(755,root,root) %{_bindir}/ixion-sorter
c796b99b
AG
141%attr(755,root,root) %{_libdir}/libixion-0.14.so.*.*.*
142%attr(755,root,root) %ghost %{_libdir}/libixion-0.14.so.0
fb44557a
JB
143
144%files devel
145%defattr(644,root,root,755)
c796b99b
AG
146%attr(755,root,root) %{_libdir}/libixion-0.14.so
147%{_includedir}/libixion-0.14
148%{_pkgconfigdir}/libixion-0.14.pc
fb44557a
JB
149
150%if %{with static_libs}
151%files static
152%defattr(644,root,root,755)
c796b99b 153%{_libdir}/libixion-0.14.a
fb44557a 154%endif
ef81fbd2 155
0885abe8 156%files -n python3-ixion
ef81fbd2 157%defattr(644,root,root,755)
0885abe8 158%attr(755,root,root) %{py3_sitedir}/ixion.so
This page took 0.090153 seconds and 4 git commands to generate.