]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- rebuild with python 3.8
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
c25abc2a 3%bcond_without apidocs # Sphinx documentation
fb44557a 4%bcond_without static_libs # static library
4fca7b80 5
fb44557a
JB
6Summary: Generic formula compulation library
7Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
8Name: ixion
a1c26094 9Version: 0.14.1
3d748cf6 10Release: 4
0885abe8 11License: MPL v2.0
fb44557a 12Group: Libraries
c25abc2a 13#Source0Download: https://gitlab.com/ixion/ixion/raw/master/README.md
0885abe8 14Source0: http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
a1c26094 15# Source0-md5: ab6b645987e4f3e2df2e4d5debace7f7
0885abe8 16Patch0: %{name}-flags.patch
ef81fbd2 17URL: https://gitlab.com/ixion/ixion
b8fb894e 18BuildRequires: autoconf >= 2.63
f369ddf3 19BuildRequires: automake >= 1:1.11
fb44557a 20BuildRequires: boost-devel >= 1.36
0885abe8 21BuildRequires: libstdc++-devel >= 6:4.7
940f72a8 22BuildRequires: libtool >= 2:2
c796b99b 23BuildRequires: mdds-devel >= 1.4.0
4fca7b80 24BuildRequires: pkgconfig
9c6a3add
JB
25BuildRequires: python3 >= 1:3.4
26BuildRequires: python3-devel >= 1:3.4
7439de13 27BuildRequires: rpmbuild(macros) >= 1.734
ef81fbd2
JB
28BuildRequires: tar >= 1:1.22
29BuildRequires: xz
c25abc2a
JB
30%if %{with apidocs}
31BuildRequires: doxygen
32BuildRequires: python3-breathe
33BuildRequires: python3-sphinx_bootstrap_theme
34BuildRequires: sphinx-pdg-3
35%endif
fb44557a
JB
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Ixion aims to provide a library for calculating the results of formula
40expressions stored in multiple named targets, or "cells". The cells
41can be referenced from each other, and the library takes care of
42resolving their dependencies automatically upon calculation. The
43caller can run the calculation routine either in a single-threaded
44mode, or a multi-threaded mode. The library also supports
45re-calculation where the contents of one or more cells have been
46modified since the last calculation, and a partial calculation of only
47the affected cells gets performed. It is written entirely in C++, and
48makes extensive use of the boost library to achieve portability across
49different platforms.
50
51%description -l pl.UTF-8
52Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
53wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
54"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
55biblioteka dba o automatyczne rozwiązywanie ich zależności przy
56obliczeniach. Procedura obliczająca może być wywołana w trybie
57jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
58przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
59komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
60komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
61C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
62przenośność na wiele platform.
63
64%package devel
65Summary: Development files for ixion
66Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: boost-devel >= 1.36
c25abc2a
JB
70Requires: libstdc++-devel >= 6:4.7
71Requires: mdds-devel >= 1.4.0
fb44557a
JB
72
73%description devel
74This package contains the header files for developing applications
75that use ixion.
76
77%description devel -l pl.UTF-8
78Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
79ixion.
80
81%package static
82Summary: Static ixion library
83Summary(pl.UTF-8): Statyczna biblioteka ixion
84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
86
87%description static
88Static ixion library.
89
90%description static -l pl.UTF-8
91Statyczna biblioteka ixion.
92
c25abc2a
JB
93%package apidocs
94Summary: API documentation for ixion library
95Summary(pl.UTF-8): Dokumentacja API biblioteki ixion
96Group: Documentation
97
98%description apidocs
99API documentation for ixion library.
100
101%description apidocs -l pl.UTF-8
102Dokumentacja API biblioteki ixion.
103
0885abe8
JB
104%package -n python3-ixion
105Summary: Python 3 interface to ixion library
106Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki ixion
ef81fbd2
JB
107Group: Libraries/Python
108Requires: %{name} = %{version}-%{release}
9c6a3add 109Requires: python3-libs >= 1:3.4
0885abe8
JB
110# python 2 is no longer supported
111Obsoletes: python-ixion
ef81fbd2 112
0885abe8
JB
113%description -n python3-ixion
114Python 3 interface to ixion library.
ef81fbd2 115
0885abe8
JB
116%description -n python3-ixion -l pl.UTF-8
117Interfejs Pythona 3 do biblioteki ixion.
ef81fbd2 118
fb44557a 119%prep
0885abe8 120%setup -q -n libixion-%{version}
70d27115 121%patch0 -p1
fb44557a
JB
122
123%build
b8fb894e
JB
124%{__libtoolize}
125%{__aclocal} -I m4
126%{__autoconf}
127%{__automake}
fb44557a 128%configure \
940f72a8
JB
129 --disable-silent-rules \
130 %{?with_static_libs:--enable-static}
fb44557a
JB
131
132%{__make}
133
c25abc2a
JB
134%if %{with apidocs}
135cd doc
136doxygen doxygen.conf
137sphinx-build-3 -b html . _build
138%endif
fb44557a
JB
139
140%install
141rm -rf $RPM_BUILD_ROOT
c25abc2a 142
fb44557a
JB
143%{__make} install \
144 DESTDIR=$RPM_BUILD_ROOT
145
0885abe8 146%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.la
ef81fbd2 147%if %{with static_libs}
0885abe8 148%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.a
ef81fbd2 149%endif
fb44557a
JB
150# obsoleted by pkg-config
151%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post -p /sbin/ldconfig
157%postun -p /sbin/ldconfig
158
159%files
160%defattr(644,root,root,755)
a1c26094 161%doc AUTHORS LICENSE
cec02f4e 162%attr(755,root,root) %{_bindir}/ixion-formula-tokenizer
fb44557a
JB
163%attr(755,root,root) %{_bindir}/ixion-parser
164%attr(755,root,root) %{_bindir}/ixion-sorter
c796b99b
AG
165%attr(755,root,root) %{_libdir}/libixion-0.14.so.*.*.*
166%attr(755,root,root) %ghost %{_libdir}/libixion-0.14.so.0
fb44557a
JB
167
168%files devel
169%defattr(644,root,root,755)
c796b99b
AG
170%attr(755,root,root) %{_libdir}/libixion-0.14.so
171%{_includedir}/libixion-0.14
172%{_pkgconfigdir}/libixion-0.14.pc
fb44557a
JB
173
174%if %{with static_libs}
175%files static
176%defattr(644,root,root,755)
c796b99b 177%{_libdir}/libixion-0.14.a
fb44557a 178%endif
ef81fbd2 179
c25abc2a
JB
180%if %{with apidocs}
181%files apidocs
182%defattr(644,root,root,755)
100dfb54 183%doc doc/_build/{_static,cpp,overview,python,*.html,*.js}
c25abc2a
JB
184%endif
185
0885abe8 186%files -n python3-ixion
ef81fbd2 187%defattr(644,root,root,755)
0885abe8 188%attr(755,root,root) %{py3_sitedir}/ixion.so
This page took 0.117579 seconds and 4 git commands to generate.