]> git.pld-linux.org Git - packages/ixgbe.git/commitdiff
- up to 4.1.2 auto/th/ixgbe-4.1.2-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Sep 2015 19:14:32 +0000 (21:14 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Sep 2015 19:14:50 +0000 (21:14 +0200)
- fix building with linux 4.2

ixgbe.spec
linux-4.1.patch
linux-4.2.patch [new file with mode: 0644]

index 643a1e94cce5c4a655da0ce9e1ec52b7f1f7fc3e..6aab28b8fa6f6e24b0873ff9be325c7871f94189 100644 (file)
@@ -9,13 +9,14 @@
 Summary:       Intel(R) 10 Gigabit driver for Linux
 Summary(pl.UTF-8):     Sterownik do karty Intel(R) 10 Gigabit
 Name:          %{pname}%{_alt_kernel}
-Version:       4.1.1
+Version:       4.1.2
 Release:       %{rel}@%{_kernel_ver_str}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
-# Source0-md5: a9f21c59f7189d3e0f3e97a8cd812670
+# Source0-md5: 191f7b0f31596cc0edc7e870ca05d037
 Patch0:                linux-4.1.patch
+Patch1:                linux-4.2.patch
 URL:           http://sourceforge.net/projects/e1000/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpmbuild(macros) >= 1.701
@@ -79,6 +80,7 @@ EOF\
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 cp src/Makefile src/Makefile.%{name}
 cat > src/Makefile <<'EOF'
index 80afa645b22cf39bc80fd233fb2a42e466ba7188..d1f3c109144656e324b5888a778ac8aed07536bc 100644 (file)
        return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0);
  #else
        return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode);
---- ixgbe-4.1.1/src/kcompat.h~ 2015-04-30 02:13:22.000000000 +0200
-+++ ixgbe-4.1.1/src/kcompat.h  2015-07-04 14:44:02.702152426 +0200
-@@ -4539,6 +4539,7 @@
- #endif
- #else
- #define HAVE_PTP_CLOCK_INFO_GETTIME64
-+#define HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
- #endif /* 4,1,0 */
- #endif /* _KCOMPAT_H_ */
diff --git a/linux-4.2.patch b/linux-4.2.patch
new file mode 100644 (file)
index 0000000..57a8c5b
--- /dev/null
@@ -0,0 +1,27 @@
+--- ixgbe-4.1.2/src/ixgbe_main.c~      2015-09-27 11:47:47.000000000 +0200
++++ ixgbe-4.1.2/src/ixgbe_main.c       2015-09-27 21:07:30.561309223 +0200
+@@ -2079,8 +2079,12 @@
+ static inline bool ixgbe_page_is_reserved(struct page *page)
+ {
+ #ifdef HAVE_STRUCT_PAGE_PFMEMALLOC
++#if ( LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0) )
+       return (page_to_nid(page) != numa_mem_id()) || page->pfmemalloc;
+ #else
++      return (page_to_nid(page) != numa_mem_id()) || page_is_pfmemalloc(page);
++#endif
++#else
+       return (page_to_nid(page) != numa_mem_id());
+ #endif
+ }
+@@ -9473,7 +9473,11 @@
+       mode = adapter->bridge_mode;
+ #ifdef HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
++#if ( LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0) )
+       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0, nlflags);
++#else
++      return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0, nlflags, filter_mask, NULL);
++#endif
+ #elif defined(HAVE_NDO_FDB_ADD_VID)
+       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0);
+ #else
This page took 0.065303 seconds and 4 git commands to generate.