]> git.pld-linux.org Git - packages/ixgbe.git/commitdiff
- updated to 4.1.5 auto/th/ixgbe-4.1.5-1
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 1 Oct 2015 06:15:02 +0000 (08:15 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 1 Oct 2015 06:15:02 +0000 (08:15 +0200)
ixgbe.spec
linux-4.1.9.patch [new file with mode: 0644]
linux-4.1.patch [deleted file]
linux-4.2.patch [deleted file]

index 6aab28b8fa6f6e24b0873ff9be325c7871f94189..873bceec255a69126807b3c548b5cef55dff6db7 100644 (file)
@@ -9,14 +9,13 @@
 Summary:       Intel(R) 10 Gigabit driver for Linux
 Summary(pl.UTF-8):     Sterownik do karty Intel(R) 10 Gigabit
 Name:          %{pname}%{_alt_kernel}
-Version:       4.1.2
+Version:       4.1.5
 Release:       %{rel}@%{_kernel_ver_str}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
-# Source0-md5: 191f7b0f31596cc0edc7e870ca05d037
-Patch0:                linux-4.1.patch
-Patch1:                linux-4.2.patch
+# Source0-md5: 8b7b97e6556eebd13ca12d5cff72d1e9
+Patch0:                linux-4.1.9.patch
 URL:           http://sourceforge.net/projects/e1000/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpmbuild(macros) >= 1.701
@@ -80,7 +79,6 @@ EOF\
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
-%patch1 -p1
 
 cp src/Makefile src/Makefile.%{name}
 cat > src/Makefile <<'EOF'
diff --git a/linux-4.1.9.patch b/linux-4.1.9.patch
new file mode 100644 (file)
index 0000000..ebf09fe
--- /dev/null
@@ -0,0 +1,23 @@
+--- ixgbe-4.1.5/src/kcompat.h~ 2015-10-01 08:09:48.000000000 +0200
++++ ixgbe-4.1.5/src/kcompat.h  2015-10-01 08:11:39.877868999 +0200
+@@ -4637,7 +4637,7 @@
+ #define HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
+ #endif /* 4,1,0 */
+-#if ( LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0) )
++#if ( (LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0)) && !(LINUX_VERSION_CODE >= KERNEL_VERSION(4,1,9)) )
+ #if (!(SLE_VERSION_CODE && SLE_VERSION_CODE >= SLE_VERSION(12,1,0)))
+ static inline bool page_is_pfmemalloc(struct page __maybe_unused *page)
+ {
+@@ -4650,8 +4650,10 @@
+ #endif /* !SLES12sp1 */
+ #else
+-#define HAVE_NDO_DFLT_BRIDGE_GETLINK_VLAN_SUPPORT
+ #undef HAVE_STRUCT_PAGE_PFMEMALLOC
+ #endif /* 4.2.0 */
++#if ( LINUX_VERSION_CODE >= KERNEL_VERSION(4,2,0) )
++#define HAVE_NDO_DFLT_BRIDGE_GETLINK_VLAN_SUPPORT
++#endif /* 4.2.0 */
+ #endif /* _KCOMPAT_H_ */
diff --git a/linux-4.1.patch b/linux-4.1.patch
deleted file mode 100644 (file)
index d1f3c10..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- ixgbe-4.1.1/src/ixgbe_main.c~      2015-04-30 02:13:22.000000000 +0200
-+++ ixgbe-4.1.1/src/ixgbe_main.c       2015-07-04 14:40:47.319817216 +0200
-@@ -9447,7 +9447,11 @@
-       return 0;
- }
--#ifdef HAVE_BRIDGE_FILTER
-+#ifdef HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
-+static int ixgbe_ndo_bridge_getlink(struct sk_buff *skb, u32 pid, u32 seq,
-+                                struct net_device *dev, u32 filter_mask,
-+                                int nlflags)
-+#elif defined(HAVE_BRIDGE_FILTER)
- static int ixgbe_ndo_bridge_getlink(struct sk_buff *skb, u32 pid, u32 seq,
-                                   struct net_device *dev,
-                                   u32 __always_unused filter_mask)
-@@ -9464,7 +9464,9 @@
-       mode = adapter->bridge_mode;
--#ifdef HAVE_NDO_FDB_ADD_VID
-+#ifdef HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
-+      return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0, nlflags);
-+#elif defined(HAVE_NDO_FDB_ADD_VID)
-       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0);
- #else
-       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode);
diff --git a/linux-4.2.patch b/linux-4.2.patch
deleted file mode 100644 (file)
index 57a8c5b..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
---- ixgbe-4.1.2/src/ixgbe_main.c~      2015-09-27 11:47:47.000000000 +0200
-+++ ixgbe-4.1.2/src/ixgbe_main.c       2015-09-27 21:07:30.561309223 +0200
-@@ -2079,8 +2079,12 @@
- static inline bool ixgbe_page_is_reserved(struct page *page)
- {
- #ifdef HAVE_STRUCT_PAGE_PFMEMALLOC
-+#if ( LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0) )
-       return (page_to_nid(page) != numa_mem_id()) || page->pfmemalloc;
- #else
-+      return (page_to_nid(page) != numa_mem_id()) || page_is_pfmemalloc(page);
-+#endif
-+#else
-       return (page_to_nid(page) != numa_mem_id());
- #endif
- }
-@@ -9473,7 +9473,11 @@
-       mode = adapter->bridge_mode;
- #ifdef HAVE_NDO_BRIDGE_GETLINK_NLFLAGS
-+#if ( LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0) )
-       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0, nlflags);
-+#else
-+      return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0, nlflags, filter_mask, NULL);
-+#endif
- #elif defined(HAVE_NDO_FDB_ADD_VID)
-       return ndo_dflt_bridge_getlink(skb, pid, seq, dev, mode, 0, 0);
- #else
This page took 0.114076 seconds and 4 git commands to generate.