]> git.pld-linux.org Git - packages/ixgbe.git/blame - ixgbe.spec
- release 3
[packages/ixgbe.git] / ixgbe.spec
CommitLineData
50ec253d 1# Conditional build:
2%bcond_without dist_kernel # allow non-distribution kernel
3%bcond_without kernel # don't build kernel modules
4%bcond_with verbose # verbose build (V=1)
5
6%ifarch sparc
7%undefine with_smp
8%endif
9
10%if %{without kernel}
11%undefine with_dist_kernel
12%endif
13%if "%{_alt_kernel}" != "%{nil}"
14%undefine with_userspace
15%endif
16
094eb0d3 17%define rel 3
50ec253d 18%define pname ixgbe
aa371a67 19Summary: Intel(R) 10 Gigabit driver for Linux
20Summary(pl.UTF-8): Sterownik do karty Intel(R) 10 Gigabit
50ec253d 21Name: %{pname}%{_alt_kernel}
e2ebe1c9 22Version: 1.3.56.5
50ec253d 23Release: %{rel}
24License: GPL v2
25Group: Base/Kernel
26Source0: http://dl.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
e2ebe1c9 27# Source0-md5: ee143098c4e6173c4e77501744dda33f
50ec253d 28URL: http://sourceforge.net/projects/e1000/
29%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
30BuildRequires: rpmbuild(macros) >= 1.379
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This package contains the Linux driver for the Intel(R) 10 Gigabit
be42ab64 35adapters with 82598EB chipset.
50ec253d 36
37%description -l pl.UTF-8
87dbbcf7 38Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych z rodziny
be42ab64 39Intel(R) 10 Gigabit opartych o układ 82598EB.
50ec253d 40
41%package -n kernel%{_alt_kernel}-net-ixgbe
aa371a67 42Summary: Intel(R) 10 Gigabit driver for Linux
43Summary(pl.UTF-8): Sterownik do karty Intel(R) 10 Gigabit
50ec253d 44Release: %{rel}@%{_kernel_ver_str}
45Group: Base/Kernel
46Requires(post,postun): /sbin/depmod
47%if %{with dist_kernel}
48%requires_releq_kernel
49Requires(postun): %releq_kernel
50%endif
51
52%description -n kernel%{_alt_kernel}-net-ixgbe
53This package contains the Linux driver for the Intel(R) 10 Gigabit
be42ab64 54adapters with 82598EB chipset.
50ec253d 55
56%description -n kernel%{_alt_kernel}-net-ixgbe -l pl.UTF-8
87dbbcf7 57Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych z rodziny
be42ab64 58Intel(R) 10 Gigabit opartych o układ 82598EB.
50ec253d 59
60%prep
61%setup -q -n %{pname}-%{version}
62cat > src/Makefile <<'EOF'
63obj-m := ixgbe.o
64ixgbe-objs := ixgbe_82598.o ixgbe_main.o ixgbe_param.o ixgbe_ethtool.o \
65kcompat.o ixgbe_api.o ixgbe_phy.o ixgbe_common.o
66
67EXTRA_CFLAGS=-DDRIVER_IXGBE
68EOF
69
70%build
71%build_kernel_modules -C src -m %{pname}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75%install_kernel_modules -m src/%{pname} -d kernel/drivers/net -n %{pname} -s current
76# blacklist kernel module
77cat > $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/%{pname}.conf <<'EOF'
78blacklist ixgbe
79alias ixgbe ixgbe-current
80EOF
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -n kernel%{_alt_kernel}-net-ixgbe
86%depmod %{_kernel_ver}
87
88%postun -n kernel%{_alt_kernel}-net-ixgbe
89%depmod %{_kernel_ver}
90
91%files -n kernel%{_alt_kernel}-net-ixgbe
92%defattr(644,root,root,755)
93%doc ixgbe.7 README
94/etc/modprobe.d/%{_kernel_ver}/%{pname}.conf
95/lib/modules/%{_kernel_ver}/kernel/drivers/net/%{pname}*.ko*
This page took 0.039471 seconds and 4 git commands to generate.