]> git.pld-linux.org Git - packages/ixgbe.git/blame - ixgbe.spec
- rebuild for kernel-3.9.4-3
[packages/ixgbe.git] / ixgbe.spec
CommitLineData
50ec253d 1# Conditional build:
2%bcond_without dist_kernel # allow non-distribution kernel
3%bcond_without kernel # don't build kernel modules
4%bcond_with verbose # verbose build (V=1)
5
6%ifarch sparc
7%undefine with_smp
8%endif
9
10%if %{without kernel}
11%undefine with_dist_kernel
12%endif
13%if "%{_alt_kernel}" != "%{nil}"
14%undefine with_userspace
15%endif
16
673b84a1 17%define rel 18
50ec253d 18%define pname ixgbe
aa371a67 19Summary: Intel(R) 10 Gigabit driver for Linux
20Summary(pl.UTF-8): Sterownik do karty Intel(R) 10 Gigabit
50ec253d 21Name: %{pname}%{_alt_kernel}
e5695948 22Version: 3.12.6
50ec253d 23Release: %{rel}
24License: GPL v2
25Group: Base/Kernel
4dd5ebc0 26Source0: http://downloads.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
e5695948 27# Source0-md5: 236e8e1b7f3ce5266a5a9510a9e5bd96
50ec253d 28URL: http://sourceforge.net/projects/e1000/
29%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
30BuildRequires: rpmbuild(macros) >= 1.379
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This package contains the Linux driver for the Intel(R) 10 Gigabit
be42ab64 35adapters with 82598EB chipset.
50ec253d 36
37%description -l pl.UTF-8
87dbbcf7 38Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych z rodziny
be42ab64 39Intel(R) 10 Gigabit opartych o układ 82598EB.
50ec253d 40
41%package -n kernel%{_alt_kernel}-net-ixgbe
aa371a67 42Summary: Intel(R) 10 Gigabit driver for Linux
43Summary(pl.UTF-8): Sterownik do karty Intel(R) 10 Gigabit
50ec253d 44Release: %{rel}@%{_kernel_ver_str}
45Group: Base/Kernel
46Requires(post,postun): /sbin/depmod
47%if %{with dist_kernel}
48%requires_releq_kernel
49Requires(postun): %releq_kernel
50%endif
51
52%description -n kernel%{_alt_kernel}-net-ixgbe
53This package contains the Linux driver for the Intel(R) 10 Gigabit
be42ab64 54adapters with 82598EB chipset.
50ec253d 55
56%description -n kernel%{_alt_kernel}-net-ixgbe -l pl.UTF-8
87dbbcf7 57Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych z rodziny
be42ab64 58Intel(R) 10 Gigabit opartych o układ 82598EB.
50ec253d 59
60%prep
61%setup -q -n %{pname}-%{version}
746efd47 62cp src/Makefile src/Makefile.%{name}
50ec253d 63cat > src/Makefile <<'EOF'
64obj-m := ixgbe.o
493ddae8 65ixgbe-objs := ixgbe_main.o ixgbe_common.o ixgbe_api.o ixgbe_param.o \
746efd47
PG
66ixgbe_lib.o ixgbe_ethtool.o kcompat.o ixgbe_82598.o \
67ixgbe_82599.o ixgbe_ptp.o ixgbe_x540.o ixgbe_sriov.o \
68ixgbe_mbx.o ixgbe_dcb.o ixgbe_dcb_82598.o ixgbe_dcb_82599.o \
69ixgbe_sysfs.o ixgbe_procfs.o ixgbe_phy.o ixgbe_fcoe.o \
e39e28d8 70ixgbe_dcb_nl.o
50ec253d 71
72EXTRA_CFLAGS=-DDRIVER_IXGBE
73EOF
74
75%build
76%build_kernel_modules -C src -m %{pname}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%install_kernel_modules -m src/%{pname} -d kernel/drivers/net -n %{pname} -s current
81# blacklist kernel module
82cat > $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/%{pname}.conf <<'EOF'
83blacklist ixgbe
84alias ixgbe ixgbe-current
85EOF
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -n kernel%{_alt_kernel}-net-ixgbe
91%depmod %{_kernel_ver}
92
93%postun -n kernel%{_alt_kernel}-net-ixgbe
94%depmod %{_kernel_ver}
95
96%files -n kernel%{_alt_kernel}-net-ixgbe
97%defattr(644,root,root,755)
98%doc ixgbe.7 README
99/etc/modprobe.d/%{_kernel_ver}/%{pname}.conf
100/lib/modules/%{_kernel_ver}/kernel/drivers/net/%{pname}*.ko*
This page took 2.007674 seconds and 4 git commands to generate.