]> git.pld-linux.org Git - packages/ipython.git/blame - ipython.spec
- testing dir is needed for debugger; release 2
[packages/ipython.git] / ipython.spec
CommitLineData
00776458 1# NOTE: Python3 version in 'ipython3.spec'
0400c33f 2#
00776458
JB
3# Conditional build:
4%bcond_with doc # Sphinx documentation (need to wait for fulfilling dependencies in PLD)
5%bcond_with tests # unit tests (need to wait for fulfilling dependencies in PLD)
6
e33c22cf 7Summary: An enhanced Interactive Python shell
ff6802f6 8Summary(pl.UTF-8): Interaktywna powłoka języka Python
e33c22cf 9Name: ipython
00776458 10Version: 5.8.0
11f7ae56 11Release: 2
18423dde 12License: BSD
bc92a4bc 13Group: Applications/Shells
62c095d7 14Source0: http://archive.ipython.org/release/%{version}/%{name}-%{version}.tar.gz
00776458
JB
15# Source0-md5: 7014b8824981eef2cb893ea5398d6b8d
16Patch0: %{name}-use-setuptools.patch
17URL: http://ipython.org/
18BuildRequires: pydoc >= 1:2.7
19BuildRequires: python-devel >= 1:2.7
20BuildRequires: python-devel-tools >= 1:2.7
21BuildRequires: python-modules-sqlite >= 1:2.7
22BuildRequires: python-setuptools >= 18.5
4bd9f8e5 23BuildRequires: rpm-pythonprov
00776458
JB
24BuildRequires: rpmbuild(macros) >= 1.714
25%if %{with tests}
26BuildRequires: python-backports-shutil_get_terminal_size
27BuildRequires: python-decorator
28BuildRequires: python-ipykernel
29BuildRequires: python-mock
30BuildRequires: python-nbformat
31BuildRequires: python-nose >= 0.10.1
32BuildRequires: python-pathlib2
33BuildRequires: python-pexpect
34BuildRequires: python-pickleshare
35BuildRequires: python-prompt_toolkit >= 1.0.4
36BuildRequires: python-prompt_toolkit < 2
37BuildRequires: python-pygments
38BuildRequires: python-requests
39BuildRequires: python-simplegeneric >= 0.8
40BuildRequires: python-testpath
41BuildRequires: python-traitlets >= 4.2
42%endif
43%if %{with doc}
44BuildRequires: python-docutils
45BuildRequires: python-ipykernel
46BuildRequires: python-sphinx_rtd_theme
47BuildRequires: sphinx-pdg-2 >= 1.3
48%endif
f1842c5e 49Requires: python-%{name} = %{version}-%{release}
00776458 50Suggests: python-PyQt5
630f58a1 51Suggests: python-zmq
e33c22cf 52BuildArch: noarch
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%description
56IPython is a free software project which tries to:
57
ef8a19a7 581. Provide an interactive interpreter superior to Python's default.
59IPython has many features for object introspection, shell access, and
60its own special command system for adding functionality when working
61interactively.
e33c22cf 62
ef8a19a7 632. Serve as an embeddable, ready to use interpreter for your own
64programs. IPython can be started with a single call from inside
65another program, providing access to the current namespace. This can
66be very useful both for debugging purposes and for situations where a
67blend of batch-processing and interactive exploration are needed.
e33c22cf 68
ef8a19a7 693. Offer a flexible framework which can be used as the base
70environment for other systems with Python as the underlying language.
71Specifically scientific environments like Mathematica, IDL and Mathcad
72inspired its design, but similar ideas can be useful in many fields.
e33c22cf 73
9299d2f0 74This package contains IPython shell.
75
8251843b
JR
76%description -l pl.UTF-8
77IPython jest wolnym oprogramowaniem, którego celem jest:
78
791. Dostarczenie interaktywnej powłoki lepszej od standardowej
80dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
81dostęp do powłoki oraz własny system poleceń, który umożliwia
82rozszerzanie funkcjonalności podczas pracy interaktywnej.
83
842. Dostarczenie gotowego interpretera, który można dołączać do własnej
85aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
86funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
87aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
88do celów takich jak śledzenie programu czy też sytuacji gdzie jest
89wymagane połączenie przetwarzania wsadowego z interaktywną
90introspekcją.
91
923. Dostarczenie szkieletu, który może zostać użyty jako podstawa
93systemu, którego polecenia opierają się na zasadach języka Python.
94Projekt został zainspirowany przez oprogramowanie naukowe takie jak
95Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
9299d2f0 96w wielu przypadkach.
97
8251843b 98Pakiet ten zawiera powłokę IPython.
9299d2f0 99
100%package -n python-ipython
101Summary: An enhanced Interactive Python shell modules
ff6802f6 102Summary(pl.UTF-8): Moduły interaktywnej powłoki języka Python
9299d2f0 103Group: Libraries/Python
00776458
JB
104Requires: pydoc >= 1:2.7
105Requires: python-devel-tools >= 1:2.7
9299d2f0 106
107%description -n python-ipython
108IPython is a free software project which tries to:
109
ef8a19a7 1101. Provide an interactive interpreter superior to Python's default.
111IPython has many features for object introspection, shell access, and
112its own special command system for adding functionality when working
113interactively.
9299d2f0 114
ef8a19a7 1152. Serve as an embeddable, ready to use interpreter for your own
116programs. IPython can be started with a single call from inside
117another program, providing access to the current namespace. This can
118be very useful both for debugging purposes and for situations where a
119blend of batch-processing and interactive exploration are needed.
9299d2f0 120
ef8a19a7 1213. Offer a flexible framework which can be used as the base
122environment for other systems with Python as the underlying language.
123Specifically scientific environments like Mathematica, IDL and Mathcad
124inspired its design, but similar ideas can be useful in many fields.
9299d2f0 125
126This package contains IPython modules.
127
8251843b
JR
128%description -n python-ipython -l pl.UTF-8
129IPython jest wolnym oprogramowaniem, którego celem jest:
130
1311. Dostarczenie interaktywnej powłoki lepszej od standardowej
132dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
133dostęp do powłoki oraz własny system poleceń, który umożliwia
134rozszerzanie funkcjonalności podczas pracy interaktywnej.
135
1362. Dostarczenie gotowego interpretera, który można dołączać do własnej
137aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
138funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
139aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
140do celów takich jak śledzenie programu czy też sytuacji gdzie jest
141wymagane połączenie przetwarzania wsadowego z interaktywną
142introspekcją.
143
1443. Dostarczenie szkieletu, który może zostać użyty jako podstawa
145systemu, którego polecenia opierają się na zasadach języka Python.
146Projekt został zainspirowany przez oprogramowanie naukowe takie jak
147Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
ef8a19a7 148w wielu przypadkach.
149
8251843b 150Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
ef8a19a7 151
e33c22cf 152%prep
2ca4e47a 153%setup -q
00776458
JB
154%patch0 -p1
155
156%build
157%py_build
158
159%if %{with tests}
57882cb5 160%{__python} IPython/testing/iptest.py IPython
00776458
JB
161%endif
162
163%if %{with doc}
164PYTHONPATH=$(pwd) \
165%{__make} -C docs html \
166 SPHINXBUILD=sphinx-build-2
167%endif
e33c22cf 168
169%install
170rm -rf $RPM_BUILD_ROOT
34d62345 171install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
e33c22cf 172
fc0eeeb1 173%py_install
e33c22cf 174
00776458 175cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
34d62345 176
4bd9f8e5 177%py_postclean
00776458
JB
178
179# test suite
180%{__rm} $RPM_BUILD_ROOT%{_bindir}/iptest*
11f7ae56 181%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/IPython/{core/tests,extensions/tests,lib/tests,terminal/tests,testing/tests,utils/tests}
4bd9f8e5 182
e33c22cf 183%clean
184rm -rf $RPM_BUILD_ROOT
185
186%files
187%defattr(644,root,root,755)
00776458
JB
188%attr(755,root,root) %{_bindir}/ipython
189%attr(755,root,root) %{_bindir}/ipython2
190%{_mandir}/man1/ipython.1*
9299d2f0 191
192%files -n python-ipython
193%defattr(644,root,root,755)
00776458
JB
194%doc COPYING.rst README.rst
195%{py_sitescriptdir}/IPython
196%{py_sitescriptdir}/ipython-%{version}-py*.egg-info
197%{_examplesdir}/%{name}-%{version}
This page took 0.723188 seconds and 4 git commands to generate.