]> git.pld-linux.org Git - packages/iproute2.git/commitdiff
- up to 4.16.0 auto/th/iproute2-4.16.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 May 2018 11:36:52 +0000 (13:36 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 May 2018 11:36:52 +0000 (13:36 +0200)
fix-bashisms.patch [deleted file]
iproute2-fou_show.patch [deleted file]
iproute2.spec

diff --git a/fix-bashisms.patch b/fix-bashisms.patch
deleted file mode 100644 (file)
index 796e9bb..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
---- iproute2-3.12.0/ip/ifcfg~  2013-11-23 13:08:41.000000000 +0200
-+++ iproute2-3.12.0/ip/ifcfg   2013-11-23 13:08:46.796879511 +0200
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#! /bin/sh
- CheckForwarding () {
-   local sbase fwd
-@@ -6,7 +6,7 @@
-   fwd=0
-   if [ -d $sbase ]; then
-     for dir in $sbase/*/forwarding; do
--      fwd=$[$fwd + `cat $dir`]
-+      fwd=$(($fwd + `cat $dir`))
-     done
-   else
-     fwd=2
-@@ -127,12 +127,12 @@ fi
- arping -q -A -c 1 -I $dev $ipaddr
- noarp=$?
- ( sleep 2 ;
--  arping -q -U -c 1 -I $dev $ipaddr ) >& /dev/null </dev/null &
-+  arping -q -U -c 1 -I $dev $ipaddr ) >/dev/null 2>&1 </dev/null &
--ip route add unreachable 224.0.0.0/24 >& /dev/null
--ip route add unreachable 255.255.255.255 >& /dev/null
-+ip route add unreachable 224.0.0.0/24 >/dev/null 2>&1
-+ip route add unreachable 255.255.255.255 >/dev/null 2>&1
- if [ "`ip link ls $dev | grep -c MULTICAST`" -ge 1 ]; then
--  ip route add 224.0.0.0/4 dev $dev scope global >& /dev/null
-+  ip route add 224.0.0.0/4 dev $dev scope global >/dev/null 2>&1
- fi
- if [ $fwd -eq 0 ]; then
---- iproute2-3.12.0/ip/rtpr~   2013-11-23 03:10:33.000000000 +0200
-+++ iproute2-3.12.0/ip/rtpr    2013-11-23 13:10:03.780255410 +0200
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#! /bin/sh
- exec tr "[\\\\]" "[
- ]"
diff --git a/iproute2-fou_show.patch b/iproute2-fou_show.patch
deleted file mode 100644 (file)
index f053a01..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-diff -ruNp iproute2-4.14.1.orig/ip/ipfou.c iproute2-4.14.1/ip/ipfou.c
---- iproute2-4.14.1.orig/ip/ipfou.c    2017-11-13 19:09:57.000000000 +0100
-+++ iproute2-4.14.1/ip/ipfou.c 2018-02-19 15:49:27.105945493 +0100
-@@ -28,6 +28,7 @@ static void usage(void)
-       fprintf(stderr, "Usage: ip fou add port PORT "
-               "{ ipproto PROTO  | gue } [ -6 ]\n");
-       fprintf(stderr, "       ip fou del port PORT [ -6 ]\n");
-+      fprintf(stderr, "       ip fou show\n");
-       fprintf(stderr, "\n");
-       fprintf(stderr, "Where: PROTO { ipproto-name | 1..255 }\n");
-       fprintf(stderr, "       PORT { 1..65535 }\n");
-@@ -134,6 +135,63 @@ static int do_del(int argc, char **argv)
-       return 0;
- }
-+static int print_fou_mapping(const struct sockaddr_nl *who,
-+                               struct nlmsghdr *n, void *arg)
-+{
-+      FILE *fp = (FILE *)arg;
-+      struct genlmsghdr *ghdr;
-+      struct rtattr *tb[FOU_ATTR_MAX + 1];
-+      int len = n->nlmsg_len;
-+      unsigned family;
-+
-+      if (n->nlmsg_type != genl_family)
-+              return 0;
-+
-+      len -= NLMSG_LENGTH(GENL_HDRLEN);
-+      if (len < 0)
-+              return -1;
-+
-+      ghdr = NLMSG_DATA(n);
-+      parse_rtattr(tb, FOU_ATTR_MAX, (void *) ghdr + GENL_HDRLEN, len);
-+
-+      if (tb[FOU_ATTR_PORT])
-+              fprintf(fp, "port %u", ntohs(rta_getattr_u16(tb[FOU_ATTR_PORT])));
-+      if (tb[FOU_ATTR_TYPE] && rta_getattr_u8(tb[FOU_ATTR_TYPE]) == FOU_ENCAP_GUE)
-+              fprintf(fp, " gue");
-+      else if (tb[FOU_ATTR_IPPROTO])
-+              fprintf(fp, " ipproto %u", rta_getattr_u8(tb[FOU_ATTR_IPPROTO]));
-+      if (tb[FOU_ATTR_AF]) {
-+              family = rta_getattr_u8(tb[FOU_ATTR_AF]);
-+              if (family == AF_INET6)
-+                      fprintf(fp, " -6");
-+      }
-+      fprintf(fp, "\n");
-+
-+      return 0;
-+}
-+
-+static int do_show(int argc, char **argv)
-+{
-+      FOU_REQUEST(req, 4096, FOU_CMD_GET, NLM_F_REQUEST | NLM_F_DUMP);
-+
-+      if (argc > 0) {
-+              fprintf(stderr, "\"ip fou show\" does not take any arguments.\n");
-+              return -1;
-+      }
-+
-+      if (rtnl_send(&genl_rth, &req.n, req.n.nlmsg_len) < 0) {
-+              perror("Cannot send show request");
-+              exit(1);
-+      }
-+
-+      if (rtnl_dump_filter(&genl_rth, print_fou_mapping, stdout) < 0) {
-+              fprintf(stderr, "Dump terminated\n");
-+              return 1;
-+      }
-+
-+      return 0;
-+}
-+
- int do_ipfou(int argc, char **argv)
- {
-       if (argc < 1)
-@@ -149,6 +207,8 @@ int do_ipfou(int argc, char **argv)
-               return do_add(argc-1, argv+1);
-       if (matches(*argv, "delete") == 0)
-               return do_del(argc-1, argv+1);
-+      if (matches(*argv, "show") == 0)
-+              return do_show(argc-1, argv+1);
-       fprintf(stderr, "Command \"%s\" is unknown, try \"ip fou help\".\n", *argv);
-       exit(-1);
- }
-diff -ruNp iproute2-4.14.1.orig/man/man8/ip-fou.8 iproute2-4.14.1/man/man8/ip-fou.8
---- iproute2-4.14.1.orig/man/man8/ip-fou.8     2017-11-13 19:09:57.000000000 +0100
-+++ iproute2-4.14.1/man/man8/ip-fou.8  2018-02-19 15:49:23.558962613 +0100
-@@ -29,6 +29,9 @@ ip-gue \- Generic UDP Encapsulation rece
- .BR "ip fou del"
- .B port
- .IR PORT
-+.br
-+.ti -8
-+.B ip fou show
- .SH DESCRIPTION
- The
- .B ip fou
index 44ab6989e66197b76e3f919083b63c59a854edca..97cb844ad173db6ffc0435f231cc4cf4630d968f 100644 (file)
@@ -14,17 +14,17 @@ Summary(es.UTF-8):  Herramientas para encaminamiento avanzado y configuración de
 Summary(pl.UTF-8):     Narzędzie do konfigurowania sieci
 Summary(pt_BR.UTF-8):  Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
-Version:       4.14.1
-Release:       2
+Version:       4.16.0
+Release:       1
 License:       GPL v2+
 Group:         Networking/Admin
 Source0:       https://www.kernel.org/pub/linux/utils/net/iproute2/%{name}-%{version}.tar.xz
-# Source0-md5: 1075423d7029e02a8f23ed4f42b7e372
+# Source0-md5: 1f12a70d767ef77ffa2d1a0c4ce48f1a
 Source1:       %{name}.tmpfiles
 Patch0:                %{name}-arp.patch
 
 Patch3:                %{name}-LDFLAGS.patch
-Patch4:                fix-bashisms.patch
+
 Patch5:                %{name}-build.patch
 Patch6:                %{name}-print_cache_route_entries.patch
 # extensions
@@ -34,7 +34,6 @@ Patch12:      001-net-dev-iface-descr-0.1.diff
 Patch13:       %{name}-q_atm_c.patch
 Patch14:       %{name}-q_srr.v0.4.patch
 Patch15:       %{name}-ip_route_get.patch
-Patch16:       %{name}-fou_show.patch
 URL:           http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
 BuildRequires: bison
 BuildRequires: db-devel
@@ -128,7 +127,7 @@ Bashowe dopełnianie parametrów poleceń iproute2 (obecnie tylko tc).
 %patch0 -p1
 
 %patch3 -p1
-%patch4 -p1
+
 %patch5 -p1
 %patch6 -p1
 # extensions:
@@ -138,7 +137,6 @@ Bashowe dopełnianie parametrów poleceń iproute2 (obecnie tylko tc).
 %patch13 -p0
 %patch14 -p1
 %patch15 -p1
-%patch16 -p1
 
 %build
 %{__make} \
@@ -215,6 +213,7 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_scopes
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_tables
 %{_mandir}/man8/bridge.8*
+%{_mandir}/man8/devlink-resource.8*
 %{_mandir}/man8/genl.8*
 %{_mandir}/man8/ifcfg.8*
 %{_mandir}/man8/ip.8*
@@ -230,6 +229,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/nstat.8*
 %{_mandir}/man8/rdma-dev.8*
 %{_mandir}/man8/rdma-link.8*
+%{_mandir}/man8/rdma-resource.8*
 %{_mandir}/man8/rdma.8*
 %{_mandir}/man8/routef.8*
 %{_mandir}/man8/routel.8*
This page took 0.243401 seconds and 4 git commands to generate.