]> git.pld-linux.org Git - packages/ipheth.git/commitdiff
- kernel part (still disabled as module included in 2.6.34)
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 18 Jul 2010 16:26:26 +0000 (16:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ipheth.spec -> 1.2

ipheth.spec

index f0b105efd42684d25cd9c9225868d6e5beec6c6d..b45dc41dd8824cba6f4ade0d6db4d216166f4ed2 100644 (file)
@@ -1,15 +1,28 @@
 #
 # Conditional build:
 %bcond_without dist_kernel     # allow non-distribution kernel
-%bcond_with            kernel          # don't build kernel modules
+%bcond_with    kernel          # don't build kernel modules
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
 
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
+
+%define                rel     1
+%define                pname   ipheth
 Summary:       iPhone USB Ethernet Driver
-Name:          ipheth
+Name:       %{pname}%{_alt_kernel}
 Version:       0.1
-Release:       0.1
-License:       GPL v2
+Release:       %{rel}
+License:       BSD/GPL v2
 Group:         X11/Applications
 Source0:       %{name}.tar.bz2
 # Source0-md5: 0cc73e6033025c8ba8c5ef0090a631b1
@@ -23,10 +36,26 @@ This is a Linux Kernel driver that adds support for iPhone tethering
 through USB cables. Unlike other solutions out there, you don't need
 to jailbreak your phone or install third-party proxy applications.
 
+%package -n kernel%{_alt_kernel}-net-ipheth
+Summary:       Linux driver for iPhone USB Ethernet Driver
+Release:       %{rel}@%{_kernel_ver_str}
+Group:         Base/Kernel
+Requires(post,postun): /sbin/depmod
+%if %{with dist_kernel}
+%requires_releq_kernel
+Requires(postun):      %releq_kernel
+%endif
+
+%description -n kernel%{_alt_kernel}-net-ipheth
+Linux driver for iPhone USB Ethernet Driver.
+
 %prep
 %setup -q -n %{name}
 
 %build
+%if %{with kernel}
+%build_kernel_modules -C ipheth-driver -m ipheth CONFIG_DEBUG_SECTION_MISMATCH=y
+%endif
 %if %{with userspace}
 %{__make} -C ipheth-pair \
        CC="%{__cc}" \
@@ -35,6 +64,10 @@ to jailbreak your phone or install third-party proxy applications.
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%if %{with kernel}
+%install_kernel_modules -m ipheth-driver/ipheth -d misc
+%endif
+
 %if %{with userspace}
 install -d $RPM_BUILD_ROOT{/lib/udev,/etc/udev/rules.d}
 install -p ipheth-pair/ipheth-pair $RPM_BUILD_ROOT/lib/udev
@@ -44,7 +77,19 @@ cp -a ipheth-pair/90-iphone-tether.rules $RPM_BUILD_ROOT/etc/udev/rules.d
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -n kernel%{_alt_kernel}-net-ipheth
+%depmod %{_kernel_ver}
+
+%postun        -n kernel%{_alt_kernel}-net-ipheth
+%depmod %{_kernel_ver}
+
 %files
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/90-iphone-tether.rules
 %attr(755,root,root) /lib/udev/ipheth-pair
+
+%if %{with kernel}
+%files -n kernel%{_alt_kernel}-net-ipheth
+%defattr(644,root,root,755)
+/lib/modules/%{_kernel_ver}/misc/*.ko*
+%endif
This page took 0.06759 seconds and 4 git commands to generate.