]> git.pld-linux.org Git - packages/intel-graphics-compiler.git/commitdiff
use sane CXXFLAGS
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 3 Jul 2019 08:27:53 +0000 (10:27 +0200)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 3 Jul 2019 08:27:53 +0000 (10:27 +0200)
intel-graphics-compiler, like the rest of compute-runtime is designed
for newer Intel processors, so it uses all the newest features by
default, but we need to be able to use it on our builders too, to build
the intel-compute-runtime package.

intel-graphics-compiler.spec

index 96873c59fbe027a79e41b2ee28ca67d5a8be062a..6d9377e8a06d806b46d850e58e268800b1f57673 100644 (file)
@@ -13,6 +13,7 @@ Group:                Libraries
 Source0:       https://github.com/intel/intel-graphics-compiler/archive/igc-%{version}/igc-%{version}.tar.gz
 # Source0-md5: 9999fd7b6947b2ed0a11f7b07b1e7acc
 Patch0:                pkgconfig.patch
+Patch1:                cxx_flags.patch
 URL:           https://github.com/intel/intel-graphics-compiler/
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: opencl-clang-devel >= %{opencl_clang_version}
@@ -49,11 +50,14 @@ Pliki nagłówkowe biblioteki %{name}.
 %setup -qn %{name}-igc-%{version}
 
 %patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
 cd build
 %cmake \
+       -DCMAKE_BUILD_TYPE=Release \
+       -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
        -DCCLANG_FROM_SYSTEM=ON \
        ../
 %{__make}
This page took 0.15487 seconds and 4 git commands to generate.