]> git.pld-linux.org Git - packages/inkscape.git/commitdiff
- rel 7; libpng build fix auto/th/inkscape-0_48_2-7
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 10 Feb 2012 17:01:49 +0000 (17:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    inkscape-0.48.1-libpng15.patch -> 1.1
    inkscape.spec -> 1.107

inkscape-0.48.1-libpng15.patch [new file with mode: 0644]
inkscape.spec

diff --git a/inkscape-0.48.1-libpng15.patch b/inkscape-0.48.1-libpng15.patch
new file mode 100644 (file)
index 0000000..e24913e
--- /dev/null
@@ -0,0 +1,40 @@
+--- inkscape-0.48.1/src/extension/internal/pdfinput/svg-builder.cpp
++++ inkscape-0.48.1-mod//src/extension/internal/pdfinput/svg-builder.cpp
+@@ -1443,7 +1443,7 @@
+         return NULL;
+     }
+     // Set error handler
+-    if (setjmp(png_ptr->jmpbuf)) {
++    if (setjmp(png_jmpbuf(png_ptr))) {
+         png_destroy_write_struct(&png_ptr, &info_ptr);
+         return NULL;
+     }
+--- inkscape-0.48.1/src/helper/png-write.cpp
++++ inkscape-0.48.1-mod//src/helper/png-write.cpp
+@@ -165,7 +165,7 @@
+     /* Set error handling.  REQUIRED if you aren't supplying your own
+      * error hadnling functions in the png_create_write_struct() call.
+      */
+-    if (setjmp(png_ptr->jmpbuf)) {
++    if (setjmp(png_jmpbuf(png_ptr))) {
+         /* If we get here, we had a problem reading the file */
+         fclose(fp);
+         png_destroy_write_struct(&png_ptr, &info_ptr);
+--- inkscape-0.48.1/src/sp-image.cpp
++++ inkscape-0.48.1-mod//src/sp-image.cpp
+@@ -386,9 +386,13 @@
+ #if defined(PNG_iCCP_SUPPORTED)
+                 {
+-                    char* name = 0;
++                    png_charp name = 0;
+                     int compression_type = 0;
+-                    char* profile = 0;
++#if (PNG_LIBPNG_VER < 10500)
++                    png_charp profile = 0;
++#else
++                    png_bytep profile = 0;
++#endif
+                     png_uint_32 proflen = 0;
+                     if ( png_get_iCCP(pngPtr, infoPtr, &name, &compression_type, &profile, &proflen) ) {
+ //                                         g_message("Found an iCCP chunk named [%s] with %d bytes and comp %d", name, proflen, compression_type);
index c71288393683e7689c7708b15f2206cd2ed15a4e..477e68c8564e461cc581ad872960fe3ad1c2c67b 100644 (file)
@@ -16,13 +16,14 @@ Summary:    Scalable vector graphics editor
 Summary(pl.UTF-8):     Edytor skalowalnej grafiki wektorowej
 Name:          inkscape
 Version:       0.48.2
-Release:       6
+Release:       7
 License:       GPL v2+, LGPL v2.1+
 Group:         X11/Applications/Graphics
 Source0:       http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
 # Source0-md5: f60b98013bd1121b2cc301f3485076ba
 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
 Patch0:                %{name}-ldl.patch
+Patch1:                %{name}-0.48.1-libpng15.patch
 URL:           http://www.inkscape.org/
 BuildRequires: ImageMagick-c++-devel
 BuildRequires: aspell-devel
@@ -77,6 +78,7 @@ dwuwymiarowej grafiki wektorowej.
 %prep
 %setup -q -n %{name}-%{version}%{beta}
 %patch0 -p1
+%patch1 -p1
 
 %{__rm} po/en_US@piglatin.po
 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
This page took 0.084998 seconds and 4 git commands to generate.