]> git.pld-linux.org Git - packages/inkscape.git/commitdiff
- inkscape-c++.patch: C++ fixes needed for gcc4. auto/th/inkscape-0_43-1
authorqrczak <qrczak@pld-linux.org>
Sun, 11 Dec 2005 12:59:23 +0000 (12:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    inkscape-c++.patch -> 1.1
    inkscape.spec -> 1.44

inkscape-c++.patch [new file with mode: 0644]
inkscape.spec

diff --git a/inkscape-c++.patch b/inkscape-c++.patch
new file mode 100644 (file)
index 0000000..a1a897b
--- /dev/null
@@ -0,0 +1,70 @@
+--- inkscape-0.43/src/libavoid/connector.h~    2005-10-25 08:04:17.000000000 +0200
++++ inkscape-0.43/src/libavoid/connector.h     2005-12-11 07:05:45.000000000 +0100
+@@ -59,7 +59,7 @@
+         bool isInitialised(void);
+         void unInitialise(void);
+         void setCallback(void (*cb)(void *), void *ptr);
+-        void ConnRef::handleInvalid(void);
++        void handleInvalid(void);
+         int generatePath(Point p0, Point p1);
+         void makePathInvalid(void);
+         
+--- inkscape-0.43/src/ui/dialog/aboutbox.h~    2005-09-05 22:18:41.000000000 +0200
++++ inkscape-0.43/src/ui/dialog/aboutbox.h     2005-12-11 07:45:47.000000000 +0100
+@@ -28,7 +28,7 @@
+ class AboutBoxChild: public Gtk::Dialog
+ {
+ public:
+-    AboutBoxChild::AboutBoxChild(Gtk::Window& parent, gchar * title)
++    AboutBoxChild(Gtk::Window& parent, gchar * title)
+         : Gtk::Dialog(title,parent) {};
+ protected:
+     virtual void         on_response(int response_id);
+--- inkscape-0.43/src/livarot/Path.h~  2005-11-07 07:04:16.000000000 +0100
++++ inkscape-0.43/src/livarot/Path.h   2005-12-11 08:02:28.000000000 +0100
+@@ -198,7 +198,7 @@
+   cut_position*    CurvilignToPosition(int nbCv,double* cvAbs,int &nbCut);
+   cut_position    PointToCurvilignPosition(NR::Point const &pos) const;
+   //Should this take a cut_position as a param?
+-  double           Path::PositionToLength(int piece, double t);
++  double           PositionToLength(int piece, double t);
+   
+   // caution: not tested on quadratic b-splines, most certainly buggy
+   void             ConvertPositionsToMoveTo(int nbPos,cut_position* poss);
+--- inkscape-0.43/src/dialogs/tiledialog.h~    2005-05-25 16:07:31.000000000 +0200
++++ inkscape-0.43/src/dialogs/tiledialog.h     2005-12-11 08:17:25.000000000 +0100
+@@ -58,7 +58,7 @@
+     /**
+      * Respond to selection change
+      */
+-    void TileDialog::updateSelection();
++    void updateSelection();
+     /**
+--- inkscape-0.43/src/extension/internal/ps.h~ 2005-09-20 07:51:13.000000000 +0200
++++ inkscape-0.43/src/extension/internal/ps.h  2005-12-11 08:47:35.000000000 +0100
+@@ -36,10 +36,10 @@
+       void print_bpath (SVGOStringStream &os, const NArtBpath *bp);
+-      void PrintPS::print_fill_style (SVGOStringStream &os, const SPStyle *style, const NRRect *pbox);
+-      void PrintPS::print_stroke_style (SVGOStringStream &os, const SPStyle *style);
++      void print_fill_style (SVGOStringStream &os, const SPStyle *style, const NRRect *pbox);
++      void print_stroke_style (SVGOStringStream &os, const SPStyle *style);
+-      const char* PrintPS::PSFontName (const SPStyle *style);
++      const char* PSFontName (const SPStyle *style);
+       unsigned int print_image (FILE *ofp, guchar *px, unsigned int width, unsigned int height, unsigned int rs,
+                                      const NRMatrix *transform);
+--- inkscape-0.43/src/ui/dialog/align-and-distribute.cpp~      2005-09-20 07:51:16.000000000 +0200
++++ inkscape-0.43/src/ui/dialog/align-and-distribute.cpp       2005-12-11 13:02:41.000000000 +0100
+@@ -954,7 +954,6 @@
+         break;
+     } // end of switch statement
+-    return NULL;
+ }
+ AlignAndDistribute::AlignTarget AlignAndDistribute::getAlignTarget()const {
index f9769df63bd772f99c7a43e0dd2e1ff5cd6aeabc..a87bf7e5fd705b4ea6078c62fbd9ed1b3f72fc44 100644 (file)
@@ -15,6 +15,7 @@ License:      GPL v2, LGPL v2.1
 Group:         Applications/Graphics
 Source0:       http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
 # Source0-md5: 97c606182f5e177eef70c1e8a55efc1f
+Patch0:                %{name}-c++.patch
 URL:           http://www.inkscape.org/
 BuildRequires: autoconf >= 2.59-3
 BuildRequires: automake >= 1:1.9.4-2
@@ -53,6 +54,7 @@ dwuwymiarowej grafiki wektorowej.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.117736 seconds and 4 git commands to generate.