]> git.pld-linux.org Git - packages/inkscape.git/blobdiff - inkscape.spec
- fix shebangs
[packages/inkscape.git] / inkscape.spec
index 477e68c8564e461cc581ad872960fe3ad1c2c67b..7a9fe7f5a12ca0eba7315b2f613363dd682d0abd 100644 (file)
 #
-# TODO: check why build requires libselinux-devel (because of some gnome* stuff)
-#
 # Conditional build
-%bcond_without xft             # Don't use xft scalable font database
+%bcond_with    dbus            # DBus interface
+%bcond_with    gtk3            # GTK+ 3 interface [experimental]
 %bcond_without gnomevfs        # Don't use gnome vfs for loading files
-%bcond_without mmx             # Force building without MMX optimazation (Default: auto-detect)
-%bcond_with    inkboard        # Enable inkboard support
 %bcond_with    relocation      # Enable binary relocation support
 #
 
-# just set it nil when non-preview arrives
-%define beta %{nil}
-
 Summary:       Scalable vector graphics editor
 Summary(pl.UTF-8):     Edytor skalowalnej grafiki wektorowej
 Name:          inkscape
-Version:       0.48.2
-Release:       7
+Version:       0.92.4
+Release:       1
 License:       GPL v2+, LGPL v2.1+
 Group:         X11/Applications/Graphics
-Source0:       http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
-# Source0-md5: f60b98013bd1121b2cc301f3485076ba
-# workaround for https://bugs.launchpad.net/inkscape/+bug/487038
-Patch0:                %{name}-ldl.patch
-Patch1:                %{name}-0.48.1-libpng15.patch
-URL:           http://www.inkscape.org/
+# download: follow https://inkscape.org/release/
+Source0:       https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.bz2
+# Source0-md5: ac30f6d5747fd9c620c00dad500f414f
+Patch0:                %{name}-man.patch
+Patch1:                %{name}-gtk3.patch
+# https://gitlab.com/inkscape/inkscape/commit/e831b034746f8dc3c3c1b88372751f6dcb974831.patch
+Patch2:                %{name}-poppler0.76.patch
+# https://gitlab.com/inkscape/inkscape/merge_requests/986.patch
+Patch3:                %{name}-poppler0.82.patch
+Patch4:                %{name}-poppler0.83.patch
+URL:           https://inkscape.org/
 BuildRequires: ImageMagick-c++-devel
 BuildRequires: aspell-devel
-BuildRequires: autoconf >= 2.59-3
+BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.9.4-2
-BuildRequires: boost-devel >= 1.35.0
-BuildRequires: cairo-devel >= 1.8.0
+BuildRequires: boost-devel >= 1.36
+BuildRequires: cairo-devel >= 1.10
+BuildRequires: cairomm-devel >= 1.9.8
+%{?with_dbus:BuildRequires:    dbus-glib-devel}
 BuildRequires: freetype-devel >= 2.0
-BuildRequires: gc-devel >= 6.4
-BuildRequires: gettext-devel
-BuildRequires: glibmm-devel >= 2.16.0
+BuildRequires: gc-devel >= 7.2
+BuildRequires: gettext-tools >= 0.17
+BuildRequires: glib2-devel >= 1:2.28
+BuildRequires: glibmm-devel >= 2.28
 %{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.15.2}
 BuildRequires: gsl-devel
-BuildRequires: gtk+2-devel >= 2:2.14.0
-BuildRequires: gtkmm-devel >= 2.10.0
-BuildRequires: gtkspell-devel >= 2.0.11
-BuildRequires: intltool >= 0.35.0
-BuildRequires: lcms-devel >= 1.15
+BuildRequires: intltool >= 0.40.0
+BuildRequires: lcms2-devel >= 2
+BuildRequires: libcdr-devel >= 0.1
+BuildRequires: libexif-devel
+BuildRequires: libgomp-devel
+BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel >= 1.2
+BuildRequires: librevenge-devel
 BuildRequires: libsigc++-devel >= 2.0.17
-BuildRequires: libstdc++-devel >= 6:4.2.2-2
-BuildRequires: libtool
-BuildRequires: libwpg-devel
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: libtool >= 2:2.2
+BuildRequires: libvisio-devel >= 0.1
+BuildRequires: libwpd-devel >= 0.9
+BuildRequires: libwpg-devel >= 0.3
 BuildRequires: libxml2-devel >= 1:2.6.26
 BuildRequires: libxslt-devel >= 1.1.17
-%{?with_inkboard:BuildRequires:        loudmouth-devel >= 1.0.3}
+BuildRequires: pango-devel >= 1:1.24
 BuildRequires: pkgconfig
-BuildRequires: poppler-glib-devel >= 0.12.2
+BuildRequires: poppler-glib-devel >= 0.29.0
 BuildRequires: popt-devel
+BuildRequires: potrace-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
-%{?with_xft:BuildRequires:     xorg-lib-libXft-devel}
 BuildRequires: zlib-devel
+%if %{with gtk3}
+BuildRequires: gdl-devel >= 3.6
+BuildRequires: gtk+3-devel >= 3.8
+BuildRequires: gtkmm3-devel >= 3.10
+BuildRequires: gtkspell3-devel >= 3.0
+%else
+BuildRequires: gtk+2-devel >= 2:2.24
+BuildRequires: gtkmm-devel >= 2.24
+BuildRequires: gtkspell-devel >= 2.0.11
+%endif
 Requires(post,postun): desktop-file-utils
-Requires:      gc >= 6.4
+Requires:      cairo >= 1.10
+Requires:      cairomm >= 1.9.8
+Requires:      gc >= 7.2
+Requires:      glib2 >= 1:2.28
+Requires:      glibmm >= 2.28
 %{?with_gnomevfs:Requires:     gnome-vfs2 >= 2.15.2}
-Requires:      gtk+2 >= 2:2.14.0
+Requires:      libsigc++ >= 2.0.17
+Requires:      libxml2 >= 1:2.6.26
+Requires:      libxslt >= 1.1.17
+Requires:      pango >= 1:1.24
 Requires:      perl-XML-XQL
+Requires:      poppler-glib >= 0.29.0
+%if %{with gtk3}
+Requires:      gdl >= 3.6
+Requires:      gtk+3 >= 3.8
+Requires:      gtkmm3 >= 3.10
+%else
+Requires:      gtk+2 >= 2:2.24
+Requires:      gtkmm >= 2.24
+Requires:      gtkspell >= 2.0.11
+%endif
 Suggests:      python-lxml
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
@@ -76,31 +109,49 @@ Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
 dwuwymiarowej grafiki wektorowej.
 
 %prep
-%setup -q -n %{name}-%{version}%{beta}
+%setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+
+%{__sed} -i -e 's,po/Makefile.in,,' configure.ac
+
+
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+      CMakeScripts/cmake_consistency_check.py \
+      buildtools/msys2checkdeps.py \
+      cxxtest/cxxtestgen.py \
+      packaging/scripts/lp-mark-bugs-released \
+      packaging/wix/*.py \
+      share/extensions/*.py \
+      share/extensions/*/*.py \
+      share/*/i18n.py
 
-%{__rm} po/en_US@piglatin.po
-%{__sed} -i -e 's|en_US@piglatin||' configure.ac
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+ruby(\s|$),#!%{__ruby}\1,' \
+      share/extensions/*.rb
 
-mv po/te_IN.po po/te.po
-%{__sed} -i -e 's|te_IN|te|' configure.ac
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
+      share/attributes/genMapDataCSS.pl \
+      share/attributes/genMapDataSVG.pl
 
 %build
 %{__libtoolize}
-%{__glib_gettextize}
+%{__gettextize}
 %{__intltoolize}
 %{__aclocal}
+%{__autoconf}
 %{__autoheader}
 %{__automake}
-%{__autoconf}
+# deprecated TimeVal API is used, so --disable-strict-build is needed
 %configure \
-       --disable-silent-rules \
-       %{!?with_xft: --without-xft} \
-       %{!?with_gnomevfs:--without-gnome-vfs} \
-       %{!?with_mmx:--disable-mmx} \
        %{?with_relocation:--enable-binreloc} \
-       %{?with_inkboard:--enable-inkboard}
+       %{?with_dbus:--enable-dbusapi} \
+       %{?with_gtk3:--enable-gtk3-experimental} \
+       --disable-silent-rules \
+       --disable-strict-build \
+       %{!?with_gnomevfs:--without-gnome-vfs}
 
 %{__make}
 
@@ -110,12 +161,28 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# localized manuals cleanup
+for manlang in de el fr ja sk zh_TW ; do
+       %{__mv} $RPM_BUILD_ROOT%{_mandir}/${manlang}/man1/{inkscape.${manlang}.1,inkscape.1}
+       %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/inkscape.${manlang}.1
+done
+
+# unify locale name, overwrite outdated bn
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
+# joke language, unsupported
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en_US@piglatin
+# unify names
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
+# unsupported variants
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
+
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-
 %post
 %update_desktop_database_post
 
@@ -126,36 +193,47 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
 %lang(ca) %doc README.ca.txt
-%lang(de) %doc README.de.txt
+%lang(de) %doc README.de.txt doc/HACKING.de.txt
 %lang(es) %doc README.es.txt
-%lang(fr) %doc README.fr.txt
-%lang(it) %doc README.it.txt
-%lang(de) %doc doc/HACKING.de.txt
-%lang(fr) %doc doc/HACKING.fr.txt
-%lang(it) %doc doc/HACKING.it.txt
+%lang(fr) %doc README.fr.txt doc/HACKING.fr.txt
+%lang(it) %doc README.it.txt doc/HACKING.it.txt
+%lang(pt_BR) %doc README.pt_BR.txt doc/HACKING.pt_BR.txt
+%lang(sk) %doc README.sk.txt
+%lang(sr) %doc README.sr.txt
 %attr(755,root,root) %{_bindir}/inkscape
 %attr(755,root,root) %{_bindir}/inkview
 %dir %{_datadir}/inkscape
 %{_datadir}/inkscape/[!e]*
 %{_datadir}/inkscape/examples
 %dir %{_datadir}/inkscape/extensions
-%{_datadir}/inkscape/extensions/Poly3DObjects/
-%{_datadir}/inkscape/extensions/alphabet_soup/
+%dir %{_datadir}/inkscape/extensions/Barcode
+%attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
+%{_datadir}/inkscape/extensions/Poly3DObjects
+%{_datadir}/inkscape/extensions/alphabet_soup
+%dir %{_datadir}/inkscape/extensions/ink2canvas
+%attr(755,root,root) %{_datadir}/inkscape/extensions/ink2canvas/*.py
+%{_datadir}/inkscape/extensions/test
+%{_datadir}/inkscape/extensions/xaml2svg
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
 %{_datadir}/inkscape/extensions/*.inx
 %{_datadir}/inkscape/extensions/*.js
+%{_datadir}/inkscape/extensions/*.svg
 %{_datadir}/inkscape/extensions/*.xml
 %{_datadir}/inkscape/extensions/*.xsl
 %{_datadir}/inkscape/extensions/*.xslt
-%attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
-%attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
-%attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
-%attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
-%attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
-%dir %{_datadir}/inkscape/extensions/Barcode
-%attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
-%dir %{_datadir}/inkscape/extensions/xaml2svg
-%{_datadir}/inkscape/extensions/xaml2svg/*.xsl
-%{_mandir}/man1/*.1*
-%lang(fr) %{_mandir}/fr/man1/*.1*
+%{_datadir}/inkscape/extensions/fontfix.conf
+%{_datadir}/inkscape/extensions/inkscape.extension.rng
+%{_datadir}/appdata/inkscape.appdata.xml
 %{_iconsdir}/hicolor/*/apps/inkscape.png
 %{_desktopdir}/inkscape.desktop
+%{_mandir}/man1/inkscape.1*
+%{_mandir}/man1/inkview.1*
+%lang(de) %{_mandir}/de/man1/inkscape.1*
+%lang(el) %{_mandir}/el/man1/inkscape.1*
+%lang(fr) %{_mandir}/fr/man1/inkscape.1*
+%lang(ja) %{_mandir}/ja/man1/inkscape.1*
+%lang(sk) %{_mandir}/sk/man1/inkscape.1*
+%lang(zh_TW) %{_mandir}/zh_TW/man1/inkscape.1*
This page took 0.074679 seconds and 4 git commands to generate.