]> git.pld-linux.org Git - packages/inkscape.git/blobdiff - inkscape.spec
- added -gcc45.patch (from Gentoo) and -ldl.patch
[packages/inkscape.git] / inkscape.spec
index 3e064747148dd93a034096bb73c0c3487e547211..49ea83ab551186206b1868a402584f002c199353 100644 (file)
@@ -3,7 +3,6 @@
 #
 # Conditional build
 %bcond_without xft             # Don't use xft scalable font database
-%bcond_without gnomeprint      # Don't use gnome print font database and spooler frontend
 %bcond_without gnomevfs        # Don't use gnome vfs for loading files
 %bcond_without mmx             # Force building without MMX optimazation (Default: auto-detect)
 %bcond_with    inkboard        # Enable inkboard support
 #
 
 # just set it nil when non-preview arrives
-%define beta pre3
+%define beta %{nil}
 
 Summary:       Scalable vector graphics editor
 Summary(pl.UTF-8):     Edytor skalowalnej grafiki wektorowej
 Name:          inkscape
 Version:       0.47
-Release:       0.%{beta}.1
+Release:       5
 License:       GPL v2, LGPL v2.1
-Group:         Applications/Graphics
+Group:         X11/Applications/Graphics
 Source0:       http://dl.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
-# Source0-md5: eaf529011bb4bc8879ff669a4c7f000d
-Patch0:                %{name}-desktop.patch
-Patch1:                %{name}-poppler.patch
-Patch2:                %{name}-gcc43.patch
-Patch3:                %{name}-gtk2.patch
-Patch4:                %{name}-slider.patch
-Patch5:                %{name}-gcc44.patch
-Patch6:                %{name}-early-png-header.patch
-Patch7:                %{name}-gchar.patch
-Patch8:                %{name}-install.patch
+# Source0-md5: 7b497c8f673e40b05295a29f6e2111f4
+# workaround for https://bugs.launchpad.net/inkscape/+bug/487038
+Patch0:                %{name}-poppler.patch
+Patch1:                %{name}-gcc45.patch
+Patch2:                %{name}-ldl.patch
 URL:           http://www.inkscape.org/
+BuildRequires: ImageMagick-c++-devel
+BuildRequires: aspell-devel
 BuildRequires: autoconf >= 2.59-3
 BuildRequires: automake >= 1:1.9.4-2
 BuildRequires: boost-devel >= 1.35.0
+BuildRequires: cairo-devel >= 1.8.0
 BuildRequires: freetype-devel >= 2.0
 BuildRequires: gcc-c++ >= 6:4.2.2-2
 BuildRequires: gc-devel >= 6.4
 BuildRequires: gettext-devel
+BuildRequires: glibmm-devel >= 2.16.0
 %{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.15.2}
-BuildRequires: gtk+2-devel >= 2:2.9.4
+BuildRequires: gtk+2-devel >= 2:2.14.0
 BuildRequires: gtkmm-devel >= 2.10.0
 BuildRequires: gtkspell-devel >= 2.0.11
 BuildRequires: gsl-devel
 BuildRequires: intltool >= 0.35.0
 BuildRequires: lcms-devel >= 1.15
-BuildRequires: libart_lgpl-devel >= 2.3.10
-%{?with_gnomeprint:BuildRequires:      libgnomeprintui-devel >= 2.12.1}
 BuildRequires: libpng-devel >= 1.2
 BuildRequires: libsigc++-devel >= 2.0.17
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 1:2.6.26
 BuildRequires: libxslt-devel >= 1.1.17
+BuildRequires: libwpg-devel
 %{?with_inkboard:BuildRequires:        loudmouth-devel >= 1.0.3}
 BuildRequires: pkgconfig
+BuildRequires: poppler-glib-devel >= 0.12.2
 BuildRequires: popt-devel
 BuildRequires: rpm-pythonprov
+BuildRequires: sed >= 4.0
 %{?with_xft:BuildRequires:     xorg-lib-libXft-devel}
 BuildRequires: zlib-devel
-Requires(post,postun): shared-mime-info
+Requires(post,postun): desktop-file-utils
 Requires:      gc >= 6.4
 %{?with_gnomevfs:Requires:     gnome-vfs2 >= 2.15.2}
-Requires:      gtk+2 >= 2:2.9.4
+Requires:      gtk+2 >= 2:2.14.0
 Requires:      perl-XML-XQL
 Suggests:      python-lxml
 # sr@Latn vs. sr@latin
@@ -79,20 +78,11 @@ dwuwymiarowej grafiki wektorowej.
 
 %prep
 %setup -q -n %{name}-%{version}%{beta}
-#%patch0 -p1
-#%patch1 -p1
-#%patch2 -p1
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
-#%patch6 -p1
-#%patch7 -p1
-#%patch8 -p1
-
-
-rm -f po/ca@valencia.po
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
 rm -f po/en_US@piglatin.po
-sed -i -e 's|ca@valencia||' configure.ac
 sed -i -e 's|en_US@piglatin||' configure.ac
 
 %build
@@ -105,13 +95,10 @@ sed -i -e 's|en_US@piglatin||' configure.ac
 %{__autoconf}
 %configure \
        %{!?with_xft: --without-xft} \
-       %{!?with_gnomeprint:--without-gnome-print} \
-       %{?with_gnomeprint:--with-gnome-print} \
        %{!?with_gnomevfs:--without-gnome-vfs} \
        %{!?with_mmx:--disable-mmx} \
        %{?with_relocation:--enable-binreloc} \
-       %{?with_inkboard:--enable-inkboard} \
-       --disable-static
+       %{?with_inkboard:--enable-inkboard}
 
 %{__make}
 
@@ -121,8 +108,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-[ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
-       mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
 %find_lang %{name}
 
 %clean
@@ -130,14 +115,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %post
-umask 022
-update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
-[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
+%update_desktop_database_post
 
 %postun
-umask 022
-update-mime-database %{_datadir}/mime >/dev/null 2>&1
-[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
+%update_desktop_database_postun
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
@@ -150,7 +131,8 @@ update-mime-database %{_datadir}/mime >/dev/null 2>&1
 %lang(de) %doc HACKING.de.txt
 %lang(fr) %doc HACKING.fr.txt
 %lang(it) %doc HACKING.it.txt
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/inkscape
+%attr(755,root,root) %{_bindir}/inkview
 %dir %{_datadir}/inkscape
 %{_datadir}/inkscape/[!e]*
 %{_datadir}/inkscape/examples
@@ -171,7 +153,7 @@ update-mime-database %{_datadir}/mime >/dev/null 2>&1
 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
 %dir %{_datadir}/inkscape/extensions/xaml2svg
 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
-%{_mandir}/man1/*
-%lang(fr) %{_mandir}/fr/man1/*
+%{_mandir}/man1/*.1*
+%lang(fr) %{_mandir}/fr/man1/*.1*
 %{_pixmapsdir}/*.png
-%{_desktopdir}/*.desktop
+%{_desktopdir}/inkscape.desktop
This page took 0.073414 seconds and 4 git commands to generate.