]> git.pld-linux.org Git - packages/inkscape.git/blobdiff - inkscape.spec
- up to final 0.47
[packages/inkscape.git] / inkscape.spec
index c45b11d8c174996b0df29dcad49cb9b251dee729..1e94720bb1a30c03cc6d6c73244bb44d9eb05341 100644 (file)
-# TODO:
-# - http://sourceforge.net/tracker/index.php?func=detail&aid=1056633&group_id=93438&atid=604306
+#
+# TODO: check why build requires libselinux-devel (because of some gnome* stuff)
 #
 # Conditional build
 %bcond_without xft             # Don't use xft scalable font database
-%bcond_without gnome_print     # Don't use gnome print font database and spooler frontend
+%bcond_without gnomeprint      # Don't use gnome print font database and spooler frontend
+%bcond_without gnomevfs        # Don't use gnome vfs for loading files
 %bcond_without mmx             # Force building without MMX optimazation (Default: auto-detect)
+%bcond_with    inkboard        # Enable inkboard support
 %bcond_with    relocation      # Enable binary relocation support
 #
+
+# just set it nil when non-preview arrives
+%define beta %{nil}
+
 Summary:       Scalable vector graphics editor
-Summary(pl):   Edytor skalowalnej grafiki wektorowej
+Summary(pl.UTF-8):     Edytor skalowalnej grafiki wektorowej
 Name:          inkscape
-Version:       0.40
+Version:       0.47
 Release:       1
 License:       GPL v2, LGPL v2.1
 Group:         Applications/Graphics
-Source0:       http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
-# Source0-md5: 5f53659eb47efce8593e39d30ebb1c77
+Source0:       http://dl.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
+# Source0-md5: 7b497c8f673e40b05295a29f6e2111f4
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-poppler.patch
+Patch2:                %{name}-gcc43.patch
+Patch3:                %{name}-gtk2.patch
+Patch4:                %{name}-slider.patch
+Patch5:                %{name}-gcc44.patch
+Patch6:                %{name}-early-png-header.patch
+Patch7:                %{name}-gchar.patch
+Patch8:                %{name}-install.patch
 URL:           http://www.inkscape.org/
-BuildRequires: autoconf >= 2.50
-BuildRequires: automake >= 1:1.7
+BuildRequires: autoconf >= 2.59-3
+BuildRequires: automake >= 1:1.9.4-2
+BuildRequires: boost-devel >= 1.35.0
 BuildRequires: freetype-devel >= 2.0
-BuildRequires: gc-devel
-BuildRequires: gtk+2-devel >= 2:2.4.0
-BuildRequires: gtkmm-devel >= 2.4
-BuildRequires: gtkspell-devel
-BuildRequires: intltool
+BuildRequires: gcc-c++ >= 6:4.2.2-2
+BuildRequires: gc-devel >= 6.4
+BuildRequires: gettext-devel
+%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.15.2}
+BuildRequires: gtk+2-devel >= 2:2.9.4
+BuildRequires: gtkmm-devel >= 2.10.0
+BuildRequires: gtkspell-devel >= 2.0.11
+BuildRequires: gsl-devel
+BuildRequires: intltool >= 0.35.0
+BuildRequires: lcms-devel >= 1.15
 BuildRequires: libart_lgpl-devel >= 2.3.10
-%{?with_gnome_print:BuildRequires:     libgnomeprintui-devel >= 1.116.0}
-BuildRequires: libpng-devel
-BuildRequires: libsigc++-devel >= 2.0.3
+%{?with_gnomeprint:BuildRequires:      libgnomeprintui-devel >= 2.12.1}
+BuildRequires: libpng-devel >= 1.2
+BuildRequires: libsigc++-devel >= 2.0.17
 BuildRequires: libtool
-BuildRequires: libxml2-devel >= 2.4.24
+BuildRequires: libxml2-devel >= 1:2.6.26
+BuildRequires: libxslt-devel >= 1.1.17
+%{?with_inkboard:BuildRequires:        loudmouth-devel >= 1.0.3}
 BuildRequires: pkgconfig
 BuildRequires: popt-devel
-%{?with_xft:BuildRequires:     xft-devel}
+BuildRequires: rpm-pythonprov
+%{?with_xft:BuildRequires:     xorg-lib-libXft-devel}
+BuildRequires: zlib-devel
 Requires(post,postun): shared-mime-info
+Requires:      gc >= 6.4
+%{?with_gnomevfs:Requires:     gnome-vfs2 >= 2.15.2}
+Requires:      gtk+2 >= 2:2.9.4
 Requires:      perl-XML-XQL
-Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Suggests:      python-lxml
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Inkscape is a program for viewing, making, and editing two-dimensional
 vector drawings.
 
-%description -l pl
-Inkscape jest programem do przegl±dania, tworzenia i edycji
+%description -l pl.UTF-8
+Inkscape jest programem do przeglądania, tworzenia i edycji
 dwuwymiarowej grafiki wektorowej.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}%{beta}
+#%patch0 -p1
+#%patch1 -p1
+#%patch2 -p1
+#%patch3 -p1
+#%patch4 -p1
+#%patch5 -p1
+#%patch6 -p1
+#%patch7 -p1
+#%patch8 -p1
+
+
+rm -f po/ca@valencia.po
+rm -f po/en_US@piglatin.po
+sed -i -e 's|ca@valencia||' configure.ac
+sed -i -e 's|en_US@piglatin||' configure.ac
 
 %build
-cp -f /usr/share/automake/mkinstalldirs .
 %{__libtoolize}
-glib-gettextize --copy --force
-intltoolize --copy --force --automake
+%{__glib_gettextize}
+%{__intltoolize}
 %{__aclocal}
 %{__autoheader}
 %{__automake}
 %{__autoconf}
 %configure \
-       %{!?with_xft: --without-xft}\
-       %{!?with_gnome_print: --without-gnome-print}\
-       %{?with_gnome_print: --with-gnome-print}\
+       %{!?with_xft: --without-xft} \
+       %{!?with_gnomeprint:--without-gnome-print} \
+       %{?with_gnomeprint:--with-gnome-print} \
+       %{!?with_gnomevfs:--without-gnome-vfs} \
        %{!?with_mmx:--disable-mmx} \
        %{?with_relocation:--enable-binreloc} \
+       %{?with_inkboard:--enable-inkboard} \
        --disable-static
 
 %{__make}
@@ -74,30 +121,57 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/inkscape/plugins/*.la
-
+[ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
+       mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
 %post
 umask 022
-update-mime-database %{_datadir}/mime
+update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
 
 %postun
 umask 022
-update-mime-database %{_datadir}/mime
+update-mime-database %{_datadir}/mime >/dev/null 2>&1
 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README
+%doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
+%lang(ca) %doc README.ca.txt
+%lang(de) %doc README.de.txt
+%lang(es) %doc README.es.txt
+%lang(fr) %doc README.fr.txt
+%lang(it) %doc README.it.txt
+%lang(de) %doc HACKING.de.txt
+%lang(fr) %doc HACKING.fr.txt
+%lang(it) %doc HACKING.it.txt
 %attr(755,root,root) %{_bindir}/*
-%{_datadir}/inkscape
-%dir %{_libdir}/inkscape
-%attr(755,root,root) %{_libdir}/inkscape/plugins/lib*.so.*.*.*
+%dir %{_datadir}/inkscape
+%{_datadir}/inkscape/[!e]*
+%{_datadir}/inkscape/examples
+%dir %{_datadir}/inkscape/extensions
+%{_datadir}/inkscape/extensions/Poly3DObjects/
+%{_datadir}/inkscape/extensions/alphabet_soup/
+%{_datadir}/inkscape/extensions/*.inx
+%{_datadir}/inkscape/extensions/*.js
+%{_datadir}/inkscape/extensions/*.xml
+%{_datadir}/inkscape/extensions/*.xsl
+%{_datadir}/inkscape/extensions/*.xslt
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
+%attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
+%dir %{_datadir}/inkscape/extensions/Barcode
+%attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
+%dir %{_datadir}/inkscape/extensions/xaml2svg
+%{_datadir}/inkscape/extensions/xaml2svg/*.xsl
 %{_mandir}/man1/*
+%lang(fr) %{_mandir}/fr/man1/*
 %{_pixmapsdir}/*.png
 %{_desktopdir}/*.desktop
This page took 0.070002 seconds and 4 git commands to generate.