]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- inkscape-c++.patch: C++ fixes needed for gcc4.
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_without  xft             # Don't use xft scalable font database
4 %bcond_without  gnome_print     # Don't use gnome print font database and spooler frontend
5 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
6 %bcond_with     inkboard        # Enable inkboard support
7 %bcond_with     relocation      # Enable binary relocation support
8 #
9 Summary:        Scalable vector graphics editor
10 Summary(pl):    Edytor skalowalnej grafiki wektorowej
11 Name:           inkscape
12 Version:        0.43
13 Release:        1
14 License:        GPL v2, LGPL v2.1
15 Group:          Applications/Graphics
16 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
17 # Source0-md5:  97c606182f5e177eef70c1e8a55efc1f
18 Patch0:         %{name}-c++.patch
19 URL:            http://www.inkscape.org/
20 BuildRequires:  autoconf >= 2.59-3
21 BuildRequires:  automake >= 1:1.9.4-2
22 BuildRequires:  freetype-devel >= 2.0
23 BuildRequires:  gc-devel >= 6.4
24 BuildRequires:  gcc-c++ >= 3.0
25 BuildRequires:  gtk+2-devel >= 2:2.4.0
26 BuildRequires:  gtkmm-devel >= 2.4
27 BuildRequires:  gtkspell-devel >= 2.0
28 BuildRequires:  intltool >= 0.22
29 BuildRequires:  libart_lgpl-devel >= 2.3.10
30 %{?with_gnome_print:BuildRequires:      libgnomeprintui-devel >= 1.116.0}
31 BuildRequires:  libpng-devel >= 1.2
32 BuildRequires:  libsigc++-devel >= 2.0.3
33 BuildRequires:  libtool
34 BuildRequires:  libxml2-devel >= 2.6.0
35 BuildRequires:  libxslt-devel >= 1.0.15
36 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0}
37 BuildRequires:  pkgconfig
38 BuildRequires:  popt-devel
39 %{?with_xft:BuildRequires:      xft-devel}
40 BuildRequires:  zlib-devel
41 Requires(post,postun):  shared-mime-info
42 Requires:       gc >= 6.4
43 Requires:       gtk+2 >= 2:2.4.0
44 Requires:       perl-XML-XQL
45 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Inkscape is a program for viewing, making, and editing two-dimensional
49 vector drawings.
50
51 %description -l pl
52 Inkscape jest programem do przeglĀ±dania, tworzenia i edycji
53 dwuwymiarowej grafiki wektorowej.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 %{__libtoolize}
61 %{__glib_gettextize}
62 %{__intltoolize}
63 %{__aclocal}
64 %{__autoheader}
65 %{__automake}
66 %{__autoconf}
67 %configure \
68         %{!?with_xft: --without-xft} \
69         %{!?with_gnome_print: --without-gnome-print} \
70         %{?with_gnome_print: --with-gnome-print} \
71         %{!?with_mmx:--disable-mmx} \
72         %{?with_relocation:--enable-binreloc} \
73         %{?with_inkboard:--enable-inkboard} \
74         --disable-static
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %find_lang %{name}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89
90 %post
91 umask 022
92 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
93 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
94
95 %postun
96 umask 022
97 update-mime-database %{_datadir}/mime >/dev/null 2>&1
98 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog NEWS README TRANSLATORS
103 %lang(ca) %doc README.ca.txt
104 %lang(de) %doc README.de.txt
105 %lang(es) %doc README.es.txt
106 %lang(fr) %doc README.fr.txt
107 %lang(it) %doc README.it.txt
108 %attr(755,root,root) %{_bindir}/*
109 %dir %{_datadir}/inkscape
110 %{_datadir}/inkscape/[!e]*
111 %{_datadir}/inkscape/examples
112 %dir %{_datadir}/inkscape/extensions
113 %{_datadir}/inkscape/extensions/*.inx
114 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
115 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
116 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
117 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
118 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
119 %{_mandir}/man1/*
120 %lang(fr) %{_mandir}/fr/man1/*
121 %{_pixmapsdir}/*.png
122 %{_desktopdir}/*.desktop
This page took 0.036576 seconds and 4 git commands to generate.