]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- release 6
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.48.0
19 Release:        6
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 Source0:        http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  fd8b17a3f06668603807176a77167bb9
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-ldl.patch
26 URL:            http://www.inkscape.org/
27 BuildRequires:  ImageMagick-c++-devel
28 BuildRequires:  aspell-devel
29 BuildRequires:  autoconf >= 2.59-3
30 BuildRequires:  automake >= 1:1.9.4-2
31 BuildRequires:  boost-devel >= 1.35.0
32 BuildRequires:  cairo-devel >= 1.8.0
33 BuildRequires:  freetype-devel >= 2.0
34 BuildRequires:  gc-devel >= 6.4
35 BuildRequires:  gettext-devel
36 BuildRequires:  glibmm-devel >= 2.16.0
37 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
38 BuildRequires:  gsl-devel
39 BuildRequires:  gtk+2-devel >= 2:2.14.0
40 BuildRequires:  gtkmm-devel >= 2.10.0
41 BuildRequires:  gtkspell-devel >= 2.0.11
42 BuildRequires:  intltool >= 0.35.0
43 BuildRequires:  lcms-devel >= 1.15
44 BuildRequires:  libpng-devel >= 1.2
45 BuildRequires:  libsigc++-devel >= 2.0.17
46 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
47 BuildRequires:  libtool
48 BuildRequires:  libwpg-devel
49 BuildRequires:  libxml2-devel >= 1:2.6.26
50 BuildRequires:  libxslt-devel >= 1.1.17
51 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
52 BuildRequires:  pkgconfig
53 BuildRequires:  poppler-glib-devel >= 0.12.2
54 BuildRequires:  popt-devel
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  sed >= 4.0
57 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
58 BuildRequires:  zlib-devel
59 Requires(post,postun):  desktop-file-utils
60 Requires:       gc >= 6.4
61 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
62 Requires:       gtk+2 >= 2:2.14.0
63 Requires:       perl-XML-XQL
64 Suggests:       python-lxml
65 # sr@Latn vs. sr@latin
66 Conflicts:      glibc-misc < 6:2.7
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Inkscape is a program for viewing, making, and editing two-dimensional
71 vector drawings.
72
73 %description -l pl.UTF-8
74 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
75 dwuwymiarowej grafiki wektorowej.
76
77 %prep
78 %setup -q -n %{name}-%{version}%{beta}
79 %patch0 -p1
80
81 rm -f po/en_US@piglatin.po
82 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
83
84 mv po/te_IN.po po/te.po
85 %{__sed} -i -e 's|te_IN|te|' configure.ac
86
87 %build
88 %{__libtoolize}
89 %{__glib_gettextize}
90 %{__intltoolize}
91 %{__aclocal}
92 %{__autoheader}
93 %{__automake}
94 %{__autoconf}
95 %configure \
96         %{!?with_xft: --without-xft} \
97         %{!?with_gnomevfs:--without-gnome-vfs} \
98         %{!?with_mmx:--disable-mmx} \
99         %{?with_relocation:--enable-binreloc} \
100         %{?with_inkboard:--enable-inkboard}
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115
116 %post
117 %update_desktop_database_post
118
119 %postun
120 %update_desktop_database_postun
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
125 %lang(ca) %doc README.ca.txt
126 %lang(de) %doc README.de.txt
127 %lang(es) %doc README.es.txt
128 %lang(fr) %doc README.fr.txt
129 %lang(it) %doc README.it.txt
130 %lang(de) %doc doc/HACKING.de.txt
131 %lang(fr) %doc doc/HACKING.fr.txt
132 %lang(it) %doc doc/HACKING.it.txt
133 %attr(755,root,root) %{_bindir}/inkscape
134 %attr(755,root,root) %{_bindir}/inkview
135 %dir %{_datadir}/inkscape
136 %{_datadir}/inkscape/[!e]*
137 %{_datadir}/inkscape/examples
138 %dir %{_datadir}/inkscape/extensions
139 %{_datadir}/inkscape/extensions/Poly3DObjects/
140 %{_datadir}/inkscape/extensions/alphabet_soup/
141 %{_datadir}/inkscape/extensions/*.inx
142 %{_datadir}/inkscape/extensions/*.js
143 %{_datadir}/inkscape/extensions/*.xml
144 %{_datadir}/inkscape/extensions/*.xsl
145 %{_datadir}/inkscape/extensions/*.xslt
146 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
147 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
148 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
149 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
150 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
151 %dir %{_datadir}/inkscape/extensions/Barcode
152 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
153 %dir %{_datadir}/inkscape/extensions/xaml2svg
154 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
155 %{_mandir}/man1/*.1*
156 %lang(fr) %{_mandir}/fr/man1/*.1*
157 %{_iconsdir}/hicolor/*/apps/inkscape.png
158 %{_desktopdir}/inkscape.desktop
This page took 0.070694 seconds and 4 git commands to generate.