]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- reorganize boost BRs (boost-devel >= 1.35.0).
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.46
16 Release:        3
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  3bae9034047379012127e52f9b138d32
21 Patch1:         %{name}-desktop.patch
22 URL:            http://www.inkscape.org/
23 BuildRequires:  autoconf >= 2.59-3
24 BuildRequires:  automake >= 1:1.9.4-2
25 BuildRequires:  boost-devel >= 1.35.0
26 BuildRequires:  freetype-devel >= 2.0
27 BuildRequires:  gcc-c++ >= 6:4.2.2-2
28 BuildRequires:  gc-devel >= 6.4
29 BuildRequires:  gettext-devel
30 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
31 BuildRequires:  gtk+2-devel >= 2:2.9.4
32 BuildRequires:  gtkmm-devel >= 2.4
33 BuildRequires:  gtkspell-devel >= 2.0.11
34 BuildRequires:  intltool >= 0.35.0
35 BuildRequires:  lcms-devel >= 1.15
36 BuildRequires:  libart_lgpl-devel >= 2.3.10
37 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
38 BuildRequires:  libpng-devel >= 1.2
39 BuildRequires:  libsigc++-devel >= 2.0.17
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.26
42 BuildRequires:  libxslt-devel >= 1.1.17
43 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
44 BuildRequires:  pkgconfig
45 BuildRequires:  popt-devel
46 BuildRequires:  rpm-pythonprov
47 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
48 BuildRequires:  zlib-devel
49 Requires(post,postun):  shared-mime-info
50 Requires:       gc >= 6.4
51 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
52 Requires:       gtk+2 >= 2:2.9.4
53 Requires:       perl-XML-XQL
54 # sr@Latn vs. sr@latin
55 Conflicts:      glibc-misc < 6:2.7
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Inkscape is a program for viewing, making, and editing two-dimensional
60 vector drawings.
61
62 %description -l pl.UTF-8
63 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
64 dwuwymiarowej grafiki wektorowej.
65
66 %prep
67 %setup -q
68 %patch1 -p1
69 rm -f po/ca@valencia.po
70 rm -f po/en_US@piglatin.po
71 sed -i -e 's|ca@valencia||' configure.ac
72 sed -i -e 's|en_US@piglatin||' configure.ac
73
74 %build
75 %{__libtoolize}
76 %{__glib_gettextize}
77 %{__intltoolize}
78 %{__aclocal}
79 %{__autoheader}
80 %{__automake}
81 %{__autoconf}
82 %configure \
83         %{!?with_xft: --without-xft} \
84         %{!?with_gnomeprint:--without-gnome-print} \
85         %{?with_gnomeprint:--with-gnome-print} \
86         %{!?with_gnomevfs:--without-gnome-vfs} \
87         %{!?with_mmx:--disable-mmx} \
88         %{?with_relocation:--enable-binreloc} \
89         %{?with_inkboard:--enable-inkboard} \
90         --disable-static
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
101         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107
108 %post
109 umask 022
110 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
111 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
112
113 %postun
114 umask 022
115 update-mime-database %{_datadir}/mime >/dev/null 2>&1
116 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
121 %lang(ca) %doc README.ca.txt
122 %lang(de) %doc README.de.txt
123 %lang(es) %doc README.es.txt
124 %lang(fr) %doc README.fr.txt
125 %lang(it) %doc README.it.txt
126 %lang(de) %doc HACKING.de.txt
127 %lang(fr) %doc HACKING.fr.txt
128 %lang(it) %doc HACKING.it.txt
129 %attr(755,root,root) %{_bindir}/*
130 %dir %{_datadir}/inkscape
131 %{_datadir}/inkscape/[!e]*
132 %{_datadir}/inkscape/examples
133 %dir %{_datadir}/inkscape/extensions
134 %{_datadir}/inkscape/extensions/*.cmd
135 %{_datadir}/inkscape/extensions/*.inx
136 %{_datadir}/inkscape/extensions/*.txt
137 %{_datadir}/inkscape/extensions/*.xml
138 %{_datadir}/inkscape/extensions/*.xsl
139 %{_datadir}/inkscape/extensions/*.xslt
140 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
141 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
142 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
143 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
144 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
145 %dir %{_datadir}/inkscape/extensions/Barcode
146 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
147 %dir %{_datadir}/inkscape/extensions/xaml2svg
148 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
149 %{_mandir}/man1/*
150 %lang(fr) %{_mandir}/fr/man1/*
151 %{_pixmapsdir}/*.png
152 %{_desktopdir}/*.desktop
This page took 0.113762 seconds and 4 git commands to generate.