]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- added -poppler.patch and -gcc43.patch
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.46
16 Release:        4
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  3bae9034047379012127e52f9b138d32
21 Patch1:         %{name}-desktop.patch
22 Patch2:         %{name}-poppler.patch
23 Patch3:         %{name}-gcc43.patch
24 URL:            http://www.inkscape.org/
25 BuildRequires:  autoconf >= 2.59-3
26 BuildRequires:  automake >= 1:1.9.4-2
27 BuildRequires:  boost-devel >= 1.35.0
28 BuildRequires:  freetype-devel >= 2.0
29 BuildRequires:  gcc-c++ >= 6:4.2.2-2
30 BuildRequires:  gc-devel >= 6.4
31 BuildRequires:  gettext-devel
32 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
33 BuildRequires:  gtk+2-devel >= 2:2.9.4
34 BuildRequires:  gtkmm-devel >= 2.10.0
35 BuildRequires:  gtkspell-devel >= 2.0.11
36 BuildRequires:  intltool >= 0.35.0
37 BuildRequires:  lcms-devel >= 1.15
38 BuildRequires:  libart_lgpl-devel >= 2.3.10
39 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
40 BuildRequires:  libpng-devel >= 1.2
41 BuildRequires:  libsigc++-devel >= 2.0.17
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.26
44 BuildRequires:  libxslt-devel >= 1.1.17
45 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
46 BuildRequires:  pkgconfig
47 BuildRequires:  popt-devel
48 BuildRequires:  rpm-pythonprov
49 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
50 BuildRequires:  zlib-devel
51 Requires(post,postun):  shared-mime-info
52 Requires:       gc >= 6.4
53 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
54 Requires:       gtk+2 >= 2:2.9.4
55 Requires:       perl-XML-XQL
56 Suggests:       python-lxml
57 # sr@Latn vs. sr@latin
58 Conflicts:      glibc-misc < 6:2.7
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Inkscape is a program for viewing, making, and editing two-dimensional
63 vector drawings.
64
65 %description -l pl.UTF-8
66 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
67 dwuwymiarowej grafiki wektorowej.
68
69 %prep
70 %setup -q
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 rm -f po/ca@valencia.po
75 rm -f po/en_US@piglatin.po
76 sed -i -e 's|ca@valencia||' configure.ac
77 sed -i -e 's|en_US@piglatin||' configure.ac
78
79 %build
80 %{__libtoolize}
81 %{__glib_gettextize}
82 %{__intltoolize}
83 %{__aclocal}
84 %{__autoheader}
85 %{__automake}
86 %{__autoconf}
87 %configure \
88         %{!?with_xft: --without-xft} \
89         %{!?with_gnomeprint:--without-gnome-print} \
90         %{?with_gnomeprint:--with-gnome-print} \
91         %{!?with_gnomevfs:--without-gnome-vfs} \
92         %{!?with_mmx:--disable-mmx} \
93         %{?with_relocation:--enable-binreloc} \
94         %{?with_inkboard:--enable-inkboard} \
95         --disable-static
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
106         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112
113 %post
114 umask 022
115 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
116 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
117
118 %postun
119 umask 022
120 update-mime-database %{_datadir}/mime >/dev/null 2>&1
121 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
126 %lang(ca) %doc README.ca.txt
127 %lang(de) %doc README.de.txt
128 %lang(es) %doc README.es.txt
129 %lang(fr) %doc README.fr.txt
130 %lang(it) %doc README.it.txt
131 %lang(de) %doc HACKING.de.txt
132 %lang(fr) %doc HACKING.fr.txt
133 %lang(it) %doc HACKING.it.txt
134 %attr(755,root,root) %{_bindir}/*
135 %dir %{_datadir}/inkscape
136 %{_datadir}/inkscape/[!e]*
137 %{_datadir}/inkscape/examples
138 %dir %{_datadir}/inkscape/extensions
139 %{_datadir}/inkscape/extensions/*.cmd
140 %{_datadir}/inkscape/extensions/*.inx
141 %{_datadir}/inkscape/extensions/*.txt
142 %{_datadir}/inkscape/extensions/*.xml
143 %{_datadir}/inkscape/extensions/*.xsl
144 %{_datadir}/inkscape/extensions/*.xslt
145 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
146 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
147 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
148 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
149 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
150 %dir %{_datadir}/inkscape/extensions/Barcode
151 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
152 %dir %{_datadir}/inkscape/extensions/xaml2svg
153 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
154 %{_mandir}/man1/*
155 %lang(fr) %{_mandir}/fr/man1/*
156 %{_pixmapsdir}/*.png
157 %{_desktopdir}/*.desktop
This page took 0.061176 seconds and 4 git commands to generate.