]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- rel 8
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.46
16 Release:        8
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  3bae9034047379012127e52f9b138d32
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-poppler.patch
23 Patch2:         %{name}-gcc43.patch
24 Patch3:         %{name}-gtk2.patch
25 Patch4:         %{name}-slider.patch
26 Patch5:         %{name}-gcc44.patch
27 Patch6:         %{name}-early-png-header.patch
28 Patch7:         %{name}-gchar.patch
29 Patch8:         %{name}-install.patch
30 URL:            http://www.inkscape.org/
31 BuildRequires:  autoconf >= 2.59-3
32 BuildRequires:  automake >= 1:1.9.4-2
33 BuildRequires:  boost-devel >= 1.35.0
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  gcc-c++ >= 6:4.2.2-2
36 BuildRequires:  gc-devel >= 6.4
37 BuildRequires:  gettext-devel
38 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
39 BuildRequires:  gtk+2-devel >= 2:2.9.4
40 BuildRequires:  gtkmm-devel >= 2.10.0
41 BuildRequires:  gtkspell-devel >= 2.0.11
42 BuildRequires:  intltool >= 0.35.0
43 BuildRequires:  lcms-devel >= 1.15
44 BuildRequires:  libart_lgpl-devel >= 2.3.10
45 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
46 BuildRequires:  libpng-devel >= 1.2
47 BuildRequires:  libsigc++-devel >= 2.0.17
48 BuildRequires:  libtool
49 BuildRequires:  libxml2-devel >= 1:2.6.26
50 BuildRequires:  libxslt-devel >= 1.1.17
51 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
52 BuildRequires:  pkgconfig
53 BuildRequires:  popt-devel
54 BuildRequires:  rpm-pythonprov
55 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
56 BuildRequires:  zlib-devel
57 Requires(post,postun):  shared-mime-info
58 Requires:       gc >= 6.4
59 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
60 Requires:       gtk+2 >= 2:2.9.4
61 Requires:       perl-XML-XQL
62 Suggests:       python-lxml
63 # sr@Latn vs. sr@latin
64 Conflicts:      glibc-misc < 6:2.7
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 Inkscape is a program for viewing, making, and editing two-dimensional
69 vector drawings.
70
71 %description -l pl.UTF-8
72 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
73 dwuwymiarowej grafiki wektorowej.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80 %patch3 -p1
81 %patch4 -p1
82 %patch5 -p1
83 %patch6 -p1
84 %patch7 -p1
85 %patch8 -p1
86
87
88 rm -f po/ca@valencia.po
89 rm -f po/en_US@piglatin.po
90 sed -i -e 's|ca@valencia||' configure.ac
91 sed -i -e 's|en_US@piglatin||' configure.ac
92
93 %build
94 %{__libtoolize}
95 %{__glib_gettextize}
96 %{__intltoolize}
97 %{__aclocal}
98 %{__autoheader}
99 %{__automake}
100 %{__autoconf}
101 %configure \
102         %{!?with_xft: --without-xft} \
103         %{!?with_gnomeprint:--without-gnome-print} \
104         %{?with_gnomeprint:--with-gnome-print} \
105         %{!?with_gnomevfs:--without-gnome-vfs} \
106         %{!?with_mmx:--disable-mmx} \
107         %{?with_relocation:--enable-binreloc} \
108         %{?with_inkboard:--enable-inkboard} \
109         --disable-static
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
120         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126
127 %post
128 umask 022
129 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
130 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
131
132 %postun
133 umask 022
134 update-mime-database %{_datadir}/mime >/dev/null 2>&1
135 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
140 %lang(ca) %doc README.ca.txt
141 %lang(de) %doc README.de.txt
142 %lang(es) %doc README.es.txt
143 %lang(fr) %doc README.fr.txt
144 %lang(it) %doc README.it.txt
145 %lang(de) %doc HACKING.de.txt
146 %lang(fr) %doc HACKING.fr.txt
147 %lang(it) %doc HACKING.it.txt
148 %attr(755,root,root) %{_bindir}/*
149 %dir %{_datadir}/inkscape
150 %{_datadir}/inkscape/[!e]*
151 %{_datadir}/inkscape/examples
152 %dir %{_datadir}/inkscape/extensions
153 %{_datadir}/inkscape/extensions/*.cmd
154 %{_datadir}/inkscape/extensions/*.inx
155 %{_datadir}/inkscape/extensions/*.txt
156 %{_datadir}/inkscape/extensions/*.xml
157 %{_datadir}/inkscape/extensions/*.xsl
158 %{_datadir}/inkscape/extensions/*.xslt
159 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
160 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
161 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
162 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
163 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
164 %dir %{_datadir}/inkscape/extensions/Barcode
165 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
166 %dir %{_datadir}/inkscape/extensions/xaml2svg
167 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
168 %{_mandir}/man1/*
169 %lang(fr) %{_mandir}/fr/man1/*
170 %{_pixmapsdir}/*.png
171 %{_desktopdir}/*.desktop
This page took 0.052266 seconds and 4 git commands to generate.