]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- rel 9; fix glib/poppler build
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.48.2
19 Release:        9
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 Source0:        http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  f60b98013bd1121b2cc301f3485076ba
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-ldl.patch
26 Patch1:         %{name}-0.48.1-libpng15.patch
27 Patch2:         inkscape-0.48.2-glib.patch
28 Patch3:         inkscape-poppler.patch
29 URL:            http://www.inkscape.org/
30 BuildRequires:  ImageMagick-c++-devel
31 BuildRequires:  aspell-devel
32 BuildRequires:  autoconf >= 2.59-3
33 BuildRequires:  automake >= 1:1.9.4-2
34 BuildRequires:  boost-devel >= 1.35.0
35 BuildRequires:  cairo-devel >= 1.8.0
36 BuildRequires:  freetype-devel >= 2.0
37 BuildRequires:  gc-devel >= 6.4
38 BuildRequires:  gettext-devel
39 BuildRequires:  glibmm-devel >= 2.16.0
40 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
41 BuildRequires:  gsl-devel
42 BuildRequires:  gtk+2-devel >= 2:2.14.0
43 BuildRequires:  gtkmm-devel >= 2.10.0
44 BuildRequires:  gtkspell-devel >= 2.0.11
45 BuildRequires:  intltool >= 0.35.0
46 BuildRequires:  lcms-devel >= 1.15
47 BuildRequires:  libpng-devel >= 1.2
48 BuildRequires:  libsigc++-devel >= 2.0.17
49 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
50 BuildRequires:  libtool
51 BuildRequires:  libwpg-devel
52 BuildRequires:  libxml2-devel >= 1:2.6.26
53 BuildRequires:  libxslt-devel >= 1.1.17
54 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
55 BuildRequires:  pkgconfig
56 BuildRequires:  poppler-glib-devel >= 0.12.2
57 BuildRequires:  popt-devel
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  sed >= 4.0
60 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
61 BuildRequires:  zlib-devel
62 Requires(post,postun):  desktop-file-utils
63 Requires:       gc >= 6.4
64 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
65 Requires:       gtk+2 >= 2:2.14.0
66 Requires:       perl-XML-XQL
67 Suggests:       python-lxml
68 # sr@Latn vs. sr@latin
69 Conflicts:      glibc-misc < 6:2.7
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Inkscape is a program for viewing, making, and editing two-dimensional
74 vector drawings.
75
76 %description -l pl.UTF-8
77 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
78 dwuwymiarowej grafiki wektorowej.
79
80 %prep
81 %setup -q -n %{name}-%{version}%{beta}
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86
87 %{__rm} po/en_US@piglatin.po
88 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
89
90 mv po/te_IN.po po/te.po
91 %{__sed} -i -e 's|te_IN|te|' configure.ac
92
93 %build
94 %{__libtoolize}
95 %{__glib_gettextize}
96 %{__intltoolize}
97 %{__aclocal}
98 %{__autoheader}
99 %{__automake}
100 %{__autoconf}
101 %configure \
102         --disable-silent-rules \
103         %{!?with_xft: --without-xft} \
104         %{!?with_gnomevfs:--without-gnome-vfs} \
105         %{!?with_mmx:--disable-mmx} \
106         %{?with_relocation:--enable-binreloc} \
107         %{?with_inkboard:--enable-inkboard}
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122
123 %post
124 %update_desktop_database_post
125
126 %postun
127 %update_desktop_database_postun
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
132 %lang(ca) %doc README.ca.txt
133 %lang(de) %doc README.de.txt
134 %lang(es) %doc README.es.txt
135 %lang(fr) %doc README.fr.txt
136 %lang(it) %doc README.it.txt
137 %lang(de) %doc doc/HACKING.de.txt
138 %lang(fr) %doc doc/HACKING.fr.txt
139 %lang(it) %doc doc/HACKING.it.txt
140 %attr(755,root,root) %{_bindir}/inkscape
141 %attr(755,root,root) %{_bindir}/inkview
142 %dir %{_datadir}/inkscape
143 %{_datadir}/inkscape/[!e]*
144 %{_datadir}/inkscape/examples
145 %dir %{_datadir}/inkscape/extensions
146 %{_datadir}/inkscape/extensions/Poly3DObjects/
147 %{_datadir}/inkscape/extensions/alphabet_soup/
148 %{_datadir}/inkscape/extensions/*.inx
149 %{_datadir}/inkscape/extensions/*.js
150 %{_datadir}/inkscape/extensions/*.xml
151 %{_datadir}/inkscape/extensions/*.xsl
152 %{_datadir}/inkscape/extensions/*.xslt
153 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
154 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
155 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
156 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
157 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
158 %dir %{_datadir}/inkscape/extensions/Barcode
159 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
160 %dir %{_datadir}/inkscape/extensions/xaml2svg
161 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
162 %{_mandir}/man1/*.1*
163 %lang(fr) %{_mandir}/fr/man1/*.1*
164 %{_iconsdir}/hicolor/*/apps/inkscape.png
165 %{_desktopdir}/inkscape.desktop
This page took 0.062858 seconds and 4 git commands to generate.