]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- release 2 - to build with new libpng
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnome_print     # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnome_vfs       # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl):    Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.44
16 Release:        2
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
20 # Source0-md5:  f0bf316e15ddc6009976d97388522f85
21 URL:            http://www.inkscape.org/
22 BuildRequires:  autoconf >= 2.59-3
23 BuildRequires:  automake >= 1:1.9.4-2
24 BuildRequires:  boost-any-devel
25 BuildRequires:  boost-bind-devel
26 BuildRequires:  freetype-devel >= 2.0
27 BuildRequires:  gcc-c++ >= 3.0
28 BuildRequires:  gc-devel >= 6.4
29 %{?with_gnome_vfs:BuildRequires:        gnome-vfs2-devel >= 2.15.2}
30 BuildRequires:  gtk+2-devel >= 2:2.9.4
31 BuildRequires:  gtkmm-devel >= 2.4
32 BuildRequires:  gtkspell-devel >= 2.0.11
33 BuildRequires:  intltool >= 0.35.0
34 BuildRequires:  lcms-devel >= 1.15
35 BuildRequires:  libart_lgpl-devel >= 2.3.10
36 %{?with_gnome_print:BuildRequires:      libgnomeprintui-devel >= 2.12.1}
37 BuildRequires:  libpng-devel >= 1.2
38 BuildRequires:  libsigc++-devel >= 2.0.17
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 1:2.6.26
41 BuildRequires:  libxslt-devel >= 1.1.17
42 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
43 BuildRequires:  pkgconfig
44 BuildRequires:  popt-devel
45 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
46 BuildRequires:  zlib-devel
47 Requires(post,postun):  shared-mime-info
48 Requires:       gc >= 6.4
49 Requires:       gtk+2 >= 2:2.9.4
50 Requires:       perl-XML-XQL
51 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Inkscape is a program for viewing, making, and editing two-dimensional
55 vector drawings.
56
57 %description -l pl
58 Inkscape jest programem do przeglĀ±dania, tworzenia i edycji
59 dwuwymiarowej grafiki wektorowej.
60
61 %prep
62 %setup -q
63
64 %build
65 %{__libtoolize}
66 %{__glib_gettextize}
67 %{__intltoolize}
68 %{__aclocal}
69 %{__autoheader}
70 %{__automake}
71 %{__autoconf}
72 %configure \
73         %{!?with_xft: --without-xft} \
74         %{!?with_gnome_print:--without-gnome-print} \
75         %{?with_gnome_print:--with-gnome-print} \
76         %{!?with_gnome_vfs:--without-gnome-vfs} \
77         %{!?with_mmx:--disable-mmx} \
78         %{?with_relocation:--enable-binreloc} \
79         %{?with_inkboard:--enable-inkboard} \
80         --disable-static
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %find_lang %{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95
96 %post
97 umask 022
98 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
99 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
100
101 %postun
102 umask 022
103 update-mime-database %{_datadir}/mime >/dev/null 2>&1
104 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
105
106 %files -f %{name}.lang
107 %defattr(644,root,root,755)
108 %doc AUTHORS ChangeLog NEWS README TRANSLATORS
109 %lang(ca) %doc README.ca.txt
110 %lang(de) %doc README.de.txt
111 %lang(es) %doc README.es.txt
112 %lang(fr) %doc README.fr.txt
113 %lang(it) %doc README.it.txt
114 %attr(755,root,root) %{_bindir}/*
115 %dir %{_datadir}/inkscape
116 %{_datadir}/inkscape/[!e]*
117 %{_datadir}/inkscape/examples
118 %dir %{_datadir}/inkscape/extensions
119 %{_datadir}/inkscape/extensions/*.cmd
120 %{_datadir}/inkscape/extensions/*.inx
121 %{_datadir}/inkscape/extensions/*.txt
122 %{_datadir}/inkscape/extensions/*.xslt
123 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
124 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
125 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
126 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
127 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
128 %{_mandir}/man1/*
129 %lang(fr) %{_mandir}/fr/man1/*
130 %{_pixmapsdir}/*.png
131 %{_desktopdir}/*.desktop
This page took 0.0671659999999999 seconds and 4 git commands to generate.