]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- release 4.
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnome_print     # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnome_vfs       # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl):    Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.44
16 Release:        4
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
20 # Source0-md5:  f0bf316e15ddc6009976d97388522f85
21 URL:            http://www.inkscape.org/
22 BuildRequires:  autoconf >= 2.59-3
23 BuildRequires:  automake >= 1:1.9.4-2
24 BuildRequires:  boost-any-devel
25 BuildRequires:  boost-bind-devel
26 BuildRequires:  freetype-devel >= 2.0
27 BuildRequires:  gcc-c++ >= 3.0
28 BuildRequires:  gc-devel >= 6.4
29 BuildRequires:  gettext-devel
30 %{?with_gnome_vfs:BuildRequires:        gnome-vfs2-devel >= 2.15.2}
31 BuildRequires:  gtk+2-devel >= 2:2.9.4
32 BuildRequires:  gtkmm-devel >= 2.4
33 BuildRequires:  gtkspell-devel >= 2.0.11
34 BuildRequires:  intltool >= 0.35.0
35 BuildRequires:  lcms-devel >= 1.15
36 BuildRequires:  libart_lgpl-devel >= 2.3.10
37 %{?with_gnome_print:BuildRequires:      libgnomeprintui-devel >= 2.12.1}
38 BuildRequires:  libpng-devel >= 1.2
39 BuildRequires:  libsigc++-devel >= 2.0.17
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.26
42 BuildRequires:  libxslt-devel >= 1.1.17
43 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
44 BuildRequires:  pkgconfig
45 BuildRequires:  popt-devel
46 BuildRequires:  rpm-pythonprov
47 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
48 BuildRequires:  zlib-devel
49 Requires(post,postun):  shared-mime-info
50 Requires:       gc >= 6.4
51 Requires:       gtk+2 >= 2:2.9.4
52 Requires:       perl-XML-XQL
53 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Inkscape is a program for viewing, making, and editing two-dimensional
57 vector drawings.
58
59 %description -l pl
60 Inkscape jest programem do przeglĀ±dania, tworzenia i edycji
61 dwuwymiarowej grafiki wektorowej.
62
63 %prep
64 %setup -q
65
66 %build
67 %{__libtoolize}
68 %{__glib_gettextize}
69 %{__intltoolize}
70 %{__aclocal}
71 %{__autoheader}
72 %{__automake}
73 %{__autoconf}
74 %configure \
75         %{!?with_xft: --without-xft} \
76         %{!?with_gnome_print:--without-gnome-print} \
77         %{?with_gnome_print:--with-gnome-print} \
78         %{!?with_gnome_vfs:--without-gnome-vfs} \
79         %{!?with_mmx:--disable-mmx} \
80         %{?with_relocation:--enable-binreloc} \
81         %{?with_inkboard:--enable-inkboard} \
82         --disable-static
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97
98 %post
99 umask 022
100 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
101 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
102
103 %postun
104 umask 022
105 update-mime-database %{_datadir}/mime >/dev/null 2>&1
106 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README TRANSLATORS
111 %lang(ca) %doc README.ca.txt
112 %lang(de) %doc README.de.txt
113 %lang(es) %doc README.es.txt
114 %lang(fr) %doc README.fr.txt
115 %lang(it) %doc README.it.txt
116 %attr(755,root,root) %{_bindir}/*
117 %dir %{_datadir}/inkscape
118 %{_datadir}/inkscape/[!e]*
119 %{_datadir}/inkscape/examples
120 %dir %{_datadir}/inkscape/extensions
121 %{_datadir}/inkscape/extensions/*.cmd
122 %{_datadir}/inkscape/extensions/*.inx
123 %{_datadir}/inkscape/extensions/*.txt
124 %{_datadir}/inkscape/extensions/*.xslt
125 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
126 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
127 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
128 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
129 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
130 %{_mandir}/man1/*
131 %lang(fr) %{_mandir}/fr/man1/*
132 %{_pixmapsdir}/*.png
133 %{_desktopdir}/*.desktop
This page took 0.039465 seconds and 4 git commands to generate.