]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- updated to 0.45.1
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.45.1
16 Release:        1
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  1ac63dfd5d78a676599bf5cf6d22e493
21 Patch0:         %{name}-ac.patch
22 URL:            http://www.inkscape.org/
23 BuildRequires:  autoconf >= 2.59-3
24 BuildRequires:  automake >= 1:1.9.4-2
25 BuildRequires:  boost-any-devel
26 BuildRequires:  boost-bind-devel
27 BuildRequires:  freetype-devel >= 2.0
28 BuildRequires:  gcc-c++ >= 3.0
29 BuildRequires:  gc-devel >= 6.4
30 BuildRequires:  gettext-devel
31 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
32 BuildRequires:  gtk+2-devel >= 2:2.9.4
33 BuildRequires:  gtkmm-devel >= 2.4
34 BuildRequires:  gtkspell-devel >= 2.0.11
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  lcms-devel >= 1.15
37 BuildRequires:  libart_lgpl-devel >= 2.3.10
38 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
39 BuildRequires:  libpng-devel >= 1.2
40 BuildRequires:  libsigc++-devel >= 2.0.17
41 BuildRequires:  libtool
42 BuildRequires:  libxml2-devel >= 1:2.6.26
43 BuildRequires:  libxslt-devel >= 1.1.17
44 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
45 BuildRequires:  pkgconfig
46 BuildRequires:  popt-devel
47 BuildRequires:  rpm-pythonprov
48 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
49 BuildRequires:  zlib-devel
50 Requires(post,postun):  shared-mime-info
51 Requires:       gc >= 6.4
52 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
53 Requires:       gtk+2 >= 2:2.9.4
54 Requires:       perl-XML-XQL
55 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Inkscape is a program for viewing, making, and editing two-dimensional
59 vector drawings.
60
61 %description -l pl.UTF-8
62 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
63 dwuwymiarowej grafiki wektorowej.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 rm -f po/en_US@piglatin.po
69 sed -i -e 's|en_US@piglatin||' configure.ac
70
71 %build
72 %{__libtoolize}
73 %{__glib_gettextize}
74 %{__intltoolize}
75 %{__aclocal}
76 %{__autoheader}
77 %{__automake}
78 %{__autoconf}
79 %configure \
80         %{!?with_xft: --without-xft} \
81         %{!?with_gnomeprint:--without-gnome-print} \
82         %{?with_gnomeprint:--with-gnome-print} \
83         %{!?with_gnomevfs:--without-gnome-vfs} \
84         %{!?with_mmx:--disable-mmx} \
85         %{?with_relocation:--enable-binreloc} \
86         %{?with_inkboard:--enable-inkboard} \
87         --disable-static
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %find_lang %{name}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102
103 %post
104 umask 022
105 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
106 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
107
108 %postun
109 umask 022
110 update-mime-database %{_datadir}/mime >/dev/null 2>&1
111 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
112
113 %files -f %{name}.lang
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
116 %lang(ca) %doc README.ca.txt
117 %lang(de) %doc README.de.txt
118 %lang(es) %doc README.es.txt
119 %lang(fr) %doc README.fr.txt
120 %lang(it) %doc README.it.txt
121 %lang(de) %doc HACKING.de.txt
122 %lang(fr) %doc HACKING.fr.txt
123 %lang(it) %doc HACKING.it.txt
124 %attr(755,root,root) %{_bindir}/*
125 %dir %{_datadir}/inkscape
126 %{_datadir}/inkscape/[!e]*
127 %{_datadir}/inkscape/examples
128 %dir %{_datadir}/inkscape/extensions
129 %{_datadir}/inkscape/extensions/*.cmd
130 %{_datadir}/inkscape/extensions/*.inx
131 %{_datadir}/inkscape/extensions/*.txt
132 %{_datadir}/inkscape/extensions/*.xslt
133 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
134 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
135 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
136 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
137 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
138 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
139 %{_mandir}/man1/*
140 %lang(fr) %{_mandir}/fr/man1/*
141 %{_pixmapsdir}/*.png
142 %{_desktopdir}/*.desktop
This page took 0.0484 seconds and 4 git commands to generate.