]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- runtime versioned deps (gc, gtk+)
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_without  xft             # Don't use xft scalable font database
4 %bcond_without  gnome_print     # Don't use gnome print font database and spooler frontend
5 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
6 %bcond_with     relocation      # Enable binary relocation support
7 #
8 Summary:        Scalable vector graphics editor
9 Summary(pl):    Edytor skalowalnej grafiki wektorowej
10 Name:           inkscape
11 Version:        0.41
12 Release:        1
13 License:        GPL v2, LGPL v2.1
14 Group:          Applications/Graphics
15 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
16 # Source0-md5:  9b4bbfaae688127dca4c3d816a42b21a
17 Patch0:         %{name}-gnome_print_compile.patch
18 URL:            http://www.inkscape.org/
19 BuildRequires:  autoconf >= 2.59-3
20 BuildRequires:  automake >= 1:1.9.4-2
21 BuildRequires:  freetype-devel >= 2.0
22 BuildRequires:  gc-devel >= 6.4
23 BuildRequires:  gtk+2-devel >= 2:2.4.0
24 BuildRequires:  gtkmm-devel >= 2.4
25 BuildRequires:  gtkspell-devel
26 BuildRequires:  intltool
27 BuildRequires:  libart_lgpl-devel >= 2.3.10
28 %{?with_gnome_print:BuildRequires:      libgnomeprintui-devel >= 1.116.0}
29 BuildRequires:  libpng-devel
30 BuildRequires:  libsigc++-devel >= 2.0.3
31 BuildRequires:  libtool
32 BuildRequires:  libxml2-devel >= 2.4.24
33 BuildRequires:  pkgconfig
34 BuildRequires:  popt-devel
35 %{?with_xft:BuildRequires:      xft-devel}
36 Requires(post,postun):  shared-mime-info
37 Requires:       gc >= 6.4
38 Requires:       gtk+2 >= 2:2.4.0
39 Requires:       perl-XML-XQL
40 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Inkscape is a program for viewing, making, and editing two-dimensional
44 vector drawings.
45
46 %description -l pl
47 Inkscape jest programem do przeglĀ±dania, tworzenia i edycji
48 dwuwymiarowej grafiki wektorowej.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53
54 %build
55 cp -f /usr/share/automake/mkinstalldirs .
56 %{__libtoolize}
57 glib-gettextize --copy --force
58 intltoolize --copy --force --automake
59 %{__aclocal}
60 %{__autoheader}
61 %{__automake}
62 %{__autoconf}
63 %configure \
64         %{!?with_xft: --without-xft}\
65         %{!?with_gnome_print: --without-gnome-print}\
66         %{?with_gnome_print: --with-gnome-print}\
67         %{!?with_mmx:--disable-mmx} \
68         %{?with_relocation:--enable-binreloc} \
69         --disable-static
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 rm -f $RPM_BUILD_ROOT%{_libdir}/inkscape/plugins/*.la
80
81 %find_lang %{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 umask 022
88 update-mime-database %{_datadir}/mime
89 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
90
91 %postun
92 umask 022
93 update-mime-database %{_datadir}/mime
94 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
95
96 %files -f %{name}.lang
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog README
99 %attr(755,root,root) %{_bindir}/*
100 %{_datadir}/inkscape
101 %dir %{_libdir}/inkscape
102 %dir %{_libdir}/inkscape/plugins
103 # why no -avoid-version?
104 %attr(755,root,root) %{_libdir}/inkscape/plugins/lib*.so*
105 %{_mandir}/man1/*
106 %{_pixmapsdir}/*.png
107 %{_desktopdir}/*.desktop
This page took 0.038479 seconds and 4 git commands to generate.