]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- additional BR's
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnome_print     # Don't use gnome print font database and spooler frontend
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11 Summary:        Scalable vector graphics editor
12 Summary(pl):    Edytor skalowalnej grafiki wektorowej
13 Name:           inkscape
14 Version:        0.44
15 Release:        0.9
16 License:        GPL v2, LGPL v2.1
17 Group:          Applications/Graphics
18 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
19 # Source0-md5:  f0bf316e15ddc6009976d97388522f85
20 URL:            http://www.inkscape.org/
21 BuildRequires:  autoconf >= 2.59-3
22 BuildRequires:  automake >= 1:1.9.4-2
23 BuildRequires:  boost-any-devel
24 BuildRequires:  boost-bind-devel
25 BuildRequires:  freetype-devel >= 2.0
26 BuildRequires:  gc-devel >= 6.4
27 BuildRequires:  gcc-c++ >= 3.0
28 BuildRequires:  gtk+2-devel >= 2:2.4.0
29 BuildRequires:  gtkmm-devel >= 2.4
30 BuildRequires:  gtkspell-devel >= 2.0
31 BuildRequires:  intltool >= 0.22
32 BuildRequires:  lcms-devel
33 BuildRequires:  libart_lgpl-devel >= 2.3.10
34 %{?with_gnome_print:BuildRequires:      libgnomeprintui-devel >= 1.116.0}
35 BuildRequires:  libpng-devel >= 1.2
36 BuildRequires:  libsigc++-devel >= 2.0.3
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2.6.0
39 BuildRequires:  libxslt-devel >= 1.0.15
40 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0}
41 BuildRequires:  pkgconfig
42 BuildRequires:  popt-devel
43 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
44 BuildRequires:  zlib-devel
45 Requires(post,postun):  shared-mime-info
46 Requires:       gc >= 6.4
47 Requires:       gtk+2 >= 2:2.4.0
48 Requires:       perl-XML-XQL
49 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Inkscape is a program for viewing, making, and editing two-dimensional
53 vector drawings.
54
55 %description -l pl
56 Inkscape jest programem do przeglĀ±dania, tworzenia i edycji
57 dwuwymiarowej grafiki wektorowej.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__libtoolize}
64 %{__glib_gettextize}
65 %{__intltoolize}
66 %{__aclocal}
67 %{__autoheader}
68 %{__automake}
69 %{__autoconf}
70 %configure \
71         %{!?with_xft: --without-xft} \
72         %{!?with_gnome_print: --without-gnome-print} \
73         %{?with_gnome_print: --with-gnome-print} \
74         %{!?with_mmx:--disable-mmx} \
75         %{?with_relocation:--enable-binreloc} \
76         %{?with_inkboard:--enable-inkboard} \
77         --disable-static
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %find_lang %{name}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92
93 %post
94 umask 022
95 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
96 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
97
98 %postun
99 umask 022
100 update-mime-database %{_datadir}/mime >/dev/null 2>&1
101 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc AUTHORS ChangeLog NEWS README TRANSLATORS
106 %lang(ca) %doc README.ca.txt
107 %lang(de) %doc README.de.txt
108 %lang(es) %doc README.es.txt
109 %lang(fr) %doc README.fr.txt
110 %lang(it) %doc README.it.txt
111 %attr(755,root,root) %{_bindir}/*
112 %dir %{_datadir}/inkscape
113 %{_datadir}/inkscape/[!e]*
114 %{_datadir}/inkscape/examples
115 %dir %{_datadir}/inkscape/extensions
116 %{_datadir}/inkscape/extensions/*.inx
117 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
118 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
119 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
120 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
121 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
122 %{_mandir}/man1/*
123 %lang(fr) %{_mandir}/fr/man1/*
124 %{_pixmapsdir}/*.png
125 %{_desktopdir}/*.desktop
This page took 0.059251 seconds and 4 git commands to generate.