]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- BR gtkmm-devel up to >= 2.10.0
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.46
16 Release:        3
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  3bae9034047379012127e52f9b138d32
21 Patch1:         %{name}-desktop.patch
22 URL:            http://www.inkscape.org/
23 BuildRequires:  autoconf >= 2.59-3
24 BuildRequires:  automake >= 1:1.9.4-2
25 BuildRequires:  boost-devel >= 1.35.0
26 BuildRequires:  freetype-devel >= 2.0
27 BuildRequires:  gcc-c++ >= 6:4.2.2-2
28 BuildRequires:  gc-devel >= 6.4
29 BuildRequires:  gettext-devel
30 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
31 BuildRequires:  gtk+2-devel >= 2:2.9.4
32 BuildRequires:  gtkmm-devel >= 2.10.0
33 BuildRequires:  gtkspell-devel >= 2.0.11
34 BuildRequires:  intltool >= 0.35.0
35 BuildRequires:  lcms-devel >= 1.15
36 BuildRequires:  libart_lgpl-devel >= 2.3.10
37 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
38 BuildRequires:  libpng-devel >= 1.2
39 BuildRequires:  libsigc++-devel >= 2.0.17
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.26
42 BuildRequires:  libxslt-devel >= 1.1.17
43 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
44 BuildRequires:  pkgconfig
45 BuildRequires:  popt-devel
46 BuildRequires:  rpm-pythonprov
47 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
48 BuildRequires:  zlib-devel
49 Requires(post,postun):  shared-mime-info
50 Requires:       gc >= 6.4
51 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
52 Requires:       gtk+2 >= 2:2.9.4
53 Requires:       perl-XML-XQL
54 Suggests:       python-lxml
55 # sr@Latn vs. sr@latin
56 Conflicts:      glibc-misc < 6:2.7
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Inkscape is a program for viewing, making, and editing two-dimensional
61 vector drawings.
62
63 %description -l pl.UTF-8
64 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
65 dwuwymiarowej grafiki wektorowej.
66
67 %prep
68 %setup -q
69 %patch1 -p1
70 rm -f po/ca@valencia.po
71 rm -f po/en_US@piglatin.po
72 sed -i -e 's|ca@valencia||' configure.ac
73 sed -i -e 's|en_US@piglatin||' configure.ac
74
75 %build
76 %{__libtoolize}
77 %{__glib_gettextize}
78 %{__intltoolize}
79 %{__aclocal}
80 %{__autoheader}
81 %{__automake}
82 %{__autoconf}
83 %configure \
84         %{!?with_xft: --without-xft} \
85         %{!?with_gnomeprint:--without-gnome-print} \
86         %{?with_gnomeprint:--with-gnome-print} \
87         %{!?with_gnomevfs:--without-gnome-vfs} \
88         %{!?with_mmx:--disable-mmx} \
89         %{?with_relocation:--enable-binreloc} \
90         %{?with_inkboard:--enable-inkboard} \
91         --disable-static
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
102         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
103 %find_lang %{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108
109 %post
110 umask 022
111 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
112 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
113
114 %postun
115 umask 022
116 update-mime-database %{_datadir}/mime >/dev/null 2>&1
117 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
122 %lang(ca) %doc README.ca.txt
123 %lang(de) %doc README.de.txt
124 %lang(es) %doc README.es.txt
125 %lang(fr) %doc README.fr.txt
126 %lang(it) %doc README.it.txt
127 %lang(de) %doc HACKING.de.txt
128 %lang(fr) %doc HACKING.fr.txt
129 %lang(it) %doc HACKING.it.txt
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_datadir}/inkscape
132 %{_datadir}/inkscape/[!e]*
133 %{_datadir}/inkscape/examples
134 %dir %{_datadir}/inkscape/extensions
135 %{_datadir}/inkscape/extensions/*.cmd
136 %{_datadir}/inkscape/extensions/*.inx
137 %{_datadir}/inkscape/extensions/*.txt
138 %{_datadir}/inkscape/extensions/*.xml
139 %{_datadir}/inkscape/extensions/*.xsl
140 %{_datadir}/inkscape/extensions/*.xslt
141 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
142 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
143 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
144 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
145 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
146 %dir %{_datadir}/inkscape/extensions/Barcode
147 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
148 %dir %{_datadir}/inkscape/extensions/xaml2svg
149 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
150 %{_mandir}/man1/*
151 %lang(fr) %{_mandir}/fr/man1/*
152 %{_pixmapsdir}/*.png
153 %{_desktopdir}/*.desktop
This page took 0.065384 seconds and 4 git commands to generate.