]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- rel. 5
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.46
16 Release:        5
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  3bae9034047379012127e52f9b138d32
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-poppler.patch
23 Patch2:         %{name}-gcc43.patch
24 Patch3:         %{name}-gtk2.patch
25 URL:            http://www.inkscape.org/
26 BuildRequires:  autoconf >= 2.59-3
27 BuildRequires:  automake >= 1:1.9.4-2
28 BuildRequires:  boost-devel >= 1.35.0
29 BuildRequires:  freetype-devel >= 2.0
30 BuildRequires:  gcc-c++ >= 6:4.2.2-2
31 BuildRequires:  gc-devel >= 6.4
32 BuildRequires:  gettext-devel
33 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
34 BuildRequires:  gtk+2-devel >= 2:2.9.4
35 BuildRequires:  gtkmm-devel >= 2.10.0
36 BuildRequires:  gtkspell-devel >= 2.0.11
37 BuildRequires:  intltool >= 0.35.0
38 BuildRequires:  lcms-devel >= 1.15
39 BuildRequires:  libart_lgpl-devel >= 2.3.10
40 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
41 BuildRequires:  libpng-devel >= 1.2
42 BuildRequires:  libsigc++-devel >= 2.0.17
43 BuildRequires:  libtool
44 BuildRequires:  libxml2-devel >= 1:2.6.26
45 BuildRequires:  libxslt-devel >= 1.1.17
46 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
47 BuildRequires:  pkgconfig
48 BuildRequires:  popt-devel
49 BuildRequires:  rpm-pythonprov
50 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
51 BuildRequires:  zlib-devel
52 Requires(post,postun):  shared-mime-info
53 Requires:       gc >= 6.4
54 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
55 Requires:       gtk+2 >= 2:2.9.4
56 Requires:       perl-XML-XQL
57 Suggests:       python-lxml
58 # sr@Latn vs. sr@latin
59 Conflicts:      glibc-misc < 6:2.7
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Inkscape is a program for viewing, making, and editing two-dimensional
64 vector drawings.
65
66 %description -l pl.UTF-8
67 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
68 dwuwymiarowej grafiki wektorowej.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76
77 rm -f po/ca@valencia.po
78 rm -f po/en_US@piglatin.po
79 sed -i -e 's|ca@valencia||' configure.ac
80 sed -i -e 's|en_US@piglatin||' configure.ac
81
82 %build
83 %{__libtoolize}
84 %{__glib_gettextize}
85 %{__intltoolize}
86 %{__aclocal}
87 %{__autoheader}
88 %{__automake}
89 %{__autoconf}
90 %configure \
91         %{!?with_xft: --without-xft} \
92         %{!?with_gnomeprint:--without-gnome-print} \
93         %{?with_gnomeprint:--with-gnome-print} \
94         %{!?with_gnomevfs:--without-gnome-vfs} \
95         %{!?with_mmx:--disable-mmx} \
96         %{?with_relocation:--enable-binreloc} \
97         %{?with_inkboard:--enable-inkboard} \
98         --disable-static
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
109         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115
116 %post
117 umask 022
118 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
119 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
120
121 %postun
122 umask 022
123 update-mime-database %{_datadir}/mime >/dev/null 2>&1
124 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
129 %lang(ca) %doc README.ca.txt
130 %lang(de) %doc README.de.txt
131 %lang(es) %doc README.es.txt
132 %lang(fr) %doc README.fr.txt
133 %lang(it) %doc README.it.txt
134 %lang(de) %doc HACKING.de.txt
135 %lang(fr) %doc HACKING.fr.txt
136 %lang(it) %doc HACKING.it.txt
137 %attr(755,root,root) %{_bindir}/*
138 %dir %{_datadir}/inkscape
139 %{_datadir}/inkscape/[!e]*
140 %{_datadir}/inkscape/examples
141 %dir %{_datadir}/inkscape/extensions
142 %{_datadir}/inkscape/extensions/*.cmd
143 %{_datadir}/inkscape/extensions/*.inx
144 %{_datadir}/inkscape/extensions/*.txt
145 %{_datadir}/inkscape/extensions/*.xml
146 %{_datadir}/inkscape/extensions/*.xsl
147 %{_datadir}/inkscape/extensions/*.xslt
148 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
149 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
150 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
151 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
152 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
153 %dir %{_datadir}/inkscape/extensions/Barcode
154 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
155 %dir %{_datadir}/inkscape/extensions/xaml2svg
156 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
157 %{_mandir}/man1/*
158 %lang(fr) %{_mandir}/fr/man1/*
159 %{_pixmapsdir}/*.png
160 %{_desktopdir}/*.desktop
This page took 0.098437 seconds and 4 git commands to generate.