]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- release 12 (by relup.sh)
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.48.4
19 Release:        12
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 Source0:        http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  47bd8546e42ba396624eef9eb66b9b6c
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-ldl.patch
26 Patch1:         %{name}-0.48.2-types.patch
27 Patch2:         %{name}-build.patch
28 Patch3:         %{name}-poppler-0.26.patch
29 URL:            http://www.inkscape.org/
30 BuildRequires:  ImageMagick-c++-devel
31 BuildRequires:  aspell-devel
32 BuildRequires:  autoconf >= 2.59-3
33 BuildRequires:  automake >= 1:1.9.4-2
34 BuildRequires:  boost-devel >= 1.36
35 BuildRequires:  cairo-devel >= 1.8.0
36 BuildRequires:  freetype-devel >= 2.0
37 BuildRequires:  gc-devel >= 6.4
38 BuildRequires:  gettext-tools
39 BuildRequires:  glibmm-devel >= 2.16.0
40 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
41 BuildRequires:  gsl-devel
42 BuildRequires:  gtk+2-devel >= 2:2.14.0
43 BuildRequires:  gtkmm-devel >= 2.10.0
44 BuildRequires:  gtkspell-devel >= 2.0.11
45 BuildRequires:  intltool >= 0.35.0
46 BuildRequires:  lcms2-devel >= 2
47 BuildRequires:  libgomp-devel
48 BuildRequires:  libpng-devel >= 1.2
49 BuildRequires:  libsigc++-devel >= 2.0.17
50 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
51 BuildRequires:  libtool
52 BuildRequires:  libwpd-devel >= 0.9
53 BuildRequires:  libwpg-devel >= 0.2
54 BuildRequires:  libxml2-devel >= 1:2.6.26
55 BuildRequires:  libxslt-devel >= 1.1.17
56 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
57 BuildRequires:  pkgconfig
58 BuildRequires:  poppler-glib-devel >= 0.20.0
59 BuildRequires:  popt-devel
60 BuildRequires:  rpm-pythonprov
61 BuildRequires:  sed >= 4.0
62 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
63 BuildRequires:  zlib-devel
64 Requires(post,postun):  desktop-file-utils
65 Requires:       cairo >= 1.8.0
66 Requires:       gc >= 6.4
67 Requires:       glibmm >= 2.16.0
68 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
69 Requires:       gtk+2 >= 2:2.14.0
70 Requires:       gtkmm >= 2.24.0
71 Requires:       gtkspell >= 2.0.11
72 Requires:       libsigc++ >= 2.0.17
73 Requires:       libxml2 >= 1:2.6.26
74 Requires:       libxslt >= 1.1.17
75 Requires:       perl-XML-XQL
76 Requires:       poppler-glib >= 0.20.0
77 Suggests:       python-lxml
78 # sr@Latn vs. sr@latin
79 Conflicts:      glibc-misc < 6:2.7
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Inkscape is a program for viewing, making, and editing two-dimensional
84 vector drawings.
85
86 %description -l pl.UTF-8
87 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
88 dwuwymiarowej grafiki wektorowej.
89
90 %prep
91 %setup -q -n %{name}-%{version}%{beta}
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p0
96
97 %{__rm} po/en_US@piglatin.po
98 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
99
100 mv po/te_IN.po po/te.po
101 %{__sed} -i -e 's|te_IN|te|' configure.ac
102
103 %build
104 %{__libtoolize}
105 %{__glib_gettextize}
106 %{__intltoolize}
107 %{__aclocal}
108 %{__autoheader}
109 %{__automake}
110 %{__autoconf}
111 %configure \
112         --disable-silent-rules \
113         %{!?with_xft: --without-xft} \
114         %{!?with_gnomevfs:--without-gnome-vfs} \
115         %{!?with_mmx:--disable-mmx} \
116         %{?with_relocation:--enable-binreloc} \
117         %{?with_inkboard:--enable-inkboard}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %find_lang %{name}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132
133 %post
134 %update_desktop_database_post
135
136 %postun
137 %update_desktop_database_postun
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
142 %lang(ca) %doc README.ca.txt
143 %lang(de) %doc README.de.txt
144 %lang(es) %doc README.es.txt
145 %lang(fr) %doc README.fr.txt
146 %lang(it) %doc README.it.txt
147 %lang(pt_BR) %doc README.it.txt
148 %lang(sk) %doc README.it.txt
149 %lang(sr) %doc README.it.txt
150 %lang(de) %doc doc/HACKING.de.txt
151 %lang(fr) %doc doc/HACKING.fr.txt
152 %lang(it) %doc doc/HACKING.it.txt
153 %lang(pt_BR) %doc doc/HACKING.it.txt
154 %attr(755,root,root) %{_bindir}/inkscape
155 %attr(755,root,root) %{_bindir}/inkview
156 %dir %{_datadir}/inkscape
157 %{_datadir}/inkscape/[!e]*
158 %{_datadir}/inkscape/examples
159 %dir %{_datadir}/inkscape/extensions
160 %{_datadir}/inkscape/extensions/Poly3DObjects/
161 %{_datadir}/inkscape/extensions/alphabet_soup/
162 %{_datadir}/inkscape/extensions/*.inx
163 %{_datadir}/inkscape/extensions/*.js
164 %{_datadir}/inkscape/extensions/*.xml
165 %{_datadir}/inkscape/extensions/*.xsl
166 %{_datadir}/inkscape/extensions/*.xslt
167 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
168 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
169 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
170 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
171 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
172 %dir %{_datadir}/inkscape/extensions/Barcode
173 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
174 %dir %{_datadir}/inkscape/extensions/xaml2svg
175 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
176 %{_mandir}/man1/*.1*
177 %lang(el) %{_mandir}/el/man1/*.1*
178 %lang(fr) %{_mandir}/fr/man1/*.1*
179 %lang(ja) %{_mandir}/ja/man1/*.1*
180 %lang(sk) %{_mandir}/sk/man1/*.1*
181 %lang(zh_TW) %{_mandir}/zh_TW/man1/*.1*
182 %{_iconsdir}/hicolor/*/apps/inkscape.png
183 %{_desktopdir}/inkscape.desktop
This page took 0.059553 seconds and 4 git commands to generate.