]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- added -gcc45.patch (from Gentoo) and -ldl.patch
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.47
19 Release:        5
20 License:        GPL v2, LGPL v2.1
21 Group:          X11/Applications/Graphics
22 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  7b497c8f673e40b05295a29f6e2111f4
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-poppler.patch
26 Patch1:         %{name}-gcc45.patch
27 Patch2:         %{name}-ldl.patch
28 URL:            http://www.inkscape.org/
29 BuildRequires:  ImageMagick-c++-devel
30 BuildRequires:  aspell-devel
31 BuildRequires:  autoconf >= 2.59-3
32 BuildRequires:  automake >= 1:1.9.4-2
33 BuildRequires:  boost-devel >= 1.35.0
34 BuildRequires:  cairo-devel >= 1.8.0
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  gcc-c++ >= 6:4.2.2-2
37 BuildRequires:  gc-devel >= 6.4
38 BuildRequires:  gettext-devel
39 BuildRequires:  glibmm-devel >= 2.16.0
40 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
41 BuildRequires:  gtk+2-devel >= 2:2.14.0
42 BuildRequires:  gtkmm-devel >= 2.10.0
43 BuildRequires:  gtkspell-devel >= 2.0.11
44 BuildRequires:  gsl-devel
45 BuildRequires:  intltool >= 0.35.0
46 BuildRequires:  lcms-devel >= 1.15
47 BuildRequires:  libpng-devel >= 1.2
48 BuildRequires:  libsigc++-devel >= 2.0.17
49 BuildRequires:  libtool
50 BuildRequires:  libxml2-devel >= 1:2.6.26
51 BuildRequires:  libxslt-devel >= 1.1.17
52 BuildRequires:  libwpg-devel
53 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
54 BuildRequires:  pkgconfig
55 BuildRequires:  poppler-glib-devel >= 0.12.2
56 BuildRequires:  popt-devel
57 BuildRequires:  rpm-pythonprov
58 BuildRequires:  sed >= 4.0
59 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
60 BuildRequires:  zlib-devel
61 Requires(post,postun):  desktop-file-utils
62 Requires:       gc >= 6.4
63 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
64 Requires:       gtk+2 >= 2:2.14.0
65 Requires:       perl-XML-XQL
66 Suggests:       python-lxml
67 # sr@Latn vs. sr@latin
68 Conflicts:      glibc-misc < 6:2.7
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Inkscape is a program for viewing, making, and editing two-dimensional
73 vector drawings.
74
75 %description -l pl.UTF-8
76 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
77 dwuwymiarowej grafiki wektorowej.
78
79 %prep
80 %setup -q -n %{name}-%{version}%{beta}
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84
85 rm -f po/en_US@piglatin.po
86 sed -i -e 's|en_US@piglatin||' configure.ac
87
88 %build
89 %{__libtoolize}
90 %{__glib_gettextize}
91 %{__intltoolize}
92 %{__aclocal}
93 %{__autoheader}
94 %{__automake}
95 %{__autoconf}
96 %configure \
97         %{!?with_xft: --without-xft} \
98         %{!?with_gnomevfs:--without-gnome-vfs} \
99         %{!?with_mmx:--disable-mmx} \
100         %{?with_relocation:--enable-binreloc} \
101         %{?with_inkboard:--enable-inkboard}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %find_lang %{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116
117 %post
118 %update_desktop_database_post
119
120 %postun
121 %update_desktop_database_postun
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
126 %lang(ca) %doc README.ca.txt
127 %lang(de) %doc README.de.txt
128 %lang(es) %doc README.es.txt
129 %lang(fr) %doc README.fr.txt
130 %lang(it) %doc README.it.txt
131 %lang(de) %doc HACKING.de.txt
132 %lang(fr) %doc HACKING.fr.txt
133 %lang(it) %doc HACKING.it.txt
134 %attr(755,root,root) %{_bindir}/inkscape
135 %attr(755,root,root) %{_bindir}/inkview
136 %dir %{_datadir}/inkscape
137 %{_datadir}/inkscape/[!e]*
138 %{_datadir}/inkscape/examples
139 %dir %{_datadir}/inkscape/extensions
140 %{_datadir}/inkscape/extensions/Poly3DObjects/
141 %{_datadir}/inkscape/extensions/alphabet_soup/
142 %{_datadir}/inkscape/extensions/*.inx
143 %{_datadir}/inkscape/extensions/*.js
144 %{_datadir}/inkscape/extensions/*.xml
145 %{_datadir}/inkscape/extensions/*.xsl
146 %{_datadir}/inkscape/extensions/*.xslt
147 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
148 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
149 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
150 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
151 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
152 %dir %{_datadir}/inkscape/extensions/Barcode
153 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
154 %dir %{_datadir}/inkscape/extensions/xaml2svg
155 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
156 %{_mandir}/man1/*.1*
157 %lang(fr) %{_mandir}/fr/man1/*.1*
158 %{_pixmapsdir}/*.png
159 %{_desktopdir}/inkscape.desktop
This page took 0.094388 seconds and 4 git commands to generate.