]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- release 13 (by relup.sh)
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.48.2
19 Release:        13
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 Source0:        http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  f60b98013bd1121b2cc301f3485076ba
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-ldl.patch
26 Patch1:         %{name}-0.48.2-types.patch
27 Patch2:         %{name}-0.48.2-glib.patch
28 Patch3:         %{name}-0.48.2-png.patch
29 Patch4:         %{name}-0.48.2-png-write.patch
30 Patch5:         %{name}-0.48.2-gcc47.patch
31 Patch6:         %{name}-0.48.2-poppler_020.patch
32 URL:            http://www.inkscape.org/
33 BuildRequires:  ImageMagick-c++-devel
34 BuildRequires:  aspell-devel
35 BuildRequires:  autoconf >= 2.59-3
36 BuildRequires:  automake >= 1:1.9.4-2
37 BuildRequires:  boost-devel >= 1.35.0
38 BuildRequires:  cairo-devel >= 1.8.0
39 BuildRequires:  freetype-devel >= 2.0
40 BuildRequires:  gc-devel >= 6.4
41 BuildRequires:  gettext-devel
42 BuildRequires:  glibmm-devel >= 2.16.0
43 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
44 BuildRequires:  gsl-devel
45 BuildRequires:  gtk+2-devel >= 2:2.14.0
46 BuildRequires:  gtkmm-devel >= 2.10.0
47 BuildRequires:  gtkspell-devel >= 2.0.11
48 BuildRequires:  intltool >= 0.35.0
49 BuildRequires:  lcms-devel >= 1.15
50 BuildRequires:  libpng-devel >= 1.2
51 BuildRequires:  libsigc++-devel >= 2.0.17
52 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
53 BuildRequires:  libtool
54 BuildRequires:  libwpg-devel
55 BuildRequires:  libxml2-devel >= 1:2.6.26
56 BuildRequires:  libxslt-devel >= 1.1.17
57 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
58 BuildRequires:  pkgconfig
59 BuildRequires:  poppler-glib-devel >= 0.12.2
60 BuildRequires:  popt-devel
61 BuildRequires:  rpm-pythonprov
62 BuildRequires:  sed >= 4.0
63 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
64 BuildRequires:  zlib-devel
65 Requires(post,postun):  desktop-file-utils
66 Requires:       gc >= 6.4
67 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
68 Requires:       gtk+2 >= 2:2.14.0
69 Requires:       perl-XML-XQL
70 Suggests:       python-lxml
71 # sr@Latn vs. sr@latin
72 Conflicts:      glibc-misc < 6:2.7
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 Inkscape is a program for viewing, making, and editing two-dimensional
77 vector drawings.
78
79 %description -l pl.UTF-8
80 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
81 dwuwymiarowej grafiki wektorowej.
82
83 %prep
84 %setup -q -n %{name}-%{version}%{beta}
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88 %patch3 -p0
89 %patch4 -p0
90 %patch5 -p0
91 %patch6 -p1
92
93 %{__rm} po/en_US@piglatin.po
94 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
95
96 mv po/te_IN.po po/te.po
97 %{__sed} -i -e 's|te_IN|te|' configure.ac
98
99 %build
100 %{__libtoolize}
101 %{__glib_gettextize}
102 %{__intltoolize}
103 %{__aclocal}
104 %{__autoheader}
105 %{__automake}
106 %{__autoconf}
107 %configure \
108         --disable-silent-rules \
109         %{!?with_xft: --without-xft} \
110         %{!?with_gnomevfs:--without-gnome-vfs} \
111         %{!?with_mmx:--disable-mmx} \
112         %{?with_relocation:--enable-binreloc} \
113         %{?with_inkboard:--enable-inkboard}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128
129 %post
130 %update_desktop_database_post
131
132 %postun
133 %update_desktop_database_postun
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
138 %lang(ca) %doc README.ca.txt
139 %lang(de) %doc README.de.txt
140 %lang(es) %doc README.es.txt
141 %lang(fr) %doc README.fr.txt
142 %lang(it) %doc README.it.txt
143 %lang(de) %doc doc/HACKING.de.txt
144 %lang(fr) %doc doc/HACKING.fr.txt
145 %lang(it) %doc doc/HACKING.it.txt
146 %attr(755,root,root) %{_bindir}/inkscape
147 %attr(755,root,root) %{_bindir}/inkview
148 %dir %{_datadir}/inkscape
149 %{_datadir}/inkscape/[!e]*
150 %{_datadir}/inkscape/examples
151 %dir %{_datadir}/inkscape/extensions
152 %{_datadir}/inkscape/extensions/Poly3DObjects/
153 %{_datadir}/inkscape/extensions/alphabet_soup/
154 %{_datadir}/inkscape/extensions/*.inx
155 %{_datadir}/inkscape/extensions/*.js
156 %{_datadir}/inkscape/extensions/*.xml
157 %{_datadir}/inkscape/extensions/*.xsl
158 %{_datadir}/inkscape/extensions/*.xslt
159 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
160 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
161 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
162 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
163 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
164 %dir %{_datadir}/inkscape/extensions/Barcode
165 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
166 %dir %{_datadir}/inkscape/extensions/xaml2svg
167 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
168 %{_mandir}/man1/*.1*
169 %lang(fr) %{_mandir}/fr/man1/*.1*
170 %{_iconsdir}/hicolor/*/apps/inkscape.png
171 %{_desktopdir}/inkscape.desktop
This page took 0.091542 seconds and 4 git commands to generate.