]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- fix extensions
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_without  xft             # Don't use xft scalable font database
4 %bcond_without  gnome_print     # Don't use gnome print font database and spooler frontend
5 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
6 %bcond_with     relocation      # Enable binary relocation support
7 #
8 Summary:        Scalable vector graphics editor
9 Summary(pl):    Edytor skalowalnej grafiki wektorowej
10 Name:           inkscape
11 Version:        0.42
12 Release:        2
13 License:        GPL v2, LGPL v2.1
14 Group:          Applications/Graphics
15 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
16 # Source0-md5:  4af587b942647bf9e27861e2238844c8
17 URL:            http://www.inkscape.org/
18 BuildRequires:  autoconf >= 2.59-3
19 BuildRequires:  automake >= 1:1.9.4-2
20 BuildRequires:  freetype-devel >= 2.0
21 BuildRequires:  gc-devel >= 6.4
22 BuildRequires:  gtk+2-devel >= 2:2.4.0
23 BuildRequires:  gtkmm-devel >= 2.4
24 BuildRequires:  gtkspell-devel
25 BuildRequires:  intltool
26 BuildRequires:  libart_lgpl-devel >= 2.3.10
27 %{?with_gnome_print:BuildRequires:      libgnomeprintui-devel >= 1.116.0}
28 BuildRequires:  libpng-devel
29 BuildRequires:  libsigc++-devel >= 2.0.3
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel >= 2.4.24
32 BuildRequires:  libxslt-devel >= 1.0.15
33 BuildRequires:  pkgconfig
34 BuildRequires:  popt-devel
35 %{?with_xft:BuildRequires:      xft-devel}
36 Requires(post,postun):  shared-mime-info
37 Requires:       gc >= 6.4
38 Requires:       gtk+2 >= 2:2.4.0
39 Requires:       perl-XML-XQL
40 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Inkscape is a program for viewing, making, and editing two-dimensional
44 vector drawings.
45
46 %description -l pl
47 Inkscape jest programem do przeglĀ±dania, tworzenia i edycji
48 dwuwymiarowej grafiki wektorowej.
49
50 %prep
51 %setup -q
52
53 %build
54 cp -f /usr/share/automake/mkinstalldirs .
55 %{__libtoolize}
56 glib-gettextize --copy --force
57 intltoolize --copy --force --automake
58 %{__aclocal}
59 %{__autoheader}
60 %{__automake}
61 %{__autoconf}
62 %configure \
63         %{!?with_xft: --without-xft}\
64         %{!?with_gnome_print: --without-gnome-print}\
65         %{?with_gnome_print: --with-gnome-print}\
66         %{!?with_mmx:--disable-mmx} \
67         %{?with_relocation:--enable-binreloc} \
68         --disable-static
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %find_lang %{name}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 umask 022
85 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
86 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
87
88 %postun
89 umask 022
90 update-mime-database %{_datadir}/mime >/dev/null 2>&1
91 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
92
93 %files -f %{name}.lang
94 %defattr(644,root,root,755)
95 %doc AUTHORS ChangeLog README
96 %attr(755,root,root) %{_bindir}/*
97 %dir %{_datadir}/inkscape
98 %{_datadir}/inkscape/[!e]*
99 %{_datadir}/inkscape/examples
100 %dir %{_datadir}/inkscape/extensions
101 %{_datadir}/inkscape/extensions/*.inx
102 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
103 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
104 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
105 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
106 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
107 %{_mandir}/man1/*
108 %lang(fr) %{_mandir}/fr/man1/*
109 %{_pixmapsdir}/*.png
110 %{_desktopdir}/*.desktop
This page took 0.062278 seconds and 4 git commands to generate.