]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- fix build with poppler 0.16
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.48.0
19 Release:        8
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 Source0:        http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  fd8b17a3f06668603807176a77167bb9
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-ldl.patch
26 Patch1:         %{name}-poppler-0.16.patch
27 URL:            http://www.inkscape.org/
28 BuildRequires:  ImageMagick-c++-devel
29 BuildRequires:  aspell-devel
30 BuildRequires:  autoconf >= 2.59-3
31 BuildRequires:  automake >= 1:1.9.4-2
32 BuildRequires:  boost-devel >= 1.35.0
33 BuildRequires:  cairo-devel >= 1.8.0
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  gc-devel >= 6.4
36 BuildRequires:  gettext-devel
37 BuildRequires:  glibmm-devel >= 2.16.0
38 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
39 BuildRequires:  gsl-devel
40 BuildRequires:  gtk+2-devel >= 2:2.14.0
41 BuildRequires:  gtkmm-devel >= 2.10.0
42 BuildRequires:  gtkspell-devel >= 2.0.11
43 BuildRequires:  intltool >= 0.35.0
44 BuildRequires:  lcms-devel >= 1.15
45 BuildRequires:  libpng-devel >= 1.2
46 BuildRequires:  libsigc++-devel >= 2.0.17
47 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
48 BuildRequires:  libtool
49 BuildRequires:  libwpg-devel
50 BuildRequires:  libxml2-devel >= 1:2.6.26
51 BuildRequires:  libxslt-devel >= 1.1.17
52 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
53 BuildRequires:  pkgconfig
54 BuildRequires:  poppler-glib-devel >= 0.12.2
55 BuildRequires:  popt-devel
56 BuildRequires:  rpm-pythonprov
57 BuildRequires:  sed >= 4.0
58 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
59 BuildRequires:  zlib-devel
60 Requires(post,postun):  desktop-file-utils
61 Requires:       gc >= 6.4
62 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
63 Requires:       gtk+2 >= 2:2.14.0
64 Requires:       perl-XML-XQL
65 Suggests:       python-lxml
66 # sr@Latn vs. sr@latin
67 Conflicts:      glibc-misc < 6:2.7
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 Inkscape is a program for viewing, making, and editing two-dimensional
72 vector drawings.
73
74 %description -l pl.UTF-8
75 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
76 dwuwymiarowej grafiki wektorowej.
77
78 %prep
79 %setup -q -n %{name}-%{version}%{beta}
80 %patch0 -p1
81 %patch1 -p1
82
83 rm -f po/en_US@piglatin.po
84 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
85
86 mv po/te_IN.po po/te.po
87 %{__sed} -i -e 's|te_IN|te|' configure.ac
88
89 %build
90 %{__libtoolize}
91 %{__glib_gettextize}
92 %{__intltoolize}
93 %{__aclocal}
94 %{__autoheader}
95 %{__automake}
96 %{__autoconf}
97 %configure \
98         %{!?with_xft: --without-xft} \
99         %{!?with_gnomevfs:--without-gnome-vfs} \
100         %{!?with_mmx:--disable-mmx} \
101         %{?with_relocation:--enable-binreloc} \
102         %{?with_inkboard:--enable-inkboard}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %find_lang %{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117
118 %post
119 %update_desktop_database_post
120
121 %postun
122 %update_desktop_database_postun
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
127 %lang(ca) %doc README.ca.txt
128 %lang(de) %doc README.de.txt
129 %lang(es) %doc README.es.txt
130 %lang(fr) %doc README.fr.txt
131 %lang(it) %doc README.it.txt
132 %lang(de) %doc doc/HACKING.de.txt
133 %lang(fr) %doc doc/HACKING.fr.txt
134 %lang(it) %doc doc/HACKING.it.txt
135 %attr(755,root,root) %{_bindir}/inkscape
136 %attr(755,root,root) %{_bindir}/inkview
137 %dir %{_datadir}/inkscape
138 %{_datadir}/inkscape/[!e]*
139 %{_datadir}/inkscape/examples
140 %dir %{_datadir}/inkscape/extensions
141 %{_datadir}/inkscape/extensions/Poly3DObjects/
142 %{_datadir}/inkscape/extensions/alphabet_soup/
143 %{_datadir}/inkscape/extensions/*.inx
144 %{_datadir}/inkscape/extensions/*.js
145 %{_datadir}/inkscape/extensions/*.xml
146 %{_datadir}/inkscape/extensions/*.xsl
147 %{_datadir}/inkscape/extensions/*.xslt
148 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
149 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
150 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
151 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
152 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
153 %dir %{_datadir}/inkscape/extensions/Barcode
154 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
155 %dir %{_datadir}/inkscape/extensions/xaml2svg
156 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
157 %{_mandir}/man1/*.1*
158 %lang(fr) %{_mandir}/fr/man1/*.1*
159 %{_iconsdir}/hicolor/*/apps/inkscape.png
160 %{_desktopdir}/inkscape.desktop
This page took 0.079422 seconds and 4 git commands to generate.