]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- require newest gcc (fixes blur)
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomeprint      # Don't use gnome print font database and spooler frontend
7 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
8 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
9 %bcond_with     inkboard        # Enable inkboard support
10 %bcond_with     relocation      # Enable binary relocation support
11 #
12 Summary:        Scalable vector graphics editor
13 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
14 Name:           inkscape
15 Version:        0.45.1
16 Release:        3
17 License:        GPL v2, LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/inkscape/%{name}-%{version}.tar.gz
20 # Source0-md5:  1ac63dfd5d78a676599bf5cf6d22e493
21 Patch0:         %{name}-ac.patch
22 Patch1:         %{name}-desktop.patch
23 URL:            http://www.inkscape.org/
24 BuildRequires:  autoconf >= 2.59-3
25 BuildRequires:  automake >= 1:1.9.4-2
26 BuildRequires:  boost-any-devel
27 BuildRequires:  boost-bind-devel
28 BuildRequires:  freetype-devel >= 2.0
29 BuildRequires:  gcc-c++ >= 6:4.2.2-2
30 BuildRequires:  gc-devel >= 6.4
31 BuildRequires:  gettext-devel
32 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
33 BuildRequires:  gtk+2-devel >= 2:2.9.4
34 BuildRequires:  gtkmm-devel >= 2.4
35 BuildRequires:  gtkspell-devel >= 2.0.11
36 BuildRequires:  intltool >= 0.35.0
37 BuildRequires:  lcms-devel >= 1.15
38 BuildRequires:  libart_lgpl-devel >= 2.3.10
39 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel >= 2.12.1}
40 BuildRequires:  libpng-devel >= 1.2
41 BuildRequires:  libsigc++-devel >= 2.0.17
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.26
44 BuildRequires:  libxslt-devel >= 1.1.17
45 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
46 BuildRequires:  pkgconfig
47 BuildRequires:  popt-devel
48 BuildRequires:  rpm-pythonprov
49 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
50 BuildRequires:  zlib-devel
51 Requires(post,postun):  shared-mime-info
52 Requires:       gc >= 6.4
53 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
54 Requires:       gtk+2 >= 2:2.9.4
55 Requires:       perl-XML-XQL
56 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Inkscape is a program for viewing, making, and editing two-dimensional
60 vector drawings.
61
62 %description -l pl.UTF-8
63 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
64 dwuwymiarowej grafiki wektorowej.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70 rm -f po/en_US@piglatin.po
71 sed -i -e 's|en_US@piglatin||' configure.ac
72
73 %build
74 %{__libtoolize}
75 %{__glib_gettextize}
76 %{__intltoolize}
77 %{__aclocal}
78 %{__autoheader}
79 %{__automake}
80 %{__autoconf}
81 %configure \
82         %{!?with_xft: --without-xft} \
83         %{!?with_gnomeprint:--without-gnome-print} \
84         %{?with_gnomeprint:--with-gnome-print} \
85         %{!?with_gnomevfs:--without-gnome-vfs} \
86         %{!?with_mmx:--disable-mmx} \
87         %{?with_relocation:--enable-binreloc} \
88         %{?with_inkboard:--enable-inkboard} \
89         --disable-static
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %find_lang %{name}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104
105 %post
106 umask 022
107 update-mime-database %{_datadir}/mime >/dev/null 2>&1 ||:
108 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
109
110 %postun
111 umask 022
112 update-mime-database %{_datadir}/mime >/dev/null 2>&1
113 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog HACKING.txt NEWS README TRANSLATORS
118 %lang(ca) %doc README.ca.txt
119 %lang(de) %doc README.de.txt
120 %lang(es) %doc README.es.txt
121 %lang(fr) %doc README.fr.txt
122 %lang(it) %doc README.it.txt
123 %lang(de) %doc HACKING.de.txt
124 %lang(fr) %doc HACKING.fr.txt
125 %lang(it) %doc HACKING.it.txt
126 %attr(755,root,root) %{_bindir}/*
127 %dir %{_datadir}/inkscape
128 %{_datadir}/inkscape/[!e]*
129 %{_datadir}/inkscape/examples
130 %dir %{_datadir}/inkscape/extensions
131 %{_datadir}/inkscape/extensions/*.cmd
132 %{_datadir}/inkscape/extensions/*.inx
133 %{_datadir}/inkscape/extensions/*.txt
134 %{_datadir}/inkscape/extensions/*.xslt
135 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
136 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
137 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
138 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
139 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
140 %attr(755,root,root) %{_datadir}/inkscape/extensions/svg_dropshadow
141 %{_mandir}/man1/*
142 %lang(fr) %{_mandir}/fr/man1/*
143 %{_pixmapsdir}/*.png
144 %{_desktopdir}/*.desktop
This page took 0.056024 seconds and 4 git commands to generate.